summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-05-10 11:57:56 +0200
committerUlrich Müller <ulm@gentoo.org>2020-05-10 12:24:00 +0200
commit1bd3be25dcc2b45c43673525de5ce880dbda0012 (patch)
treeb00509f0669b62ad92a71e341b17ae76081a8377 /app-editors/fe
parentapp-emacs/d-mode: Fix compilation with Emacs 27. (diff)
downloadgentoo-1bd3be25dcc2b45c43673525de5ce880dbda0012.tar.gz
gentoo-1bd3be25dcc2b45c43673525de5ce880dbda0012.tar.bz2
gentoo-1bd3be25dcc2b45c43673525de5ce880dbda0012.zip
app-editors/fe: Call tc-getAR to determine the ar program.
Closes: https://bugs.gentoo.org/722036 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/fe')
-rw-r--r--app-editors/fe/fe-2.0.ebuild11
-rw-r--r--app-editors/fe/files/fe-2.0-ar.patch21
2 files changed, 30 insertions, 2 deletions
diff --git a/app-editors/fe/fe-2.0.ebuild b/app-editors/fe/fe-2.0.ebuild
index ca6658d94079..207e9ec3f773 100644
--- a/app-editors/fe/fe-2.0.ebuild
+++ b/app-editors/fe/fe-2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,10 @@ RDEPEND="sys-libs/ncurses:0=
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
-PATCHES=("${FILESDIR}"/${PN}-1.8-makefile.patch)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8-makefile.patch
+ "${FILESDIR}"/${P}-ar.patch
+)
src_configure() {
econf \
@@ -27,6 +30,10 @@ src_configure() {
LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
}
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_install() {
emake \
prefix="${D}"/usr \
diff --git a/app-editors/fe/files/fe-2.0-ar.patch b/app-editors/fe/files/fe-2.0-ar.patch
new file mode 100644
index 000000000000..8096400ab01e
--- /dev/null
+++ b/app-editors/fe/files/fe-2.0-ar.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/722036
+
+--- fe-2.0-orig/Makefile.in
++++ fe-2.0/Makefile.in
+@@ -15,6 +15,7 @@
+ CPPFLAGS= @CPPFLAGS@ -DLOCALEDIR=\"$(localedir)\"
+ LDFLAGS= @LDFLAGS@
+ LIBS= @LIBS@
++AR= ar
+
+ CATALOGS= de.mo
+ OBJS= buffer.o complete.o display.o macro.o misc.o msgline.o
+@@ -27,7 +28,7 @@
+ $(CC) -o $@ $(LDFLAGS) fe.o libfe.a $(LIBS)
+
+ libfe.a: $(OBJS)
+- rm -f $@; ar q $@ $(OBJS); @RANLIB@ $@
++ rm -f $@; $(AR) q $@ $(OBJS); @RANLIB@ $@
+
+ install-po: install-po-@USE_NLS@
+ install-po-no: