summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2018-10-08 21:44:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-27 17:54:34 +0200
commit0daf8ca5893c401522a3f5624e1e203efebfa185 (patch)
treeec4af7951967e38cb69160c73824b78833eedf84 /app-editors/ghostwriter
parentapp-arch/hardlink: restore DEPEND (diff)
downloadgentoo-0daf8ca5893c401522a3f5624e1e203efebfa185.tar.gz
gentoo-0daf8ca5893c401522a3f5624e1e203efebfa185.tar.bz2
gentoo-0daf8ca5893c401522a3f5624e1e203efebfa185.zip
app-editors/ghostwriter: verbump to 1.7.3
Closes: https://bugs.gentoo.org/668126 Closes: https://github.com/gentoo/gentoo/pull/10110 Signed-off-by: David Roman <davidroman96@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/ghostwriter')
-rw-r--r--app-editors/ghostwriter/Manifest1
-rw-r--r--app-editors/ghostwriter/ghostwriter-1.7.3.ebuild55
-rw-r--r--app-editors/ghostwriter/metadata.xml4
3 files changed, 60 insertions, 0 deletions
diff --git a/app-editors/ghostwriter/Manifest b/app-editors/ghostwriter/Manifest
index 6d871ce407cc..443e7970811c 100644
--- a/app-editors/ghostwriter/Manifest
+++ b/app-editors/ghostwriter/Manifest
@@ -1 +1,2 @@
DIST ghostwriter-1.5.0.tar.gz 620301 BLAKE2B 07af6c6b176f15a7b6bee0594936a346160783c553dfd91cd69bde3975ada5c125920c1029ab19aee21c89576c6fab311f7a893447c457ff5a174149e57f67bb SHA512 4b6e1430342069b224f7aece30d5a592a43e9f702cb93fc073fded741771ea74b8478203aeaecdabb791aa7ddd8055d5c36346518adc7dd19b61e5f2e2cbe219
+DIST ghostwriter-1.7.3.tar.gz 673328 BLAKE2B 5304f5218da5fe535dea1ed9d43c4358212d9b1025dcc7102a77852c833ba1301d59539df4e2a44fd8a46abe7dfbdc7c6ab490d3f9e8ed5f7b4571b604c3bbb6 SHA512 a6f7e64078bdb3ecd9ea48ead8e96811e62215292a1c4a269f23efb6c0403c62fb0aab3e1303397b08036a7f3507d04a8eb8c14baafd78f64fea20805bb24a5a
diff --git a/app-editors/ghostwriter/ghostwriter-1.7.3.ebuild b/app-editors/ghostwriter/ghostwriter-1.7.3.ebuild
new file mode 100644
index 000000000000..6988d84d5c15
--- /dev/null
+++ b/app-editors/ghostwriter/ghostwriter-1.7.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Cross-platform, aesthetic, distraction-free markdown editor"
+HOMEPAGE="https://wereturtle.github.io/ghostwriter/"
+SRC_URI="https://github.com/wereturtle/ghostwriter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ app-text/hunspell
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ dev-qt/qtconcurrent:5
+"
+
+DOCS=( CREDITS.md README.md )
+
+src_prepare() {
+ default
+
+ sed -i -e "/^VERSION =/s/\$.*/${PV}/" ghostwriter.pro || die "failed to override version"
+}
+
+src_configure() {
+ eqmake5 \
+ CONFIG+=$(usex debug debug release) \
+ PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/app-editors/ghostwriter/metadata.xml b/app-editors/ghostwriter/metadata.xml
index 960a05beff6a..f0f7966a74f1 100644
--- a/app-editors/ghostwriter/metadata.xml
+++ b/app-editors/ghostwriter/metadata.xml
@@ -5,6 +5,10 @@
<email>reagentoo@gmail.com</email>
<name>Dmitry Baranov</name>
</maintainer>
+ <maintainer type="person">
+ <email>davidroman96@gmail.com</email>
+ <name>David Roman</name>
+ </maintainer>
<maintainer type="project">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>