summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2020-12-08 20:58:26 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-12-15 09:18:01 +0200
commit4dd69ce3959999af0bbf9e268fbb032377f33e97 (patch)
tree480b09d9ed300e3e9f84cd72222ced43ed6ce426 /app-editors/vis
parentapp-admin/passwordsafe: remove old (diff)
downloadgentoo-4dd69ce3959999af0bbf9e268fbb032377f33e97.tar.gz
gentoo-4dd69ce3959999af0bbf9e268fbb032377f33e97.tar.bz2
gentoo-4dd69ce3959999af0bbf9e268fbb032377f33e97.zip
app-editors/vis: Version bump, 0.7
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/vis')
-rw-r--r--app-editors/vis/Manifest2
-rw-r--r--app-editors/vis/vis-0.7.ebuild75
-rw-r--r--app-editors/vis/vis-9999.ebuild2
3 files changed, 78 insertions, 1 deletions
diff --git a/app-editors/vis/Manifest b/app-editors/vis/Manifest
index 6258f1a7c753..fa478daedca6 100644
--- a/app-editors/vis/Manifest
+++ b/app-editors/vis/Manifest
@@ -1,4 +1,6 @@
DIST vis-0.5.tar.gz 390461 BLAKE2B e628891c48dbbd11ed706768a3c625ffe9edf4fea3cd77452b4b41ae0d50194a31647e4cc945b69fb3af8fe7fd76ebf5f7afd8c2baa356f5f9fd3cc04be129ca SHA512 fe6b0394006562177efdf06713d7b95cd12fabf90b171c262eb2620d2b0944e73d3d8bb61f4f0d43d32154f0490c338bbc161a89455b14bb8a9d22cd75097780
DIST vis-0.6.tar.gz 397707 BLAKE2B 9768f3d5586afd261f3e82721c08bdfddcd1c51a4f76d45c2f75eb954feed49d1ebeb1ee2cb31675cf68b356a0d32bcc33454aa2fbf0fd5c77afeea0a73465cd SHA512 3809b40f75816e03e47e0c2c16d2681cc1c01ad50a3d051285d5f1e9ff0a333160e668228a129a1596109aa079dc8364d3ad060b88e9dba33bb1d60a15eaf4e2
+DIST vis-0.7.tar.gz 403918 BLAKE2B 5e4930fdb14ed42a2daf6682a99107ee6eb59e99e348abab5262bdbc53956dd9ccd094695d7f53c6770d10e46b2812b0e07ff90184ff920790f5b95f4091a610 SHA512 ccc6a054fea6917e7751882468a74c30c712f7ec400a913c95c0084691f706e2bee54efb86b75be8b121c9a209c7e587e72e5474c55271d9943e91fc8aaf9bac
DIST vis-test-0.3.tar.gz 97814 BLAKE2B f62b216df3d846bb8bfdb14f6092309b55f6571cbc980e7a9aed46b1672fbaa65c007ac4617266dff3d5ad0293e3f5e7bd8390252817ebcdd6f64edb350f82ee SHA512 5f68a70cf6f1fb64f9b50c1a56940c966f205e51240c7dd1175bc15f3e42b475fb6842a53e36547113955c2efa359de0cc71e0800305b0e45881c319a14564e5
DIST vis-test-0.4.tar.gz 98703 BLAKE2B dc9df00ae97ecd58022f885b25cb8163dd8b86f93d95cf93bbe1bd1efcc7690393efc4d47e3dccedc5f0ac6c33519136e6f13e6b9b9707f870b421aa3101537e SHA512 446eea2fdb7b15fd4962901e2076649964981217b9cf47112f16d1404da7cc024ba4b13164df0afa763363cef4f82db4ad9d7283a7554aead2165f29ca0bc9a5
+DIST vis-test-0.5.tar.gz 99314 BLAKE2B 988d7e93d0f3c58d2fc8fbe9293049c6a3cc44dfcbfbd4f42f7992815cf33a604340b59171dcd880f7180ae56e3f73f46684b7aacd96438480db6c4592851f2c SHA512 c41b40f23a45a7ebd9c16aa853d9c3b517767cb88ff8dc268da44276a02aa8c77de0fc6aa243a1e4cdfbc27182870b82d0b9bc892bb87ea74d5275d76c554ed1
diff --git a/app-editors/vis/vis-0.7.ebuild b/app-editors/vis/vis-0.7.ebuild
new file mode 100644
index 000000000000..4d2ac5754f60
--- /dev/null
+++ b/app-editors/vis/vis-0.7.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PTV=0.5
+LUA_COMPAT=( lua5-2 lua5-3 lua5-4 )
+
+inherit lua-single optfeature
+
+DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor"
+HOMEPAGE="https://github.com/martanne/vis"
+SRC_URI="https://github.com/martanne/vis/releases/download/v${PV}/${P}.tar.gz
+ test? ( https://github.com/martanne/vis-test/releases/download/v${MY_PTV}/vis-test-${MY_PTV}.tar.gz )"
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+ncurses +lua selinux test tre"
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+# - Known to also work with NetBSD curses
+DEPEND="dev-libs/libtermkey
+ ncurses? ( sys-libs/ncurses:0= )
+ lua? ( ${LUA_DEPS} )
+ tre? ( dev-libs/tre:= )"
+RDEPEND="${DEPEND}
+ app-eselect/eselect-vi"
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+}
+
+src_prepare() {
+ if use test; then
+ rm -r test || die
+ mv "${WORKDIR}/vis-test-${MY_PTV}" test || die
+
+ # https://bugs.gentoo.org/722014 https://github.com/martanne/vis-test/pull/22
+ sed -i 's;./ccan-config > config.h;./ccan-config "${CC}" ${CFLAGS} > config.h;' test/core/Makefile || die
+
+ # https://github.com/martanne/vis-test/issues/27 a Werror clone
+ sed -i 's;|| strstr(output, "warning");;' test/core/ccan-config.c || die
+ fi
+
+ sed -i 's|STRIP?=.*|STRIP=true|' Makefile || die
+ sed -i 's|${DOCPREFIX}/vis|${DOCPREFIX}|' Makefile || die
+ sed -i 's|DOCUMENTATION = LICENSE|DOCUMENTATION =|' Makefile || die
+
+ default
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable lua) \
+ $(use_enable ncurses curses) \
+ $(use_enable selinux) \
+ $(use_enable tre) || die
+}
+
+update_symlinks() {
+ einfo "Calling eselect vi update --if-unset"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ update_symlinks
+}
+
+pkg_postinst() {
+ update_symlinks
+ optfeature "syntax highlighting support" dev-lua/lpeg
+}
diff --git a/app-editors/vis/vis-9999.ebuild b/app-editors/vis/vis-9999.ebuild
index 38ea0ff6ecd6..bb8d1be8d88a 100644
--- a/app-editors/vis/vis-9999.ebuild
+++ b/app-editors/vis/vis-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-LUA_COMPAT=( lua5-2 lua5-3 )
+LUA_COMPAT=( lua5-2 lua5-3 lua5-4 )
inherit lua-single git-r3 optfeature