summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-07-21 23:15:32 +0200
committerSam James <sam@gentoo.org>2022-07-26 21:34:57 +0100
commit7dea592a9f4b5d2d06f26391dd8a62f7c9428215 (patch)
tree50dd1c76058c865e8a05e3e93d05e76c087b54d6 /app-editors
parentsys-cluster/knem: drop 1.1.3-r3 (diff)
downloadgentoo-7dea592a9f4b5d2d06f26391dd8a62f7c9428215.tar.gz
gentoo-7dea592a9f4b5d2d06f26391dd8a62f7c9428215.tar.bz2
gentoo-7dea592a9f4b5d2d06f26391dd8a62f7c9428215.zip
app-editors/gvim: drop gtk2, nextaw, athena GUIs
The Athena GUI was reported as not working in version 8.2.4514 Support for Athena GUI was removed in 9.0.0057. Drop the neXt use flag as well and the gtk2 flag as gtk+2 is EOL. Also drop the gtk use flag, and make the gtk GUI the default while still supporting aqua and motif. This only drops them from the live ebuild. See: https://github.com/vim/vim/issues/9894#issuecomment-1060673495 See: https://github.com/vim/vim/commit/0b40d086b337f14fdd0dbc035988ffb0aec8ce5f Bug: https://bugs.gentoo.org/858830 Bug: https://bugs.gentoo.org/831250 Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Closes: https://github.com/gentoo/gentoo/pull/26512 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gvim/gvim-9999.ebuild43
1 files changed, 8 insertions, 35 deletions
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index 99018e02a288..aaab6e09d27d 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -29,10 +29,11 @@ HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
LICENSE="vim"
SLOT="0"
-IUSE="acl aqua crypt cscope debug gtk gtk2 lua motif neXt netbeans nls perl python racket ruby selinux session sound tcl"
+IUSE="acl aqua crypt cscope debug lua motif netbeans nls perl python racket ruby selinux session sound tcl"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
+ aqua? ( !motif )
"
RDEPEND="
@@ -45,23 +46,11 @@ RDEPEND="
x11-libs/libXt
acl? ( kernel_linux? ( sys-apps/acl ) )
!aqua? (
- gtk? (
+ motif? ( >=x11-libs/motif-2.3:0 )
+ !motif? (
x11-libs/gtk+:3
x11-libs/libXft
)
- !gtk? (
- gtk2? (
- >=x11-libs/gtk+-2.6:2
- x11-libs/libXft
- )
- !gtk2? (
- motif? ( >=x11-libs/motif-2.3:0 )
- !motif? (
- neXt? ( x11-libs/neXtaw )
- !neXt? ( x11-libs/libXaw )
- )
- )
- )
)
crypt? ( dev-libs/libsodium:= )
cscope? ( dev-util/cscope )
@@ -227,13 +216,7 @@ src_configure() {
)
fi
- # gvim's GUI preference order is as follows:
- # aqua CARBON (not tested)
- # -aqua gtk GTK3
- # -aqua -gtk gtk2 GTK2
- # -aqua -gtk -gtk motif MOTIF
- # -aqua -gtk -gtk -motif neXt NEXTAW
- # -aqua -gtk -gtk -motif -neXt ATHENA
+ # Default is gtk unless aqua or motif are enabled
echo ; echo
if use aqua; then
einfo "Building gvim with the Carbon GUI"
@@ -241,23 +224,13 @@ src_configure() {
--enable-darwin
--enable-gui=carbon
)
- elif use gtk; then
- myconf+=( --enable-gtk3-check )
- einfo "Building gvim with the gtk+-3 GUI"
- myconf+=( --enable-gui=gtk3 )
- elif use gtk2; then
- myconf+=( --enable-gtk2-check )
- einfo "Building gvim with the gtk+-2 GUI"
- myconf+=( --enable-gui=gtk2 )
elif use motif; then
einfo "Building gvim with the MOTIF GUI"
myconf+=( --enable-gui=motif )
- elif use neXt; then
- einfo "Building gvim with the neXtaw GUI"
- myconf+=( --enable-gui=nextaw )
else
- einfo "Building gvim with the Athena GUI"
- myconf+=( --enable-gui=athena )
+ myconf+=( --enable-gtk3-check )
+ einfo "Building gvim with the gtk+-3 GUI"
+ myconf+=( --enable-gui=gtk3 )
fi
echo ; echo