summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-09-09 08:35:53 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-09 08:54:52 +0300
commit9a4e866e578d3ba4d03d59b5e85eaf0f3fec4a28 (patch)
tree6a3f45db7b5dd0d784d95668afd4f7f2de0c0dc7 /app-editors
parentdev-ruby/thor: remove unused patch (diff)
downloadgentoo-9a4e866e578d3ba4d03d59b5e85eaf0f3fec4a28.tar.gz
gentoo-9a4e866e578d3ba4d03d59b5e85eaf0f3fec4a28.tar.bz2
gentoo-9a4e866e578d3ba4d03d59b5e85eaf0f3fec4a28.zip
app-editors/vscodium: add 1.82.0.23250
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.82.0.23250.ebuild109
2 files changed, 112 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index 9a8590f2b1b3..46ec90e93d53 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -4,3 +4,6 @@ DIST vscodium-1.81.0.23216-arm64.tar.gz 121397635 BLAKE2B 6c87bbbe4c9ca08b48330a
DIST vscodium-1.81.1.23222-amd64.tar.gz 121109927 BLAKE2B 5242bf72a5708c1c3d35500bc698170eacd7cdbc7c20874d2bfbbf22a64ab048dbbb1fca5c46b6c8a64fb6bdf66b22f615533556075f062926036e60d37810c4 SHA512 3c985a1974504e57f6f97ae3e157720cec72fd0ad8d067709f2cad4cb4442e92f80d5d39a63ce8143edb0a2baa3d11bdc0128f60fa10d9dfc09ae8f9a5bf4a7b
DIST vscodium-1.81.1.23222-arm.tar.gz 109854729 BLAKE2B 6d0e9ddd23070bdaca1ed2d9a559a0752d01eaf31018dd91f46bda99e2ba8f7e5344df7b93d43948b51c6d7ca7d57522a82a6aace66d90cc0883071360b1592d SHA512 a171a219e8104762dd62bd0ee50d915e8adf35e4ae4c922c64823f4e15cb92ab498e11fa58fdf57635f29df232723bea6153ae88ac7b57540b74cecaa663c18b
DIST vscodium-1.81.1.23222-arm64.tar.gz 121398210 BLAKE2B de2504f5c10fe3c652fb3a393815bd8e32bf8f729dd71a0df558f2575855d5678d1a535882a9c1663b312e1a7f75421da456a4985259e13034a07ececccd19d9 SHA512 53a9198e94df0997083a585f652dc9999dedfde1cc5a24936620f23fb9811ff1c0f61fc20c9b1443b431d86b59fca65b906c89fcf67ab61419bf2e296429c2e3
+DIST vscodium-1.82.0.23250-amd64.tar.gz 122389248 BLAKE2B ea0b0483c63086dee906c4c018cc547867446fd4fca39298e6ef38cf2c60831fbf0a5ca5d7c7aaa41864b23837e06c0caa81b296cf09b3e8f8164684058aa61d SHA512 edb52dd0503a4f9e5948489693b0444abf921d947ff0ffd8783051663750840302dce9d34e853e35511479217ba2b7f00af6d9755ee3ebb4c17cfba1ddc21f8c
+DIST vscodium-1.82.0.23250-arm.tar.gz 110995455 BLAKE2B 5db45ae26ea0c8cae119dc763a22ea192b7e668517bd290ef180b2bae906737761af548948c215032766b549b730314de0861ee0a315521ac3146df8fc899ad3 SHA512 3572132c278384376a2a87810dfeb0da5009da781044edb28db6d74aea36ed9472916d8590bae71e609463a2dc668799da077983f844a8c7c1cfa9d34fdc0111
+DIST vscodium-1.82.0.23250-arm64.tar.gz 122765625 BLAKE2B 0c5ea5d8bbb0890b1484c516afc13bfab3427d247b023bdf96527b5199ae570da637fe420a1f84601ef0616f20dab7cc04e83f9c9c542fc55c5f4f9f50323b94 SHA512 e89d2c502920d815b4e83d6dbd9757536eb0469409c342ad11af2160d954d195153e48a2b9cc18dd6be08f0086d97702b521684e3dc71057a329759459f404d3
diff --git a/app-editors/vscodium/vscodium-1.82.0.23250.ebuild b/app-editors/vscodium/vscodium-1.82.0.23250.ebuild
new file mode 100644
index 000000000000..a5fc09b2ca4c
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.82.0.23250.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+# Usage: arch_src_uri <gentoo arch> <upstream arch>
+arch_src_uri() {
+ echo "${1}? (
+ https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-${2}-${PV}.tar.gz
+ -> ${P}-${1}.tar.gz
+ )"
+}
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ $(arch_src_uri amd64 x64)
+ $(arch_src_uri arm armhf)
+ $(arch_src_uri arm64 arm64)
+"
+S="${WORKDIR}"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE="kerberos"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+ kerberos? ( app-crypt/mit-krb5 )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ if ! use kerberos; then
+ rm -r "${S}/resources/app/node_modules.asar.unpacked/kerberos" || die
+ fi
+
+ # Install
+ pax-mark m codium
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym -r "/opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+ optfeature "keyring support inside vscode" "virtual/secret-service"
+}