summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-04 18:41:09 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-04 18:42:02 +0300
commitde80f52b1bb8ba9f7293acc1c2828f817211d632 (patch)
tree6728f2b8447d64d6776fb29f28e2ee9068fec067 /app-editors
parentdev-python/django: Merge 3.2.19 py311 patches (diff)
downloadgentoo-de80f52b1bb8ba9f7293acc1c2828f817211d632.tar.gz
gentoo-de80f52b1bb8ba9f7293acc1c2828f817211d632.tar.bz2
gentoo-de80f52b1bb8ba9f7293acc1c2828f817211d632.zip
app-editors/vscode: add 1.78.0
Experiment with cleaner install scheme, preserving original executable flags Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscode/Manifest3
-rw-r--r--app-editors/vscode/vscode-1.78.0.ebuild122
2 files changed, 125 insertions, 0 deletions
diff --git a/app-editors/vscode/Manifest b/app-editors/vscode/Manifest
index d1e8aa27af37..e5571adaa3cc 100644
--- a/app-editors/vscode/Manifest
+++ b/app-editors/vscode/Manifest
@@ -1,3 +1,6 @@
DIST vscode-1.77.3-amd64.tar.gz 124980454 BLAKE2B b8f92010c575edec2daf39af5bb2eb8ff43c9538a8ac6cd8ce2c6a66f461c5d0a3284b6dd0e540e7b8ef195652e7c5c2439a8c4ef8286a63d3fa24fa6c663c20 SHA512 9772ec50e6e8fb099f746e89b5b6fb3948699e92d1bb865f2de95317baa2dbad7ce30d61132585859dcd11699b52f91229cc2622b01492d1c63254964015727c
DIST vscode-1.77.3-arm.tar.gz 112112804 BLAKE2B 53be5e0f8ec3d859b36626f98799f3cbc7270aef5f8770a69924a5a6121d28609592cd1c77e663715015128c9c4180f6555ab35ff896e76f9e913b2c308770ae SHA512 9160e0cdafa3f562a504e24f94c8b70100d79a776dd711b2ddcd700ded4428d7523a1f396d9377bf8ed7a4977a448a2ee98d77111afb13f69ae91f870cfd8ba6
DIST vscode-1.77.3-arm64.tar.gz 121682734 BLAKE2B f9428cd9ebf921bee3797e4b3a816935e00a37f1cbe0ea128769b52f28e3b3fce4f758caefc6667eb0e2dd2702a6047ad337db91b82e16167860a265310ad5bc SHA512 b16f4d3a1d6c1c612520128fd422f339f0c2acd049fe82e3bebb903641ad17dfcbfffcba32b15bd9595d7ed622b69af343efb5e616ed94f991247ae17fcb38bc
+DIST vscode-1.78.0-amd64.tar.gz 134687218 BLAKE2B f29366cd55661fbdcdeeb5344ff55fa8924fcdd8bb9df77a83caded61dc51999b69effbfc758bde98a04e48c926a6671969d978fd98d5a5c706f54cafc8dbd6e SHA512 214b198f21b663b001667280627a99deca07409220565355eaf21d74ddf0524aec5ceff3cf7f97bf60e12657bd88a394ffcc5b9decb379b8e2323ff37b243b6e
+DIST vscode-1.78.0-arm.tar.gz 119254165 BLAKE2B 5ddf5372f1ef21e99463d742cb73f2d889f03f5feba6753ea11f5eb48f19772bcdb951a3f291cb6820bfb9892b4ea5c01a73854c202903685f28b28d088b752b SHA512 f1d03a494442e49d591c11f618abaa976e63c2ecb8927d8a45bcde37ee9e9380b2fa621754b4ece0efdf524aabaeedfa6442f476a06edce30a13aeba98d6901c
+DIST vscode-1.78.0-arm64.tar.gz 130765917 BLAKE2B 8ed333530481ed1067163a8e27bf619e47504429051408d581cdaec8095ba8648c0045f59d8907f5cfec1ac2cc51acdc6022cf97e57a98c68483e8f725f9c89d SHA512 dffe7761eb961e9d2584fb5ca42e56fdcff1dfed858a5a098309c7f9311d79949c9bbc00be94258d052e541b27be2e45b935f2b7a1afc498898e1bfde084e304
diff --git a/app-editors/vscode/vscode-1.78.0.ebuild b/app-editors/vscode/vscode-1.78.0.ebuild
new file mode 100644
index 000000000000..eed866455058
--- /dev/null
+++ b/app-editors/vscode/vscode-1.78.0.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="Multiplatform Visual Studio Code from Microsoft"
+HOMEPAGE="https://code.visualstudio.com"
+SRC_URI="
+ amd64? ( https://update.code.visualstudio.com/${PV}/linux-x64/stable -> ${P}-amd64.tar.gz )
+ arm? ( https://update.code.visualstudio.com/${PV}/linux-armhf/stable -> ${P}-arm.tar.gz )
+ arm64? ( https://update.code.visualstudio.com/${PV}/linux-arm64/stable -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}"
+
+RESTRICT="mirror strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ Microsoft-vscode
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscode/bin/code-tunnel
+ /opt/vscode/chrome_crashpad_handler
+ /opt/vscode/chrome-sandbox
+ /opt/vscode/code
+ /opt/vscode/libEGL.so
+ /opt/vscode/libffmpeg.so
+ /opt/vscode/libGLESv2.so
+ /opt/vscode/libvk_swiftshader.so
+ /opt/vscode/libvulkan.so*
+ /opt/vscode/resources/app/extensions/*
+ /opt/vscode/resources/app/node_modules.asar.unpacked/*
+ /opt/vscode/swiftshader/libEGL.so
+ /opt/vscode/swiftshader/libGLESv2.so
+"
+
+src_install() {
+ if use amd64; then
+ cd "${WORKDIR}/VSCode-linux-x64" || die
+ elif use arm; then
+ cd "${WORKDIR}/VSCode-linux-armhf" || die
+ elif use arm64; then
+ cd "${WORKDIR}/VSCode-linux-arm64" || die
+ else
+ die "Visual Studio Code only supports amd64, arm and arm64"
+ fi
+
+ # Cleanup
+ rm -r ./resources/app/LICENSES.chromium.html ./resources/app/LICENSE.rtf ./resources/app/licenses || die
+
+ # Disable update server
+ sed -e "/updateUrl/d" -i ./resources/app/product.json || die
+
+ # Install
+ pax-mark m code
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/vscode"
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/code"
+ dosym -r "/opt/${PN}/bin/code-tunnel" "usr/bin/code-tunnel"
+ domenu "${FILESDIR}/vscode.desktop"
+ domenu "${FILESDIR}/vscode-url-handler.desktop"
+ domenu "${FILESDIR}/vscode-wayland.desktop"
+ domenu "${FILESDIR}/vscode-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscode.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}