summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/auctex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/auctex')
-rw-r--r--app-emacs/auctex/Manifest2
-rw-r--r--app-emacs/auctex/auctex-11.87-r1.ebuild66
-rw-r--r--app-emacs/auctex/auctex-11.88.ebuild65
-rw-r--r--app-emacs/auctex/files/50auctex-gentoo.el8
-rw-r--r--app-emacs/auctex/files/60auctex-gentoo.el4
-rw-r--r--app-emacs/auctex/files/auctex-11.87-jit-lock.patch31
-rw-r--r--app-emacs/auctex/metadata.xml19
7 files changed, 195 insertions, 0 deletions
diff --git a/app-emacs/auctex/Manifest b/app-emacs/auctex/Manifest
new file mode 100644
index 000000000000..3a7740145e03
--- /dev/null
+++ b/app-emacs/auctex/Manifest
@@ -0,0 +1,2 @@
+DIST auctex-11.87.tar.gz 1206073 SHA256 63d57229e585dbf727f5545337615b997488bfdf475274da0718c90b77bd5cf2 SHA512 41a575a36ef2c111f214ad2e87a06c246751859a14ad3f8af77aaf180d8357a4c8d44c2f344b673404d2e011cdf4a193abda93f1b26ffff663f310ed430c5fa1 WHIRLPOOL d3bee56c1b940a2eb041a5b3b6e5ffe876b740e97c5793dd9295b42723abb5febd1fc40d9a0007df5d63f00547a5a59202eca2c102dfb878924ac07dac504eb0
+DIST auctex-11.88.tar.gz 1302836 SHA256 716867d5fbcc5c67cca781d7c1984e6a3a6d5da056ec3b4f35170805bf4dc83f SHA512 30c422b52b3fc698e453ada9643038dd30978f6b1a99f5118a53ae5b939d63246adcb1937f0e5c4cf166477dca78fa17d721402a90c833c9e91d75072ae0f67d WHIRLPOOL fa348913637bf6062184873f50c6988aa1afdd7e4a456acfb139d704de9769480503e796716a632e9769f7d3f68d70e6e42a739ae8742857fcf6390baec156d6
diff --git a/app-emacs/auctex/auctex-11.87-r1.ebuild b/app-emacs/auctex/auctex-11.87-r1.ebuild
new file mode 100644
index 000000000000..b34bea9c0cc4
--- /dev/null
+++ b/app-emacs/auctex/auctex-11.87-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp latex-package
+
+DESCRIPTION="Extended support for writing, formatting and using (La)TeX, Texinfo and BibTeX files"
+HOMEPAGE="http://www.gnu.org/software/auctex/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="preview-latex"
+
+DEPEND="virtual/latex-base
+ preview-latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ )"
+RDEPEND="${DEPEND}"
+
+ELISP_PATCHES="${P}-jit-lock.patch"
+TEXMF="/usr/share/texmf-site"
+
+src_prepare() {
+ elisp_src_prepare
+}
+
+src_configure() {
+ EMACS_NAME=emacs EMACS_FLAVOR=emacs econf --disable-build-dir-test \
+ --with-auto-dir="${EPREFIX}/var/lib/auctex" \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagelispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagedatadir="${EPREFIX}${SITEETC}/${PN}" \
+ --with-texmf-dir="${EPREFIX}${TEXMF}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable preview-latex preview)
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}"/fonts
+ emake
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" || die
+ if use preview-latex; then
+ elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el" || die
+ fi
+ dodoc ChangeLog CHANGES FAQ INSTALL README RELEASE TODO
+}
+
+pkg_postinst() {
+ # rebuild TeX-inputfiles-database
+ use preview-latex && latex-package_pkg_postinst
+ elisp-site-regen
+}
+
+pkg_postrm(){
+ use preview-latex && latex-package_pkg_postrm
+ elisp-site-regen
+}
diff --git a/app-emacs/auctex/auctex-11.88.ebuild b/app-emacs/auctex/auctex-11.88.ebuild
new file mode 100644
index 000000000000..88abd2317690
--- /dev/null
+++ b/app-emacs/auctex/auctex-11.88.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp latex-package
+
+DESCRIPTION="Extended support for writing, formatting and using (La)TeX, Texinfo and BibTeX files"
+HOMEPAGE="http://www.gnu.org/software/auctex/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="preview-latex"
+
+DEPEND="virtual/latex-base
+ preview-latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ )"
+RDEPEND="${DEPEND}"
+
+TEXMF="/usr/share/texmf-site"
+
+src_prepare() {
+ elisp_src_prepare
+}
+
+src_configure() {
+ EMACS_NAME=emacs EMACS_FLAVOR=emacs econf --disable-build-dir-test \
+ --with-auto-dir="${EPREFIX}/var/lib/auctex" \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagelispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-packagedatadir="${EPREFIX}${SITEETC}/${PN}" \
+ --with-texmf-dir="${EPREFIX}${TEXMF}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable preview-latex preview)
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}"/fonts
+ emake
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
+ if use preview-latex; then
+ elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el"
+ fi
+ dodoc ChangeLog CHANGES FAQ INSTALL PROBLEMS.preview README RELEASE TODO
+}
+
+pkg_postinst() {
+ # rebuild TeX-inputfiles-database
+ use preview-latex && latex-package_pkg_postinst
+ elisp-site-regen
+}
+
+pkg_postrm(){
+ use preview-latex && latex-package_pkg_postrm
+ elisp-site-regen
+}
diff --git a/app-emacs/auctex/files/50auctex-gentoo.el b/app-emacs/auctex/files/50auctex-gentoo.el
new file mode 100644
index 000000000000..ad4377967194
--- /dev/null
+++ b/app-emacs/auctex/files/50auctex-gentoo.el
@@ -0,0 +1,8 @@
+
+;;; auctex site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(require 'tex-site)
+
+;; detect needed steps after rebuild
+(setq TeX-parse-self t)
diff --git a/app-emacs/auctex/files/60auctex-gentoo.el b/app-emacs/auctex/files/60auctex-gentoo.el
new file mode 100644
index 000000000000..93b601b29769
--- /dev/null
+++ b/app-emacs/auctex/files/60auctex-gentoo.el
@@ -0,0 +1,4 @@
+
+;;; auctex site-lisp configuration, activating preview-latex
+
+(load "preview-latex.el" nil t t)
diff --git a/app-emacs/auctex/files/auctex-11.87-jit-lock.patch b/app-emacs/auctex/files/auctex-11.87-jit-lock.patch
new file mode 100644
index 000000000000..5063a2f8d408
--- /dev/null
+++ b/app-emacs/auctex/files/auctex-11.87-jit-lock.patch
@@ -0,0 +1,31 @@
+commit 5b5ef6eeb0468c273a329a05d31b3788fd46b5d7
+Author: Mosè Giordano <giordano.mose@libero.it>
+Date: Sun May 12 12:01:37 2013 +0200
+
+ Temporary fix for font-latex-jit-lock-force-redisplay.
+
+ * font-latex.el (font-latex-jit-lock-force-redisplay): Don't rely
+ on existing `jit-lock-force-redisplay' because recent bzr Emacs
+ broke compatibility changing the number of arguments. Reported by
+ Robert Goldman.
+
+--- auctex-11.87-orig/font-latex.el
++++ auctex-11.87/font-latex.el
+@@ -1220,8 +1220,6 @@
+
+ (defun font-latex-jit-lock-force-redisplay (buf start end)
+ "Compatibility for Emacsen not offering `jit-lock-force-redisplay'."
+- (if (fboundp 'jit-lock-force-redisplay)
+- (jit-lock-force-redisplay buf start end)
+ ;; The following block is an expansion of `jit-lock-force-redisplay'
+ ;; and involved macros taken from CVS Emacs on 2007-04-28.
+ (with-current-buffer buf
+@@ -1236,7 +1234,7 @@
+ buffer-file-truename)
+ (put-text-property start end 'fontified t))
+ (unless modified
+- (restore-buffer-modified-p nil)))))))
++ (restore-buffer-modified-p nil))))))
+
+ (defun font-latex-fontify-region (beg end &optional loudly)
+ "Fontify region from BEG to END.
diff --git a/app-emacs/auctex/metadata.xml b/app-emacs/auctex/metadata.xml
new file mode 100644
index 000000000000..f36206c93577
--- /dev/null
+++ b/app-emacs/auctex/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<herd>tex</herd>
+<longdescription>
+ AUCTeX is an extensible package for writing and formatting TeX files
+ in GNU Emacs and XEmacs. It supports many different TeX macro packages,
+ including AMS-TeX, LaTeX, Texinfo, ConTeXt, and docTeX (dtx files).
+
+ AUCTeX includes preview-latex which makes LaTeX a tightly integrated
+ component of your editing workflow by visualizing selected source chunks
+ (such as single formulas or graphics) directly as images in the source
+ buffer.
+</longdescription>
+<use>
+ <flag name='preview-latex'>Use bundled preview-latex</flag>
+</use>
+</pkgmetadata>