summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-17 15:04:24 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-17 15:22:12 +0200
commitdea3f6d07792adf95c1aafce8429b9eff7eb4741 (patch)
tree0621a59496ae9ea20c9832707fab7d377d2b7eb6 /app-emacs/corfu
parentapp-emacs/corfu: drop old 0.36 (diff)
downloadgentoo-dea3f6d07792adf95c1aafce8429b9eff7eb4741.tar.gz
gentoo-dea3f6d07792adf95c1aafce8429b9eff7eb4741.tar.bz2
gentoo-dea3f6d07792adf95c1aafce8429b9eff7eb4741.zip
app-emacs/corfu: bump to 0.38
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/corfu')
-rw-r--r--app-emacs/corfu/Manifest1
-rw-r--r--app-emacs/corfu/corfu-0.38.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/corfu/Manifest b/app-emacs/corfu/Manifest
index 29aa4b84256f..76f9746b7410 100644
--- a/app-emacs/corfu/Manifest
+++ b/app-emacs/corfu/Manifest
@@ -1 +1,2 @@
DIST corfu-0.37.tar.gz 46624 BLAKE2B 256412325253f9282b39981bb1402825b193cf12e13fc4dc33bcf946931b554dfa6b95b331c553889cb2105a670632051441f0d0434882ce4e69b51ce663460d SHA512 a7ba07083fa93785ca23ffe5f959a9178aed079e00b44a2dcc90f64c6763555e27b04906aa0dab63bce8f07b30b60e60b785572b53257f86b794c800835a58b3
+DIST corfu-0.38.tar.gz 47354 BLAKE2B d36e07d494f56a91070f365801e47fb57b2e90a02e1dca325e795cc9158bf9baf577e413402592663ef66ab722e9750a1abb186816e93332f68d3a8a2bd72819 SHA512 40016e0b65a2ec9787ea236d6a6c5c499000ef7a07684a35bbe461edb5a975b6608cd82dbc3308c59e7e92076fe6fe2638cf253a8d53085f52d8d47e9e620f40
diff --git a/app-emacs/corfu/corfu-0.38.ebuild b/app-emacs/corfu/corfu-0.38.ebuild
new file mode 100644
index 000000000000..e1bbf4ca3ef1
--- /dev/null
+++ b/app-emacs/corfu/corfu-0.38.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion Overlay Region FUnction"
+HOMEPAGE="https://github.com/minad/corfu/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.3.4"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}