summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/ess
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/ess')
-rw-r--r--app-emacs/ess/Manifest3
-rw-r--r--app-emacs/ess/ess-13.09.ebuild45
-rw-r--r--app-emacs/ess/ess-14.09.ebuild44
-rw-r--r--app-emacs/ess/ess-15.03.1.ebuild46
-rw-r--r--app-emacs/ess/files/50ess-gentoo.el2
-rw-r--r--app-emacs/ess/metadata.xml5
6 files changed, 145 insertions, 0 deletions
diff --git a/app-emacs/ess/Manifest b/app-emacs/ess/Manifest
new file mode 100644
index 000000000000..f35ea1520780
--- /dev/null
+++ b/app-emacs/ess/Manifest
@@ -0,0 +1,3 @@
+DIST ess-13.09.tgz 3356969 SHA256 d0625f8ac38831a05d419435d3a6ccf852878c8aea018c3f4a9c9d6bd61e71d2 SHA512 96a91a41c9b390c27646e4b95d7a41e6b22d592c82bf775f2e1b70905c7bc684c3d6645496275d245c9f882030da1b3bd5cd3ba5711acbec3a07cdb2d065a5dd WHIRLPOOL 3560d95bcb43a65ca86787274fa96106611a98041cf63905a4066223247d8557405b7557da2c468d836d4570d4e791aa36e84e76585fc9668729926ef0759598
+DIST ess-14.09.tgz 3350987 SHA256 b6f1badd065e2e42f1d9d75a4e7a04290849d6f7a2bdb8413f73e0eae4014571 SHA512 91e275810f7a8c856f3392194ad3fb3d5f5b966e887568b22c133a362164e71ff5306d1d1a70e97f9d10261fe82eecb5f14e99a0dad4a4e239f5b810d7bba8ac WHIRLPOOL 5eabe6d65d7b5d420a7c6989b82d9901ac20d7b6376223f5aee39da7212ea395d15a98ce86c49fb2782706ba524532ceb38fd23dafaae5891a55958d1c676221
+DIST ess-15.03-1.tgz 3177102 SHA256 ad2f1b48dd4671848709d226aab72427129ac2fd5f85c0c0b39b96be24eee66f SHA512 5260d8afa10e1382cac3c70a4b6f753dd77e9f24bb2f68247732605b0f5fbb1b06e090dbcb45d747a484333f0779959c9213a4792103839b11c9e239bf35534d WHIRLPOOL eb1e6917a05b7444f4c37949a51554b6b33a0841bad5dae6aa93f575a7914fb36299c7c63ec27ec24944104a39b5844ada12b1c74a64daa04a682d5e97001834
diff --git a/app-emacs/ess/ess-13.09.ebuild b/app-emacs/ess/ess-13.09.ebuild
new file mode 100644
index 000000000000..e80e2e1550fa
--- /dev/null
+++ b/app-emacs/ess/ess-13.09.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="http://ess.r-project.org/"
+SRC_URI="http://ess.r-project.org/downloads/ess/${P}.tgz"
+
+LICENSE="GPL-2+ GPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="app-text/texi2html
+ virtual/latex-base"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ INFODIR="${ED}/usr/share/info" \
+ LISPDIR="${ED}${SITELISP}/ess" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ install
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ # Most documentation is installed by the package's build system.
+ rm -f "${ED}${SITELISP}/${PN}/ChangeLog"
+ dodoc ChangeLog *NEWS doc/{TODO,ess-intro.pdf}
+ newdoc lisp/ChangeLog ChangeLog-lisp
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog "Please see /usr/share/doc/${PF} for the complete documentation."
+ elog "Usage hints are in ${SITELISP}/${PN}/ess-site.el ."
+}
diff --git a/app-emacs/ess/ess-14.09.ebuild b/app-emacs/ess/ess-14.09.ebuild
new file mode 100644
index 000000000000..67e9b61498e2
--- /dev/null
+++ b/app-emacs/ess/ess-14.09.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="http://ess.r-project.org/"
+SRC_URI="http://ess.r-project.org/downloads/ess/${P}.tgz"
+
+LICENSE="GPL-2+ GPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="app-text/texi2html
+ virtual/latex-base"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ INFODIR="${ED}/usr/share/info" \
+ LISPDIR="${ED}${SITELISP}/ess" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ install
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ # Most documentation is installed by the package's build system.
+ rm -f "${ED}${SITELISP}/${PN}/ChangeLog"
+ dodoc ChangeLog *NEWS doc/{TODO,ess-intro.pdf}
+ newdoc doc/ChangeLog ChangeLog-doc
+ newdoc lisp/ChangeLog ChangeLog-lisp
+
+ DOC_CONTENTS="Please see /usr/share/doc/${PF} for the complete
+ documentation. Usage hints are in ${SITELISP}/${PN}/ess-site.el ."
+ readme.gentoo_create_doc
+}
diff --git a/app-emacs/ess/ess-15.03.1.ebuild b/app-emacs/ess/ess-15.03.1.ebuild
new file mode 100644
index 000000000000..8f342fa7f661
--- /dev/null
+++ b/app-emacs/ess/ess-15.03.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo elisp
+
+MY_P="${PN}-${PV%.*}-${PV##*.}"
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="http://ess.r-project.org/"
+SRC_URI="http://ess.r-project.org/downloads/ess/${MY_P}.tgz"
+
+LICENSE="GPL-2+ GPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="app-text/texi2html
+ virtual/latex-base"
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ INFODIR="${ED}/usr/share/info" \
+ LISPDIR="${ED}${SITELISP}/ess" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ install
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ # Most documentation is installed by the package's build system.
+ rm -f "${ED}${SITELISP}/${PN}/ChangeLog"
+ dodoc ChangeLog *NEWS doc/{TODO,ess-intro.pdf}
+ newdoc doc/ChangeLog ChangeLog-doc
+ newdoc lisp/ChangeLog ChangeLog-lisp
+
+ DOC_CONTENTS="Please see /usr/share/doc/${PF} for the complete
+ documentation. Usage hints are in ${SITELISP}/${PN}/ess-site.el ."
+ readme.gentoo_create_doc
+}
diff --git a/app-emacs/ess/files/50ess-gentoo.el b/app-emacs/ess/files/50ess-gentoo.el
new file mode 100644
index 000000000000..597e41c706fb
--- /dev/null
+++ b/app-emacs/ess/files/50ess-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(require 'ess-site)
diff --git a/app-emacs/ess/metadata.xml b/app-emacs/ess/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/ess/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>