summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/javascript
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/javascript')
-rw-r--r--app-emacs/javascript/Manifest2
-rw-r--r--app-emacs/javascript/files/50javascript-gentoo.el4
-rw-r--r--app-emacs/javascript/javascript-2.0_beta8.ebuild18
-rw-r--r--app-emacs/javascript/javascript-2.2.1.ebuild18
-rw-r--r--app-emacs/javascript/metadata.xml5
5 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/javascript/Manifest b/app-emacs/javascript/Manifest
new file mode 100644
index 000000000000..f3ec65542e4d
--- /dev/null
+++ b/app-emacs/javascript/Manifest
@@ -0,0 +1,2 @@
+DIST javascript-2.0_beta8.el.bz2 6067 SHA256 d2e77337442ceaf065d0767cce22609ecdfe045ec60552db79f2d8683d90b512 SHA512 fe212b938bf390f06e97981b127bb3cbda048d665fa56a2053f9ed2a27f76abb77d0c1cf120afacc26f423f9a0abc70fb53ef05537942b2c8768c6626eecbdb8 WHIRLPOOL cb90ba5b7726bae9382f29dd25133ce813241f40007096d9890ad49380c78a6ebd780d2e578b920fc0490654952b94f0061787870242e79be1a7608cd119a642
+DIST javascript-2.2.1.el.bz2 6141 SHA256 9f7e7039662e2081b1d373f2c1fb449c975882f6d09f566719eef85c8bc21433 SHA512 1c84b394bafa4ebbdb9827f109ada2219860b147546e7bda337cb570296aced30758276da1c12ac33398ce3f6e6fc49b6a1e9c300dd2759017882fcd1ee085ec WHIRLPOOL 845571cb06b6b059a3b0524c020c19072e79ad0d579bd37f73779f8c9285ede081cffeb99913528ad39dec234c7c47610fe620461a17ff5a1cb5789de238d950
diff --git a/app-emacs/javascript/files/50javascript-gentoo.el b/app-emacs/javascript/files/50javascript-gentoo.el
new file mode 100644
index 000000000000..b533cd4c1a2c
--- /dev/null
+++ b/app-emacs/javascript/files/50javascript-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'javascript-mode "javascript"
+ "Major mode for editing JavaScript source text." t)
+(add-to-list 'auto-mode-alist '("\\.js\\'" . javascript-mode))
diff --git a/app-emacs/javascript/javascript-2.0_beta8.ebuild b/app-emacs/javascript/javascript-2.0_beta8.ebuild
new file mode 100644
index 000000000000..83cf0e55ea45
--- /dev/null
+++ b/app-emacs/javascript/javascript-2.0_beta8.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit elisp
+
+DESCRIPTION="Major mode for editing JavaScript source text"
+HOMEPAGE="http://www.karllandstrom.se/emacs_modes.php
+ http://www.emacswiki.org/emacs/JavaScriptMode"
+# taken from http://web.comhem.se/~u34308910/emacs/javascript.el.zip
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+SITEFILE=50${PN}-gentoo.el
diff --git a/app-emacs/javascript/javascript-2.2.1.ebuild b/app-emacs/javascript/javascript-2.2.1.ebuild
new file mode 100644
index 000000000000..ace3810ae373
--- /dev/null
+++ b/app-emacs/javascript/javascript-2.2.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit elisp
+
+DESCRIPTION="Major mode for editing JavaScript source text"
+HOMEPAGE="http://www.karllandstrom.se/emacs_modes.php
+ http://www.emacswiki.org/emacs/JavaScriptMode"
+# taken from http://www.brgeight.se/downloads/emacs/javascript.el
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/javascript/metadata.xml b/app-emacs/javascript/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/javascript/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>