summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/php-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/php-mode')
-rw-r--r--app-emacs/php-mode/Manifest1
-rw-r--r--app-emacs/php-mode/files/50php-mode-gentoo.el5
-rw-r--r--app-emacs/php-mode/metadata.xml8
-rw-r--r--app-emacs/php-mode/php-mode-1.5.0.ebuild19
4 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/php-mode/Manifest b/app-emacs/php-mode/Manifest
new file mode 100644
index 000000000000..97b083cfa359
--- /dev/null
+++ b/app-emacs/php-mode/Manifest
@@ -0,0 +1 @@
+DIST php-mode-1.5.0.tar.gz 42687 SHA256 d8b179941141994d9cc9e77d244e91df3b4d845f4c6e1818eeefc59bc97bcead SHA512 e05cf9eeff3d17f6af29b03d08f279e4c04f79a2c018de5ddcf097adbf9e67978eeb9f0f9e67b9406c1f33c494597ab1bfa629bdab131d668de40b81d68e796f WHIRLPOOL fd5a92af5c006abc00d10803770a64452f49d803c16c3b57a77f3f87ebf984ad3db951304d6ece9fad395cd46ac4a0e7ec2d256e3dbe7c75d68b276bc178ab74
diff --git a/app-emacs/php-mode/files/50php-mode-gentoo.el b/app-emacs/php-mode/files/50php-mode-gentoo.el
new file mode 100644
index 000000000000..50c4ef71afa3
--- /dev/null
+++ b/app-emacs/php-mode/files/50php-mode-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'php-mode "php-mode" "Major mode for editing PHP code." t)
+(add-to-list 'auto-mode-alist '("\\.php[s34]?\\'" . php-mode))
+(add-to-list 'auto-mode-alist '("\\.phtml\\'" . php-mode))
+(add-to-list 'auto-mode-alist '("\\.inc\\'" . php-mode))
diff --git a/app-emacs/php-mode/metadata.xml b/app-emacs/php-mode/metadata.xml
new file mode 100644
index 000000000000..f7f0dd4460a2
--- /dev/null
+++ b/app-emacs/php-mode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="sourceforge">php-mode</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/php-mode/php-mode-1.5.0.ebuild b/app-emacs/php-mode/php-mode-1.5.0.ebuild
new file mode 100644
index 000000000000..a3aa7f843caf
--- /dev/null
+++ b/app-emacs/php-mode/php-mode-1.5.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs major mode for editing PHP code"
+HOMEPAGE="http://php-mode.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.2+"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="${PN}.texi"
+DOCS="ChangeLog"