summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-19 15:50:39 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-19 16:18:01 +0200
commit9bf80bba553393f5acb0dd69948f2794833e5a7f (patch)
tree166d690f8759074e93907e09945c8eefe0ff73bd /app-emacs
parentapp-emacs/macrostep: bump to 0.9.2 (diff)
downloadgentoo-9bf80bba553393f5acb0dd69948f2794833e5a7f.tar.gz
gentoo-9bf80bba553393f5acb0dd69948f2794833e5a7f.tar.bz2
gentoo-9bf80bba553393f5acb0dd69948f2794833e5a7f.zip
app-emacs/eldev: bump to 1.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/eldev/Manifest1
-rw-r--r--app-emacs/eldev/eldev-1.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/eldev/Manifest b/app-emacs/eldev/Manifest
index cce1342faa2d..d2cca719d2b0 100644
--- a/app-emacs/eldev/Manifest
+++ b/app-emacs/eldev/Manifest
@@ -1 +1,2 @@
DIST eldev-1.3.1.tar.gz 259101 BLAKE2B 838c000865c04079c0ca6d03fff0bf3b9a45d1494a9b1d471303769ff21f2bdd99914e188c9fbf450ded8434bab6a5cb40b7c3b8e445f379f32519dda05d94aa SHA512 255f9a8bc68fb625e5ba5cc8f26720f5736ee70f2e08bec1e088e37705576d8d07607f1c365eb4891aa9b8fa422ea034c88e580b7024e3d4548e0fd250c28fa7
+DIST eldev-1.4.tar.gz 267097 BLAKE2B bd84241834c69d071f8d5ef89434c52f6a063a20c0d5aee4f5e40e5c1259a1b21648416149286ae197a94274c4d219395ef900cc101afe919540eff88bcc29f7 SHA512 ac5639db96ba157902381024a1442f292e97f85c4c9f005702f897c3755d174663b76972e5d10247cb799dcf27357a4a4e1d870513954b7a9892fbeb8ff8e5ec
diff --git a/app-emacs/eldev/eldev-1.4.ebuild b/app-emacs/eldev/eldev-1.4.ebuild
new file mode 100644
index 000000000000..057c43865443
--- /dev/null
+++ b/app-emacs/eldev/eldev-1.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp Development Tool"
+HOMEPAGE="https://github.com/doublep/eldev/"
+SRC_URI="https://github.com/doublep/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DOCS=( README.adoc )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ELDEV_LOCAL="${S}" ./bin/${PN} test
+}
+
+src_install() {
+ elisp_src_install
+ dobin bin/${PN}
+
+ # NOTICE: If ELDEV_LOCAL is defined Eldev will use it
+ # to load up it's components,
+ # if it is not it will bootstrap itself from network
+ # always check if it uses installed Emacs Lisp files.
+ # Also, do not forget to run `env-update` & reopen your shell.
+ # https://github.com/doublep/eldev#influential-environment-variables
+ echo "ELDEV_LOCAL=${SITELISP}/${PN}" >> "${T}"/99${PN} || die
+ doenvd "${T}"/99${PN}
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ ewarn "Remember to run \`env-update && source /etc/profile\` if you plan"
+ ewarn "to use Eldev in a shell before logging out (or restarting"
+ ewarn "your login manager)."
+}