summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Ziak <0xe2.0x9a.0x9b@gmail.com>2018-03-14 16:39:10 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-14 18:26:48 +0100
commitcbd244ceaa2dac69a38c50b70e18456455efc384 (patch)
tree37da3a82f50931993e47584e34b100c26be634d7 /app-emulation/fuse
parentprofiles: prepare SVGA backend USE flag for app-emu*/fuse (diff)
downloadgentoo-cbd244ceaa2dac69a38c50b70e18456455efc384.tar.gz
gentoo-cbd244ceaa2dac69a38c50b70e18456455efc384.tar.bz2
gentoo-cbd244ceaa2dac69a38c50b70e18456455efc384.zip
app-emulation/fuse: make USE flags satisfiable
Makes default backend USE flags non-contradictory. Closes: https://bugs.gentoo.org/649180 Closes: https://github.com/gentoo/gentoo/pull/7372
Diffstat (limited to 'app-emulation/fuse')
-rw-r--r--app-emulation/fuse/fuse-1.5.1.ebuild25
-rw-r--r--app-emulation/fuse/metadata.xml7
2 files changed, 19 insertions, 13 deletions
diff --git a/app-emulation/fuse/fuse-1.5.1.ebuild b/app-emulation/fuse/fuse-1.5.1.ebuild
index 4b8b2fa01d8e..ab203809cef5 100644
--- a/app-emulation/fuse/fuse-1.5.1.ebuild
+++ b/app-emulation/fuse/fuse-1.5.1.ebuild
@@ -10,26 +10,25 @@ SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="alsa ao fbcon gpm gtk joystick memlimit png sdl svga X xml"
+IUSE="alsa ao backend-fbcon +backend-gtk backend-sdl backend-svga backend-X gpm joystick memlimit png xml"
# Only one UI back-end can be enabled at a time
-REQUIRED_USE="^^ ( X fbcon gtk sdl svga )"
+REQUIRED_USE="^^ ( backend-fbcon backend-gtk backend-sdl backend-svga backend-X )"
RDEPEND=">=app-emulation/libspectrum-1.4.1
dev-libs/glib:2
alsa? ( media-libs/alsa-lib )
ao? ( media-libs/libao )
gpm? ( sys-libs/gpm )
- gtk? ( x11-libs/gtk+:3 )
joystick? ( media-libs/libjsw )
png? ( media-libs/libpng:0= sys-libs/zlib )
- sdl? ( media-libs/libsdl )
- svga? ( media-libs/svgalib )
- X? ( x11-libs/libX11
- x11-libs/libXext )
+ backend-gtk? ( x11-libs/gtk+:3 )
+ backend-sdl? ( media-libs/libsdl )
+ backend-svga? ( media-libs/svgalib )
+ backend-X? ( x11-libs/libX11 x11-libs/libXext )
xml? ( dev-libs/libxml2:2 )"
DEPEND="${RDEPEND}
- fbcon? ( virtual/linux-sources )
+ backend-fbcon? ( virtual/linux-sources )
dev-lang/perl
virtual/pkgconfig"
@@ -48,15 +47,15 @@ src_configure() {
$(use_with xml libxml2)
)
- if use gtk; then
+ if use backend-gtk; then
:
- elif use sdl; then
+ elif use backend-sdl; then
myconf+=("--with-sdl")
- elif use X; then
+ elif use backend-X; then
myconf+=("--without-gtk")
- elif use svga; then
+ elif use backend-svga; then
myconf+=("--with-svgalib")
- elif use fbcon; then
+ elif use backend-fbcon; then
myconf+=("--with-fb")
fi
diff --git a/app-emulation/fuse/metadata.xml b/app-emulation/fuse/metadata.xml
index 3687ac68007d..bb6d65be18ac 100644
--- a/app-emulation/fuse/metadata.xml
+++ b/app-emulation/fuse/metadata.xml
@@ -12,4 +12,11 @@
<upstream>
<remote-id type="sourceforge">fuse-emulator</remote-id>
</upstream>
+ <use>
+ <flag name="backend-fbcon">Use framebuffer rendering backend</flag>
+ <flag name="backend-gtk">Use GTK+ rendering backend</flag>
+ <flag name="backend-sdl">Use SDL rendering backend</flag>
+ <flag name="backend-svga">Use svgalib rendering backend</flag>
+ <flag name="backend-X">Use X11 rendering backend</flag>
+ </use>
</pkgmetadata>