summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-10-07 16:21:26 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-10-07 16:21:26 +0200
commit683a4b78fcffa5428bfe1d33937d4612f36ba4b0 (patch)
tree1cae762267baa5b45e9d50ba010ad8c919f08325 /app-emulation/img
parentapp-admin/kube-bench: Remove old (diff)
downloadgentoo-683a4b78fcffa5428bfe1d33937d4612f36ba4b0.tar.gz
gentoo-683a4b78fcffa5428bfe1d33937d4612f36ba4b0.tar.bz2
gentoo-683a4b78fcffa5428bfe1d33937d4612f36ba4b0.zip
app-emulation/img: Use -mod vendor
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-emulation/img')
-rw-r--r--app-emulation/img/img-0.5.7.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/app-emulation/img/img-0.5.7.ebuild b/app-emulation/img/img-0.5.7.ebuild
index a83d24d7c281..21373b5f486d 100644
--- a/app-emulation/img/img-0.5.7.ebuild
+++ b/app-emulation/img/img-0.5.7.ebuild
@@ -21,7 +21,7 @@ RESTRICT="test"
src_compile() {
local TAGS=$(usex seccomp 'seccomp' '')
pushd src/${EGO_PN} || die
- GOPATH="${S}" go build -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ GOPATH="${S}" go build -mod vendor -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
popd || die
}