summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-07-28 16:33:32 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-08-08 12:04:04 +0300
commit56bf8b6a7e58810b7f3399e4ec33963d936c3cd6 (patch)
tree7420ec156ed085ce0b5d732aa3db3f942327066c /app-emulation/punes
parentapp-admin/pwman3: bump version to 0.11.1 (diff)
downloadgentoo-56bf8b6a7e58810b7f3399e4ec33963d936c3cd6.tar.gz
gentoo-56bf8b6a7e58810b7f3399e4ec33963d936c3cd6.tar.bz2
gentoo-56bf8b6a7e58810b7f3399e4ec33963d936c3cd6.zip
app-emulation/punes: update to 0.106
Update package to 0.106, which fixes gcc10 compilation issue (#710612). Additional fixes compilation error #734276. Closes: https://bugs.gentoo.org/710612 Closes: https://bugs.gentoo.org/734276 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-emulation/punes')
-rw-r--r--app-emulation/punes/Manifest1
-rw-r--r--app-emulation/punes/punes-0.106.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-emulation/punes/Manifest b/app-emulation/punes/Manifest
index bb1aecade63b..1f866af056fb 100644
--- a/app-emulation/punes/Manifest
+++ b/app-emulation/punes/Manifest
@@ -1,2 +1,3 @@
DIST punes-0.104.tar.gz 5381182 BLAKE2B fefa6eb85e9cfe5eb10fd987061e6f708a2d29db374552ca217e1e47bfd3a982390d2fdf33f23407bb54d7e1a3491e33cc2c520ff3ead4566f687c6c652bcc6a SHA512 9636440cf66cb9f48b532cebff4342a775ddacffd98748e5669d820e213a648cbfb3e4e94f67389f21f88b4fa618bf514e31738c10df079abe22d4b19593d904
DIST punes-0.105.tar.gz 5376203 BLAKE2B 9008ee14189d669c4c4c815de1c5498e3af22cbae52a25b538ae658fdc3fe9d39600a431e6652c84b24e20b1e713847462e4b802021a635c8f14f7d91317678f SHA512 4ce1487554218b17b0e3e2966c7b4ac0852e0b0bc83aeabbb0e3127d4952f0ef921374a97ce59990d01b5e0ac08204cca5f13476cd7e4a1e7a238850e8305d29
+DIST punes-0.106.tar.gz 5595484 BLAKE2B aa3bb5c869e679b19829a3d1de970517d6d626e0ed2404a9ed09d16af8fabb1ee3258ec8fbb4027fb6b70b5449b2bb7ac6880f43c3ba846687c65d8a0eeaf3f2 SHA512 f35c5cee05464cb11f130938cf7aa519d4dea35dbf52ce3606c3c6bb2596bc59b75e11816a5b44c7b1c9d402a299b4db49727087b4c93c3cb2ba473adfdd4fa2
diff --git a/app-emulation/punes/punes-0.106.ebuild b/app-emulation/punes/punes-0.106.ebuild
new file mode 100644
index 000000000000..1cdb9cc4f012
--- /dev/null
+++ b/app-emulation/punes/punes-0.106.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg-utils
+
+DESCRIPTION="Nintendo Entertainment System (NES) emulator"
+HOMEPAGE="https://github.com/punesemu/puNES"
+SRC_URI="https://github.com/punesemu/puNES/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cg"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-libs/alsa-lib
+ virtual/glu
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ cg? ( media-gfx/nvidia-cg-toolkit )
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+S="${WORKDIR}/puNES-${PV}"
+
+src_prepare() {
+ default
+
+ sed -i "/update-desktop-database/d" misc/Makefile.am || die
+ eautoreconf
+ # FIXME why eautoreconf can't handle this?
+ cd "src/extra/lib7zip-1.6.5" || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with cg opengl-nvidia-cg)
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}