summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-03-29 23:55:01 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-03-29 23:55:13 +0100
commit0837524b145743820a05177f77a6d7c05f677df4 (patch)
tree28749b8e6f4221888cc9897bebebc0604ddc8734 /app-emulation/qemu
parentdev-util/src-cli: CLI for the sourcegraph code search tool (diff)
downloadgentoo-0837524b145743820a05177f77a6d7c05f677df4.tar.gz
gentoo-0837524b145743820a05177f77a6d7c05f677df4.tar.bz2
gentoo-0837524b145743820a05177f77a6d7c05f677df4.zip
app-emulation/qemu: filter out -fcommon
Next qemu release should have a proper fix for symbol collision: $ git grep -P '[^a-z_]machine_init_done[^a-z_]' | cat softmmu/vl.c:bool machine_init_done; stubs/machine-init-done.c:bool machine_init_done = true; I'm not comfortable backporting the change and only filtering out -fcommon as a workaround. We'll remove a workaround in next release. Reported-by: Agostino Sarubbo Reported-by: gordon@niflheim.info Closes: https://bugs.gentoo.org/726560 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/qemu-5.2.0-r3.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-emulation/qemu/qemu-5.2.0-r3.ebuild b/app-emulation/qemu/qemu-5.2.0-r3.ebuild
index 62b50afd5d93..f986ee42a1d9 100644
--- a/app-emulation/qemu/qemu-5.2.0-r3.ebuild
+++ b/app-emulation/qemu/qemu-5.2.0-r3.ebuild
@@ -8,8 +8,9 @@ PYTHON_REQ_USE="ncurses,readline"
FIRMWARE_ABI_VERSION="4.0.0-r50"
-inherit eutils linux-info toolchain-funcs multilib python-r1 \
- udev fcaps readme.gentoo-r1 pax-utils l10n xdg-utils
+inherit eutils linux-info toolchain-funcs multilib python-r1
+inherit udev fcaps readme.gentoo-r1 pax-utils l10n xdg-utils
+inherit flag-o-matic
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://git.qemu.org/git/qemu.git"
@@ -359,6 +360,10 @@ check_targets() {
}
src_prepare() {
+ # workaround -fcommon breakage: bug #726560
+ [[ ${PV} == 5.2.0 ]] || die "Check if -fcommon hack is needed"
+ filter-flags -fcommon
+
check_targets IUSE_SOFTMMU_TARGETS softmmu
check_targets IUSE_USER_TARGETS linux-user