summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-09-04 11:43:34 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-09-04 11:47:43 +0200
commite5dbf8fe21edcb909f894cc7a8d334385733af29 (patch)
treec014d543d4244c36a844fddba20aadbc32593f9d /app-emulation/virtualbox-modules
parentdev-ada/gnatcoll: Work with libgpr-2019 too (diff)
downloadgentoo-e5dbf8fe21edcb909f894cc7a8d334385733af29.tar.gz
gentoo-e5dbf8fe21edcb909f894cc7a8d334385733af29.tar.bz2
gentoo-e5dbf8fe21edcb909f894cc7a8d334385733af29.zip
virtualbox packages: Bump to version 6.0.12
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-emulation/virtualbox-modules')
-rw-r--r--app-emulation/virtualbox-modules/Manifest1
-rw-r--r--app-emulation/virtualbox-modules/virtualbox-modules-6.0.12.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-emulation/virtualbox-modules/Manifest b/app-emulation/virtualbox-modules/Manifest
index 95e0a7093459..b43d45bcc876 100644
--- a/app-emulation/virtualbox-modules/Manifest
+++ b/app-emulation/virtualbox-modules/Manifest
@@ -2,4 +2,5 @@ DIST vbox-kernel-module-src-5.2.26.tar.xz 642096 BLAKE2B fa908b8dda4c49e880005f2
DIST vbox-kernel-module-src-5.2.30.tar.xz 642476 BLAKE2B 497a381b10f813ee333f0ac0a0b9f7893b0cc3c842757e85f119bc28dec4ed978bab827df116c8f99bafb412b8bf5a97592a964cf61f7e813284b2e74e7e8a6d SHA512 80511d96c44294a1faae165e874b838f76449a898cdc01411eae0dbdc5f7ee79f75f8c6a52e9e0c9c1ad8bd054c64751f6be6f7790d0053933db8d786dfbc53e
DIST vbox-kernel-module-src-5.2.32.tar.xz 642428 BLAKE2B 0dda5cb5608c1eed22bea209564d53c5f7eab58ca620db2cc441e3c1ba9ad66609c4ef13df07fd29b691f2941a070f9852e8729cd386081df6a82ede345f33c5 SHA512 fadedab690cb7dee8b9a6747ed711d924bf3bce8999b24e7b64cb8738c53c2fa7372b1a8e8535e7e4ef0235aec02d4a3f1f67cd07d7621934fab684c5163329e
DIST vbox-kernel-module-src-6.0.10.tar.xz 669008 BLAKE2B 80250aeca8421aa0b88efb1d090f78d0bc6c7b4b2c3b7e0c5c7953d9ef5246ee25df6fa14b75b821e1e3d05cda3ff975560ede89dc482e34faa801a592405a9f SHA512 afab0130c14b86e822f2a9528373388a9eeee952deec9ff7158e4b788b64343235f3a3da10218bfabcb71dd4d89c8ace0031ea9b64d7385140f6c580b5087333
+DIST vbox-kernel-module-src-6.0.12.tar.xz 669148 BLAKE2B 2291e3fcb9f049ce5657288151d182dfc9a3d6d6e8e1b32047e4b682f35e56f0a5bb5d3ad7efbc98082d2d1823aeb821099e9878b8a237322e8900fb2e2d65de SHA512 e9d8fcbfc076bf4e7d4dc5954e0c24509273c6358ee2de9ddfa87ea650b69fdc31d223595d610c1dd921efd6620ba5285f7f6a10170e90e706bf731e3629dc51
DIST vbox-kernel-module-src-6.0.8.tar.xz 668380 BLAKE2B 06deabe0bae37503ec2b2df3cf1edb820b190c9e453aad8e211278a27c9ffaf229b98c08b2d7510b3721a30ca53833b43184636fde7ce3e5ac0bcbc588330486 SHA512 a4fb626c5a58637cfef7ebc44ccfcf82d6f2a7e91af665a8854d9fafb0c9b042d473c6767dad64497aed5110aefd23299461d39b43f8e57aa0c255cfcc94b448
diff --git a/app-emulation/virtualbox-modules/virtualbox-modules-6.0.12.ebuild b/app-emulation/virtualbox-modules/virtualbox-modules-6.0.12.ebuild
new file mode 100644
index 000000000000..7257cb3b5812
--- /dev/null
+++ b/app-emulation/virtualbox-modules/virtualbox-modules-6.0.12.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# XXX: the tarball here is just the kernel modules split out of the binary
+# package that comes from virtualbox-bin
+
+EAPI=7
+
+inherit linux-mod user
+
+MY_P="vbox-kernel-module-src-${PV}"
+DESCRIPTION="Kernel Modules for Virtualbox"
+HOMEPAGE="https://www.virtualbox.org/"
+SRC_URI="https://dev.gentoo.org/~polynomial-c/virtualbox/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="pax_kernel"
+
+RDEPEND="!=app-emulation/virtualbox-9999"
+
+S="${WORKDIR}"
+
+BUILD_TARGETS="all"
+BUILD_TARGET_ARCH="${ARCH}"
+MODULE_NAMES="vboxdrv(misc:${S}) vboxnetflt(misc:${S}) vboxnetadp(misc:${S}) vboxpci(misc:${S})"
+
+pkg_setup() {
+ enewgroup vboxusers
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KERN_DIR=${KV_DIR} KERN_VER=${KV_FULL} O=${KV_OUT_DIR} V=1 KBUILD_VERBOSE=1"
+}
+
+src_prepare() {
+ if use pax_kernel && kernel_is -ge 3 0 0 ; then
+ eapply -p0 "${FILESDIR}"/${PN}-5.2.8-pax-const.patch
+ fi
+
+ default
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /usr/lib/modules-load.d/
+ doins "${FILESDIR}"/virtualbox.conf
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+}