summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-04-18 22:42:42 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-04-18 23:26:53 -0400
commit3cbd86a214d29fa86fc3b4d58b50332a6f867cf4 (patch)
tree5abbfb925f3be36cecf7a6f9e345781c255fe850 /app-emulation
parentdev-util/mingw64-toolchain: add 10.0.0_p3 (unkeyworded w/ gcc13) (diff)
downloadgentoo-3cbd86a214d29fa86fc3b4d58b50332a6f867cf4.tar.gz
gentoo-3cbd86a214d29fa86fc3b4d58b50332a6f867cf4.tar.bz2
gentoo-3cbd86a214d29fa86fc3b4d58b50332a6f867cf4.zip
app-emulation/dxvk: fix build w/ gcc13
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dxvk/dxvk-1.10.3.ebuild6
-rw-r--r--app-emulation/dxvk/dxvk-2.0.ebuild6
-rw-r--r--app-emulation/dxvk/dxvk-2.1.ebuild4
-rw-r--r--app-emulation/dxvk/dxvk-2.1_p20230207.ebuild4
-rw-r--r--app-emulation/dxvk/files/dxvk-1.10.3-gcc13.patch17
5 files changed, 35 insertions, 2 deletions
diff --git a/app-emulation/dxvk/dxvk-1.10.3.ebuild b/app-emulation/dxvk/dxvk-1.10.3.ebuild
index 0f86f1f04e95..3995d9ee33e0 100644
--- a/app-emulation/dxvk/dxvk-1.10.3.ebuild
+++ b/app-emulation/dxvk/dxvk-1.10.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -32,6 +32,10 @@ BDEPEND="
dev-util/glslang
!crossdev-mingw? ( dev-util/mingw64-toolchain[${MULTILIB_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10.3-gcc13.patch
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} == binary ]] && return
diff --git a/app-emulation/dxvk/dxvk-2.0.ebuild b/app-emulation/dxvk/dxvk-2.0.ebuild
index 4511ec137b34..48c2560d3808 100644
--- a/app-emulation/dxvk/dxvk-2.0.ebuild
+++ b/app-emulation/dxvk/dxvk-2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -42,6 +42,10 @@ BDEPEND="
dev-util/glslang
!crossdev-mingw? ( dev-util/mingw64-toolchain[${MULTILIB_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10.3-gcc13.patch
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} == binary ]] && return
diff --git a/app-emulation/dxvk/dxvk-2.1.ebuild b/app-emulation/dxvk/dxvk-2.1.ebuild
index e807643ef746..d58b78a8f0ef 100644
--- a/app-emulation/dxvk/dxvk-2.1.ebuild
+++ b/app-emulation/dxvk/dxvk-2.1.ebuild
@@ -48,6 +48,10 @@ BDEPEND="
dev-util/glslang
!crossdev-mingw? ( dev-util/mingw64-toolchain[${MULTILIB_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10.3-gcc13.patch
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} == binary ]] && return
diff --git a/app-emulation/dxvk/dxvk-2.1_p20230207.ebuild b/app-emulation/dxvk/dxvk-2.1_p20230207.ebuild
index 8f164958b449..24b2a3ad1e50 100644
--- a/app-emulation/dxvk/dxvk-2.1_p20230207.ebuild
+++ b/app-emulation/dxvk/dxvk-2.1_p20230207.ebuild
@@ -50,6 +50,10 @@ BDEPEND="
dev-util/glslang
!crossdev-mingw? ( dev-util/mingw64-toolchain[${MULTILIB_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10.3-gcc13.patch
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} == binary ]] && return
diff --git a/app-emulation/dxvk/files/dxvk-1.10.3-gcc13.patch b/app-emulation/dxvk/files/dxvk-1.10.3-gcc13.patch
new file mode 100644
index 000000000000..580e412fcd6e
--- /dev/null
+++ b/app-emulation/dxvk/files/dxvk-1.10.3-gcc13.patch
@@ -0,0 +1,17 @@
+https://github.com/doitsujin/dxvk/commit/1a5afc77b1859e6c7e31b55e11ece899e3b5295a
+--- a/src/util/config/config.h
++++ b/src/util/config/config.h
+@@ -1,4 +1,5 @@
+ #pragma once
+
++#include <cstdint>
+ #include <string>
+ #include <unordered_map>
+--- a/src/util/util_bit.h
++++ b/src/util/util_bit.h
+@@ -17,4 +17,5 @@
+ #include "util_math.h"
+
++#include <cstdint>
+ #include <cstring>
+ #include <iterator>