summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-22 01:05:17 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-22 01:55:45 -0400
commit5a99343091d086a5e77b4be6777f8b2e2ddfd236 (patch)
tree59fd0caeed7fca6d0f0d1833b3e8c37031f659f8 /app-emulation
parentwww-servers/puma: drop 5.6.5, 6.1.1-r1, 6.2.2, 6.3.0 (diff)
downloadgentoo-5a99343091d086a5e77b4be6777f8b2e2ddfd236.tar.gz
gentoo-5a99343091d086a5e77b4be6777f8b2e2ddfd236.tar.bz2
gentoo-5a99343091d086a5e77b4be6777f8b2e2ddfd236.zip
app-emulation/vkd3d: add 1.9
Also do a dirty fix for implicit configure check, not going to spend much time here given this is only packaged for old wine-7. May eventually mask USE=vkd3d on it rather than keep updating this given it is unlikely dx12-users are not using a more recent Wine and it is questionable how compatible these bumps are. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vkd3d/Manifest1
-rw-r--r--app-emulation/vkd3d/files/vkd3d-1.9-implicit-gettid.patch8
-rw-r--r--app-emulation/vkd3d/vkd3d-1.9.ebuild51
3 files changed, 60 insertions, 0 deletions
diff --git a/app-emulation/vkd3d/Manifest b/app-emulation/vkd3d/Manifest
index e7e6d59c4253..d26e7801100b 100644
--- a/app-emulation/vkd3d/Manifest
+++ b/app-emulation/vkd3d/Manifest
@@ -1 +1,2 @@
DIST vkd3d-1.8.tar.xz 829648 BLAKE2B 0e7bb53e3eb9003ea76ee523dfa317b6ab95fd1c2decb453d650f0cf046d5b802a32e40c4e6f6464748903143ef9352e70fdf8ca7fa8e9b9909e0f15235d2b01 SHA512 43d65bf4aa60750e08653226197f40c97bc88d56dc5513b70182b5fe289ab56a225682c96400776cd625ad5a8f76644bf4b46bd3ed54aa8496f538f6854d680a
+DIST vkd3d-1.9.tar.xz 902300 BLAKE2B 62c71b98912e66d86a2d2d934f6bd4c252cced68d3ad96c23b7404dbe346e7a11e43affb1959b389cfc90b53f32b2011ceeca6d066bcae876d24ff0822719d2b SHA512 7fe931fca4bc2e13bd59f2068d758581797aa15530fb811d71323e3cd83a0f12ec3a00e2951f38033fccf8eabfca45e06dad79d80ccc164e047e13cbfc960d0e
diff --git a/app-emulation/vkd3d/files/vkd3d-1.9-implicit-gettid.patch b/app-emulation/vkd3d/files/vkd3d-1.9-implicit-gettid.patch
new file mode 100644
index 000000000000..5aea3171c2de
--- /dev/null
+++ b/app-emulation/vkd3d/files/vkd3d-1.9-implicit-gettid.patch
@@ -0,0 +1,8 @@
+Dirty quick fix for implicit function check, VKD3D_CHECK_FUNC ideally
+needs to be adjusted to be able to pass headers.
+--- a/configure
++++ b/configure
+@@ -18656,2 +18656,3 @@
+ /* end confdefs.h. */
++#include <unistd.h>
+ int main(void) { return gettid(); }
diff --git a/app-emulation/vkd3d/vkd3d-1.9.ebuild b/app-emulation/vkd3d/vkd3d-1.9.ebuild
new file mode 100644
index 000000000000..2056245ceba0
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-1.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://gitlab.winehq.org/wine/vkd3d/"
+SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses spirv-tools"
+RESTRICT="test" #838655
+
+RDEPEND="
+ media-libs/vulkan-loader[${MULTILIB_USEDEP}]
+ ncurses? ( sys-libs/ncurses:= )
+ spirv-tools? ( dev-util/spirv-tools[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/spirv-headers
+ dev-util/vulkan-headers
+"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.9-implicit-gettid.patch
+)
+
+multilib_src_configure() {
+ local conf=(
+ $(multilib_native_use_with ncurses)
+ $(use_with spirv-tools)
+ --disable-doxygen-pdf
+ --without-xcb
+ )
+
+ ECONF_SOURCE=${S} econf "${conf[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name '*.la' -delete || die
+}