summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-26 05:02:34 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-26 06:10:09 -0400
commitd0ea0771a059b3d85149c7731e27659b52ea8952 (patch)
treef0be9e085b43f8ffb09198eb3a30fc4b2b3f7c4c /app-emulation
parentdev-ruby/fiber-annotation: Keyword 0.2.0 ppc64, #909168 (diff)
downloadgentoo-d0ea0771a059b3d85149c7731e27659b52ea8952.tar.gz
gentoo-d0ea0771a059b3d85149c7731e27659b52ea8952.tar.bz2
gentoo-d0ea0771a059b3d85149c7731e27659b52ea8952.zip
app-emulation/wine-vanilla: pass -mno-avx for mingw cross
AVX issues with mingw-gcc aren't exactly new, e.g. https://bugs.winehq.org/show_bug.cgi?id=45289 Been known to cause issues with dxvk too, albeit unsure if that's still relevant as issues are scattered/lost. Newly, >=wine-8.10 is likely to crash doing anything at all 32bit if used -march=native (w/ avx) and 32bit (e.g. `WINEARCH=win32 winecfg`). Adding this to every packages using mingw as a precaution, not believed there is much to gain from keeping AVX given the fragility here (note only revbumping wine-8.10 and 8.11 as they are affected the worst). May revisit eventually with a newer GCC. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.10-r1.ebuild (renamed from app-emulation/wine-vanilla/wine-vanilla-8.10.ebuild)5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild (renamed from app-emulation/wine-vanilla/wine-vanilla-8.11.ebuild)5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.7.ebuild5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.8.ebuild5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-8.9.ebuild5
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild5
8 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
index 36c592c40934..fe54aab83894 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.0.2.ebuild
@@ -267,6 +267,11 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild
index 686049493098..6aa6458e6edd 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.0.1.ebuild
@@ -269,6 +269,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.10.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.10-r1.ebuild
index f2da3a5c1b7b..11ed198a2f98 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.10.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.10-r1.ebuild
@@ -273,6 +273,11 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.11.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild
index f2da3a5c1b7b..11ed198a2f98 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.11.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.11-r1.ebuild
@@ -273,6 +273,11 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.7.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.7.ebuild
index b8ac1a27c65a..5389f45538a8 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.7.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.7.ebuild
@@ -275,6 +275,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.8.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.8.ebuild
index b8ac1a27c65a..5389f45538a8 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.8.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.8.ebuild
@@ -275,6 +275,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-8.9.ebuild b/app-emulation/wine-vanilla/wine-vanilla-8.9.ebuild
index a513b26e07bb..8286b85d538e 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-8.9.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-8.9.ebuild
@@ -275,6 +275,11 @@ src_configure() {
append-cflags '-fno-strict-aliasing'
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index f2da3a5c1b7b..11ed198a2f98 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -273,6 +273,11 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-cflags -mno-avx
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'