summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-12-06 20:02:08 -0500
committerMichael Orlitzky <mjo@gentoo.org>2015-12-06 20:02:25 -0500
commit7c711c8293c7f67c8de8e0cab5133d85b77af08d (patch)
tree8397ab19064f6e01df46d0c4fb3c6657f7cde050 /app-eselect
parentapp-backup/bareos: fix sandbox violation. fixes #566834 (diff)
downloadgentoo-7c711c8293c7f67c8de8e0cab5133d85b77af08d.tar.gz
gentoo-7c711c8293c7f67c8de8e0cab5133d85b77af08d.tar.bz2
gentoo-7c711c8293c7f67c8de8e0cab5133d85b77af08d.zip
app-eselect/eselect-php: version bump with partial php-7.x support for apache2.
This new version adds the ability to switch the apache2 implementation to php-7.x. This was missing earlier due to a library name change, libphp5 -> libphp7. This partially addresses bug #552156, although there is still some work to be done in the apache config file. Upstream development has moved to a Gentoo-hosted git repository at https://gitweb.gentoo.org/proj/eselect-php.git/ Gentoo-Bug: 552156 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-php/Manifest1
-rw-r--r--app-eselect/eselect-php/eselect-php-0.8.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-eselect/eselect-php/Manifest b/app-eselect/eselect-php/Manifest
index 27a9d1f6ede4..9c9280e473ee 100644
--- a/app-eselect/eselect-php/Manifest
+++ b/app-eselect/eselect-php/Manifest
@@ -1 +1,2 @@
DIST eselect-php-0.7.1.bz2 2251 SHA256 10aa400e2d08bc71989366993f12ddb546a0ea29f191c40e37beba1d11d7abd7 SHA512 a6b4c1475dda9f368d799db7658c50cef7d6f71482a53a186fb1394e7ea1fff3c0ef123c82b7ca4d1e45aadb0a034d36f213fc9450766878a60d28639761cb3d WHIRLPOOL a4e45492068616ff30fd888b0cc64441a6eb6e6656e0107d00bd2cf15360dce15052d4d62089ab89d43e6bb36e126529aa101c70e8bd94a9fc916a5369463e3b
+DIST eselect-php-0.8.0.tar.xz 43932 SHA256 1ddc6aafe269ebbf3006737701403bd2c7b324b9eea0fcbdc91e85a856f8a10d SHA512 53c735275264742542d3909ae2994d0720bc961533a3df5373dbc7a7a1f04e91591f4e8356c268954420487d3ead4006cc5d6f361ef0ac2836f7f126556e960d WHIRLPOOL 94deba4a5bd4d0d85c8f3afc96ac30a69cca5db95014b2fd8701495cc83488389302f640065e923cabd40c95f97f792dd173337cc33c7d38441956049fb90cda
diff --git a/app-eselect/eselect-php/eselect-php-0.8.0.ebuild b/app-eselect/eselect-php/eselect-php-0.8.0.ebuild
new file mode 100644
index 000000000000..ea571784c702
--- /dev/null
+++ b/app-eselect/eselect-php/eselect-php-0.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit depend.apache systemd
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
+SRC_URI="https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="fpm apache2"
+
+# The "DirectoryIndex" line in 70_mod_php5.conf requires mod_dir.
+RDEPEND="app-admin/eselect
+ apache2? ( www-servers/apache[apache2_modules_dir] )"
+
+want_apache
+
+src_install() {
+ default
+
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR#${EPREFIX}}"
+ newins "${FILESDIR}/70_mod_php5.conf-apache2-r1" "70_mod_php5.conf"
+ fi
+
+ if use fpm ; then
+ newinitd "${FILESDIR}/php-fpm.init-r4" "php-fpm"
+ systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
+ exeinto /usr/libexec
+ doexe "${FILESDIR}/php-fpm-launcher"
+ fi
+}