summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2024-06-03 23:54:58 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-06-07 09:35:47 +0200
commit0bf49aeaaa868939f3b153ed03c2e4cfbde0e66f (patch)
tree10bf349b988fd3a227c3c86f4298dabc50eb41ae /app-forensics
parentapp-forensics/chkrootkit: update HOMEPAGE, SRC_URI (diff)
downloadgentoo-0bf49aeaaa868939f3b153ed03c2e4cfbde0e66f.tar.gz
gentoo-0bf49aeaaa868939f3b153ed03c2e4cfbde0e66f.tar.bz2
gentoo-0bf49aeaaa868939f3b153ed03c2e4cfbde0e66f.zip
app-forensics/chkrootkit: add 0.58b
Closes: https://bugs.gentoo.org/910173 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/37013 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/chkrootkit/Manifest2
-rw-r--r--app-forensics/chkrootkit/chkrootkit-0.58b.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/app-forensics/chkrootkit/Manifest b/app-forensics/chkrootkit/Manifest
index 4e48504fea13..de1145cd3898 100644
--- a/app-forensics/chkrootkit/Manifest
+++ b/app-forensics/chkrootkit/Manifest
@@ -1,2 +1,4 @@
DIST chkrootkit-0.57-gentoo.patch.bz2 5143 BLAKE2B 2b6018881b12121d6317f45d1b761a0b27e13bcfe4d936a468a13968357039419bb85650a4e0aa85f475226cd196fc17d3bac1222dc5be39f715c3d01a64b8a6 SHA512 21a389bfe1fc838cbf527db107ac7081ad61a90da04ab96d7a1bdd352f1e40745b0a5e31559fde7ff8f4214718510a281f9eb67de38df33f13b9ac2e3c640251
DIST chkrootkit-0.57.tar.gz 41948 BLAKE2B b75bec7e5f582aad363c84308c57de9881facf0176ef8c32adcdffdb04182f248b1dcc40b6df439bb9014580383b7f43e7503877098e8ecba6740c21b46b23a1 SHA512 ff35f01042bc68bdd10c4e26dbde7af7127768442c7a10f114260188dcc7e357e2c48d157c0b83b99e2fd465db3ed3933c84ae12fa411c5c28f64b955e742ff7
+DIST chkrootkit-0.58b-gentoo.patch.bz2 5067 BLAKE2B f1690d72f40269429e437c4ea407e0edbb080b760457a85cfd0c32843f69dc7ecdada795545c390887658a34504243cb8a814f082da85fd78eb3c3e9a99f485f SHA512 266b981304fe129117cb11c304a44f39e2c76c9acc634e6aa5a6654ac7ea76480950652b80378e43cab57a3993d3a0c11b413c9b9e9699924f9b44f6f50a9ec1
+DIST chkrootkit-0.58b.tar.gz 42957 BLAKE2B 92a17d9bb01e2c713791404568a1a625138d2ccd898f2624b1e076dd7d29d6a9154013f6408ffdcf1a5e2cea7236d3c218849ee732dd89f53e1f121cd560d342 SHA512 50829446aa5a320ef3aa678c7bbc03ba2ebc14dca3b4c1f312fb46d3d8206345628d2e94b99cfea33e0d3971afbc025dbd387fb32c4e1135a7466c20eb3afab2
diff --git a/app-forensics/chkrootkit/chkrootkit-0.58b.ebuild b/app-forensics/chkrootkit/chkrootkit-0.58b.ebuild
new file mode 100644
index 000000000000..cbb0f3549958
--- /dev/null
+++ b/app-forensics/chkrootkit/chkrootkit-0.58b.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd toolchain-funcs
+
+GENTOO_PATCH="${P}-gentoo.patch"
+
+DESCRIPTION="Tool to locally check for signs of a rootkit"
+HOMEPAGE="https://www.chkrootkit.org/"
+SRC_URI="ftp://ftp.chkrootkit.org/pub/seg/pac/${P}.tar.gz
+ https://md11.it.cx/download/${PN}/${GENTOO_PATCH}.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="+cron"
+
+RDEPEND="cron? ( virtual/cron )"
+
+PATCHES=(
+ "${WORKDIR}/${P}-gentoo.patch"
+ "${FILESDIR}/${PN}-0.55-fcntl_h.patch"
+ "${FILESDIR}/${PN}-0.55-limits_h.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -e 's:/var/adm/:/var/log/:g' \
+ -i chklastlog.c || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" STRIP=/bin/true sense
+}
+
+src_install() {
+ dosbin chkdirs chklastlog chkproc chkrootkit chkwtmp chkutmp ifpromisc strings-static
+ dodoc ACKNOWLEDGMENTS README*
+
+ if use cron ; then
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}"/${PN}.cron ${PN}
+ fi
+
+ systemd_dounit "${FILESDIR}/${PN}.timer" "${FILESDIR}/${PN}.service"
+}
+
+pkg_postinst() {
+ if use cron ; then
+ elog
+ elog "Edit ${EROOT}/etc/cron.weekly/chkrootkit to activate chkrootkit!"
+ elog
+ fi
+
+ if systemd_is_booted || has_version sys-apps/systemd ; then
+ elog
+ elog "To enable the systemd timer, run the following command:"
+ elog " systemctl enable --now chkrootkit.timer"
+ elog
+ fi
+
+ elog
+ elog "Some applications, such as portsentry, will cause chkrootkit"
+ elog "to produce false positives. Read the chkrootkit FAQ at"
+ elog "http://www.chkrootkit.org/ for more information."
+ elog
+}