summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/ibus-rime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/ibus-rime')
-rw-r--r--app-i18n/ibus-rime/Manifest3
-rw-r--r--app-i18n/ibus-rime/ibus-rime-0.9.9.ebuild29
-rw-r--r--app-i18n/ibus-rime/ibus-rime-1.1.ebuild29
-rw-r--r--app-i18n/ibus-rime/ibus-rime-1.2.ebuild29
-rw-r--r--app-i18n/ibus-rime/metadata.xml17
5 files changed, 107 insertions, 0 deletions
diff --git a/app-i18n/ibus-rime/Manifest b/app-i18n/ibus-rime/Manifest
new file mode 100644
index 000000000000..791d2d1536ca
--- /dev/null
+++ b/app-i18n/ibus-rime/Manifest
@@ -0,0 +1,3 @@
+DIST ibus-rime-0.9.9.tar.gz 23912 SHA256 5bbb76abc763bdd3c83a5fe594f1488b34377b34b3f6e3c8c7b5cf86ab550cad SHA512 b18e6f3ba6c97e3b55900d9c4cb70d58f24b202bf2ae894ca861af10ddb028c193d9ac97e609f3b4f0f183b212b74180a02e5d823f235b4c799733933a48afb7 WHIRLPOOL 65d50aafe79014536da3fbbd274fcdf45b93223b1162dae52a2a6c99b2bf2f15192051011ae7aad13f2044fe24b6cdce018f0527cd9ff61164134893447e0431
+DIST ibus-rime-1.1.tar.gz 23418 SHA256 5aff3bbf5ce1eddd1243436ce2bbbb55a6c745b7cba8b6df4e5049f116a8b2be SHA512 2510f9019045013f85af5b8401286b338b739fa0e908a3e30e1d59971a43c32212f388d367b51942292e236859feb1a70d7e7b8deb17eafd8b4f878cc7ba018f WHIRLPOOL 1df8da49b1d3e420ea78cae9ee65b5bf646928480a7d13ed9d05358b274cb932f2026a232876a3c72402ced5957a03c82d3839f84b2a272f5e650aac17ed7360
+DIST ibus-rime-1.2.tar.gz 33396 SHA256 932e0ce6d480562fbb4e3e266d48cdf6007ce0288db4fa3f3cbc3bb1c69b6fce SHA512 e1851781a6d069a79d04890b5b0aa2a706e611c08df3fcb99f883eeedd4dc4eefcac207f35b5cf1d856a41f0153ec3fbb040b4e6f610727384baa19b52a64155 WHIRLPOOL 3ab5b34268913846f29ae3bacf0c46133ecf19728094850dd2a9d28fe78811af1a7ef2d9e6c04221c4ba44a6e5a8fdb50456836def20a61621639dda14d6d2bb
diff --git a/app-i18n/ibus-rime/ibus-rime-0.9.9.ebuild b/app-i18n/ibus-rime/ibus-rime-0.9.9.ebuild
new file mode 100644
index 000000000000..f65142c1a562
--- /dev/null
+++ b/app-i18n/ibus-rime/ibus-rime-0.9.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Rime Input Method Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/rimeime/"
+SRC_URI="http://rimeime.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="app-i18n/ibus
+ app-i18n/librime
+ x11-libs/libnotify"
+DEPEND="${COMMON_DEPEND}
+ dev-util/cmake"
+RDEPEND="${COMMON_DEPEND}
+ app-i18n/rime-data"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i -e "/^libexecdir/s:/lib:/libexec:" Makefile || die
+ sed -i -e "/exec/s:/usr/lib:/usr/libexec:" rime.xml || die
+}
diff --git a/app-i18n/ibus-rime/ibus-rime-1.1.ebuild b/app-i18n/ibus-rime/ibus-rime-1.1.ebuild
new file mode 100644
index 000000000000..0265250c5dce
--- /dev/null
+++ b/app-i18n/ibus-rime/ibus-rime-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Rime Input Method Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/rimeime/"
+SRC_URI="http://rimeime.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="app-i18n/ibus
+ app-i18n/librime
+ x11-libs/libnotify"
+DEPEND="${COMMON_DEPEND}
+ dev-util/cmake"
+RDEPEND="${COMMON_DEPEND}
+ app-i18n/rime-data"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i -e "/^libexecdir/s:/lib:/libexec:" Makefile || die
+ sed -i -e "/exec/s:/usr/lib:/usr/libexec:" rime.xml || die
+}
diff --git a/app-i18n/ibus-rime/ibus-rime-1.2.ebuild b/app-i18n/ibus-rime/ibus-rime-1.2.ebuild
new file mode 100644
index 000000000000..022b86fb58d1
--- /dev/null
+++ b/app-i18n/ibus-rime/ibus-rime-1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Rime Input Method Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/rimeime/"
+SRC_URI="http://dl.bintray.com/lotem/rime/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="app-i18n/ibus
+ app-i18n/librime
+ x11-libs/libnotify"
+DEPEND="${COMMON_DEPEND}
+ dev-util/cmake"
+RDEPEND="${COMMON_DEPEND}
+ app-i18n/rime-data"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i -e "/^libexecdir/s:/lib:/libexec:" Makefile || die
+ sed -i -e "/exec/s:/usr/lib:/usr/libexec:" rime.xml || die
+}
diff --git a/app-i18n/ibus-rime/metadata.xml b/app-i18n/ibus-rime/metadata.xml
new file mode 100644
index 000000000000..0a8c950f3291
--- /dev/null
+++ b/app-i18n/ibus-rime/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>chen.sst@gmail.com</email>
+ <name>Gong Chen</name>
+ </maintainer>
+ <bugs-to>http://code.google.com/p/rimeime/issues/list</bugs-to>
+ <remote-id type="google-code">rimeime</remote-id>
+ </upstream>
+</pkgmetadata>