summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-12 13:04:55 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-12 13:05:40 +0100
commit409741fd7cc9be0e260716068c70cff0e8756ac8 (patch)
treebde720de81822d1f64d76080e99882525621409f /app-i18n/jfbterm
parentnet-proxy/3proxy: version bump to 0.8.9 (diff)
downloadgentoo-409741fd7cc9be0e260716068c70cff0e8756ac8.tar.gz
gentoo-409741fd7cc9be0e260716068c70cff0e8756ac8.tar.bz2
gentoo-409741fd7cc9be0e260716068c70cff0e8756ac8.zip
app-i18n/jfbterm: Modernise to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-i18n/jfbterm')
-rw-r--r--app-i18n/jfbterm/jfbterm-0.4.7-r4.ebuild42
1 files changed, 24 insertions, 18 deletions
diff --git a/app-i18n/jfbterm/jfbterm-0.4.7-r4.ebuild b/app-i18n/jfbterm/jfbterm-0.4.7-r4.ebuild
index b79f0ff20b57..43d7361f0f28 100644
--- a/app-i18n/jfbterm/jfbterm-0.4.7-r4.ebuild
+++ b/app-i18n/jfbterm/jfbterm-0.4.7-r4.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-inherit flag-o-matic eutils autotools
+EAPI=6
+
+inherit autotools flag-o-matic
DESCRIPTION="The J Framebuffer Terminal/Multilingual Enhancement with UTF-8 support"
HOMEPAGE="http://jfbterm.sourceforge.jp/"
@@ -13,35 +15,39 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE="debug"
-DEPEND=">=sys-libs/ncurses-5.6"
-RDEPEND="media-fonts/unifont
+DEPEND="sys-libs/ncurses:0"
+RDEPEND="
+ media-fonts/unifont
media-fonts/font-misc-misc
media-fonts/intlfonts"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-sigchld-debian.patch"
- epatch "${FILESDIR}/${P}-no-kernel-headers.patch"
- epatch "${FILESDIR}/${P}-gentoo.patch"
- epatch "${FILESDIR}/${P}-wrong-inline-gcc5.patch"
+PATCHES=(
+ "${FILESDIR}"/${P}-sigchld-debian.patch
+ "${FILESDIR}"/${P}-no-kernel-headers.patch
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-wrong-inline-gcc5.patch
+)
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
-src_compile() {
- econf $(use_enable debug) || die "econf failed"
- emake || die "emake failed"
+src_configure() {
+ econf $(use_enable debug)
}
src_install() {
dodir /etc /usr/share/fonts/jfbterm
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ default
- mv "${D}"/etc/jfbterm.conf{.sample,}
+ mv "${ED%/}"/etc/jfbterm.conf{.sample,} || die
- doman jfbterm.1 jfbterm.conf.5 || die "doman failed"
+ doman jfbterm.1 jfbterm.conf.5
- dodoc AUTHORS ChangeLog NEWS README* jfbterm.conf.sample* \
- || die "dodoc failed"
+ # install example config files
+ docinto examples
+ dodoc jfbterm.conf.sample*
+ docompress -x /usr/share/doc/${PF}/examples
}