summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-06-23 18:14:41 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-06-23 18:14:41 +0900
commit0fa6fa42116a479d1b6b0bb7007f8ffeeb224e8f (patch)
tree2f8d44a4d39be71da5d97915fb3341547e12e86e /app-i18n
parentapp-text/po4a: new upstream release (diff)
downloadgentoo-0fa6fa42116a479d1b6b0bb7007f8ffeeb224e8f.tar.gz
gentoo-0fa6fa42116a479d1b6b0bb7007f8ffeeb224e8f.tar.bz2
gentoo-0fa6fa42116a479d1b6b0bb7007f8ffeeb224e8f.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.9.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 50703f380499..aeb243a61269 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.25.7.tar.gz 12389694 BLAKE2B 192618e366b53849e94281ea4d9b98356f820ed6594dcd9ec1c4ddbfacf06d161fe44b4f37c19b3d007515c858b100a2f8b8fd6beb51088a668f269c86feadc6 SHA512 9603b99293e596c958aa2d21e8f0d78b06c6873769b2206c8f5bc225993d53e6af51d493d664d51b8632550e996f714a9ebf0c4ff8f914cd11b4119ac7570203
DIST ibus-typing-booster-2.25.8.tar.gz 13241387 BLAKE2B 0c5b253f5b7b0b75decce318ccea3c10ca0676fcf2a060e55a0d195dbf591d1fd1aeb319f07e449e1bac2cd22a35e98cce30f6bd55b92edebae6a613d102fb38 SHA512 22581e6e400a93797c2a9b4ff27afe56ab7754624bc229425a34eebb72de8f96b327f360a4d2d0e3f2e80a49005397b555986c09df5463cbbbc011f361e1e336
+DIST ibus-typing-booster-2.25.9.tar.gz 13241247 BLAKE2B 3ecd96e95f22022ce52ad2b1821faaeec45f6b5f50b4c6e1df67ee4f1908539090ac0668aa73180bb5a665ad60a8bd8c37a72aa776420ab28bdc59ece003fa21 SHA512 3427336e15199eb851178393c3568bc8b8dcbae35da0cb9d9ec14740db108d66483e7209d39449e370a55aa11ce1f8d179d6e0a5b1b00b3b17b85af77813eea1
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.9.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.9.ebuild
new file mode 100644
index 000000000000..97351b6920ac
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}