summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Coppens <coppens.matthias.abc@gmail.com>2020-08-10 01:08:11 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-06 08:55:17 +0300
commit74436838a0da53e067c2bb8a80e21f2df13244ee (patch)
tree88267e5bd74a7c881648118b31eafd2002bc0145 /app-i18n
parentsys-fs/simple-mtpfs: update fuse dependency slot (diff)
downloadgentoo-74436838a0da53e067c2bb8a80e21f2df13244ee.tar.gz
gentoo-74436838a0da53e067c2bb8a80e21f2df13244ee.tar.bz2
gentoo-74436838a0da53e067c2bb8a80e21f2df13244ee.zip
app-i18n/uchardet: Version bump + maintainership
+ Added version 0.0.7, patch from 0.0.6-r2 isn't needed there + EAPI 6 -> 7 + Eclass cmake-utils -> cmake + I've adopted this orphaned package Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Matthias Coppens <coppens.matthias.abc@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17066 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/uchardet/Manifest1
-rw-r--r--app-i18n/uchardet/metadata.xml15
-rw-r--r--app-i18n/uchardet/uchardet-0.0.7.ebuild36
-rw-r--r--app-i18n/uchardet/uchardet-9999.ebuild18
4 files changed, 60 insertions, 10 deletions
diff --git a/app-i18n/uchardet/Manifest b/app-i18n/uchardet/Manifest
index c07df8b95bd5..6d0131253a35 100644
--- a/app-i18n/uchardet/Manifest
+++ b/app-i18n/uchardet/Manifest
@@ -1 +1,2 @@
DIST uchardet-0.0.6.tar.xz 169192 BLAKE2B a0bc80ecd12565c1459b8136e3dc0530250571b5adbe4a7013c561f846f64f58482b9fd9cc5aa7493f20e913f59504a6e08c26571bf33ff34b4823f55d857b8c SHA512 eceeadae060bf277e298d709856609dde32921271140dc1fb0a33c7b6e1381033fc2960d616ebbd82c92815936864d2c0743b1b5ea1b7d4a200df87df80d6de5
+DIST uchardet-0.0.7.tar.xz 215492 BLAKE2B 1f8b171676bc6edf1f3493a4a370e32b7b956104ea0b12a03837d817c386d59aa512c3a107426aedb087987cf3a7b99c4b2df4a667ed685ff9959f6bc6b4506c SHA512 ddb7b63dd09c1d9acbe620d86217e583d9aa5340780ab4010ec9faa4fd331498859d5efa7829bf8847da89325accf8f7304b51d410210178fc1ffa6658064a6f
diff --git a/app-i18n/uchardet/metadata.xml b/app-i18n/uchardet/metadata.xml
index df067141bad0..3c431c24f073 100644
--- a/app-i18n/uchardet/metadata.xml
+++ b/app-i18n/uchardet/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <bugs-to>https://bugs.freedesktop.org/enter_bug.cgi?product=uchardet</bugs-to>
- </upstream>
+ <maintainer type="person">
+ <email>coppens.matthias.abc@gmail.com</email>
+ <name>Matthias Coppens</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugs.freedesktop.org/enter_bug.cgi?product=uchardet</bugs-to>
+ </upstream>
</pkgmetadata>
diff --git a/app-i18n/uchardet/uchardet-0.0.7.ebuild b/app-i18n/uchardet/uchardet-0.0.7.ebuild
new file mode 100644
index 000000000000..777ebc8cfb7c
--- /dev/null
+++ b/app-i18n/uchardet/uchardet-0.0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+if [ "${PV}" = 9999 ]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"
+else
+ SRC_URI="https://www.freedesktop.org/software/uchardet/releases/${P}.tar.xz"
+fi
+
+DESCRIPTION="An encoding detector library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"
+
+LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cpu_flags_x86_sse2 static-libs test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ cmake_src_prepare
+ use test || cmake_comment_add_subdirectory test
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DTARGET_ARCHITECTURE="${ARCH}"
+ -DBUILD_STATIC=$(usex static-libs)
+ -DCHECK_SSE2=$(usex cpu_flags_x86_sse2)
+ )
+ cmake_src_configure
+}
diff --git a/app-i18n/uchardet/uchardet-9999.ebuild b/app-i18n/uchardet/uchardet-9999.ebuild
index 0aef01cb3c64..031c6d829482 100644
--- a/app-i18n/uchardet/uchardet-9999.ebuild
+++ b/app-i18n/uchardet/uchardet-9999.ebuild
@@ -1,13 +1,19 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils git-r3
+inherit cmake
+if [ "${PV}" = 9999 ]
+then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"
+else
+ SRC_URI="https://www.freedesktop.org/software/uchardet/releases/${P}.tar.xz"
+fi
DESCRIPTION="An encoding detector library"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/uchardet/uchardet.git"
LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
SLOT="0"
@@ -16,7 +22,7 @@ IUSE="cpu_flags_x86_sse2 static-libs test"
RESTRICT="!test? ( test )"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
use test || cmake_comment_add_subdirectory test
}
@@ -26,5 +32,5 @@ src_configure() {
-DBUILD_STATIC=$(usex static-libs)
-DCHECK_SSE2=$(usex cpu_flags_x86_sse2)
)
- cmake-utils_src_configure
+ cmake_src_configure
}