summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-11-10 08:21:04 -0500
committerMichael Orlitzky <mjo@gentoo.org>2019-11-10 08:24:26 -0500
commit97f93ee0f1f33717e56e8f1edd41253e4ed7facd (patch)
treecb8f24559eca8d85a80c52addc44c2c3f9ff2911 /app-laptop
parentapp-laptop/hdaps-gl: add myself as maintainer. (diff)
downloadgentoo-97f93ee0f1f33717e56e8f1edd41253e4ed7facd.tar.gz
gentoo-97f93ee0f1f33717e56e8f1edd41253e4ed7facd.tar.bz2
gentoo-97f93ee0f1f33717e56e8f1edd41253e4ed7facd.zip
app-laptop/hdaps-gl: new EAPI=7 revision.
The ancient v0.0.5 is still the latest version, but surprisingly it still works well. The new revision just cleans things up a bit. Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild b/app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..6e145279052f
--- /dev/null
+++ b/app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="OpenGL visualization for HDAPS data"
+HOMEPAGE="http://hdaps.sourceforge.net"
+SRC_URI="mirror://sourceforge/hdaps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND=""
+DEPEND="virtual/opengl
+ media-libs/freeglut"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-as-needed.diff" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin "${PN}"
+}