summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/hexcompare
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/hexcompare')
-rw-r--r--app-misc/hexcompare/Manifest2
-rw-r--r--app-misc/hexcompare/files/hexcompare-1.0.1.patch52
-rw-r--r--app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch14
-rw-r--r--app-misc/hexcompare/hexcompare-1.0.1.ebuild38
-rw-r--r--app-misc/hexcompare/hexcompare-1.0.4.ebuild29
-rw-r--r--app-misc/hexcompare/metadata.xml11
6 files changed, 146 insertions, 0 deletions
diff --git a/app-misc/hexcompare/Manifest b/app-misc/hexcompare/Manifest
new file mode 100644
index 000000000000..c916b102200a
--- /dev/null
+++ b/app-misc/hexcompare/Manifest
@@ -0,0 +1,2 @@
+DIST hexcompare-1.0.4.tar.gz 9686 SHA256 a9609b28099d7578228f359a460a06f7fc1ae8cde614ea10e525b88eb04a9451 SHA512 847bf7e26f27aa0ff56e38b3fe95ad7940a0226e0c496963530fa405d8a3a50f8288a4c7f28d48d4cce05e52c1f69180917a7f10da0943cabf977f78b62eb5fe WHIRLPOOL 45925df7b39ccd9f27532f8148b70a106a50958bac0f129bb37b408b3916dbd801713fac790c0326489a4843b300bd0ccd0d55a62c832caefc0b8090fda15d1b
+DIST hexcompare-101.tar.gz 8718 SHA256 3aad559a1784aacd315109ebad47ab99364ad8c9ab6410463f3d457d5d7e7e76 SHA512 dacce9eefc37b139347452aaf1698f0f1c9fc9b6bca83487154aab840735cd3a46ddb333b76a268149b99d4ef786123cd1799dfb809c047ada62dd87d8dd5dc2 WHIRLPOOL b0979a4d6f8df3fce4530c9baf1d1dcaca39ed753fc81fe28443e30f43a11e56dcbb31e9519fa428a5bd7e6a3be2462c26056a8e0e8fa0f3e5578c3bd3adccf1
diff --git a/app-misc/hexcompare/files/hexcompare-1.0.1.patch b/app-misc/hexcompare/files/hexcompare-1.0.1.patch
new file mode 100644
index 000000000000..8971a5e2c703
--- /dev/null
+++ b/app-misc/hexcompare/files/hexcompare-1.0.1.patch
@@ -0,0 +1,52 @@
+--- hexcompare-101/gui.c
++++ hexcompare-101/gui.c
+@@ -39,7 +39,7 @@
+ {
+ // With a given offset, calculate which element it corresponds to
+ // in the offset_index.
+- int i, current_block;
++ int i, current_block = 0;
+ for (i = 0; i < total_blocks; i++) {
+
+ // Go block by block, and see if our offset is greater than
+@@ -62,7 +62,7 @@
+ char offset_query[32];
+ char offset_line[32];
+ int offset_size = 0;
+- int previous_size, current_size, i;
++ int previous_size, current_size = 0, i;
+ int redo_loop = false;
+
+ // Endless loop until we figure out an offset size that is constant
+@@ -533,10 +533,6 @@
+
+ // Create variables.
+ int i, j;
+- bool active_declared = false;
+- int offset_string_length = 0;
+- unsigned long temp_offset;
+- char offset_line[32];
+
+ // Define colors block diagram.
+ init_pair(BLOCK_SAME, COLOR_WHITE, COLOR_BLUE);
+@@ -621,12 +617,6 @@
+ //
+ //
+
+- // Create variables.
+- int i, j;
+- bool active_declared = false;
+- int offset_string_length = 0;
+- unsigned long temp_offset;
+-
+ // Define colors block diagram.
+ init_pair(BLOCK_SAME, COLOR_WHITE, COLOR_BLUE);
+ init_pair(BLOCK_DIFFERENT, COLOR_WHITE, COLOR_RED);
+@@ -753,7 +743,6 @@
+ while((key_pressed = wgetch(main_window)) != 'q')
+ {
+ int rows;
+- int bytes_per_row = (width - SIDE_MARGIN*2) * bytes_per_block;
+ if (mode == OVERVIEW_MODE) rows = 5; else rows = height - 5;
+
+ switch(key_pressed)
diff --git a/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
new file mode 100644
index 000000000000..5ccef2047bc7
--- /dev/null
+++ b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
@@ -0,0 +1,14 @@
+--- hexcompare-1.0.4/Makefile
++++ hexcompare-1.0.4/Makefile
+@@ -1,9 +1,9 @@
+-CFLAGS = -O3 -Wall -Wextra -pedantic -Wformat-security -std=gnu89
++CFLAGS += -Wall -Wextra -pedantic -Wformat-security -std=gnu89
+
+ all: hexcompare
+
+ hexcompare: main.c gui.c
+- $(CC) $(CFLAGS) -o hexcompare main.c gui.c -lncurses
++ $(CC) $(CFLAGS) `pkg-config --cflags ncurses` -o hexcompare main.c gui.c `pkg-config --libs ncurses`
+
+ clean:
+ rm -f *.o
diff --git a/app-misc/hexcompare/hexcompare-1.0.1.ebuild b/app-misc/hexcompare/hexcompare-1.0.1.ebuild
new file mode 100644
index 000000000000..b05a75e5693d
--- /dev/null
+++ b/app-misc/hexcompare/hexcompare-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils toolchain-funcs versionator
+
+DESCRIPTION="ncurses-based visual comparison of binary files"
+HOMEPAGE="http://hexcompare.sourceforge.net/"
+MY_P=${PN}-$(replace_all_version_separators '')
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_compile() {
+ $(tc-getCC) \
+ ${CFLAGS} $(/usr/bin/ncurses5-config --cflags) \
+ -o ${PN} main.c gui.c \
+ ${LDFLAGS} $(/usr/bin/ncurses5-config --libs) || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ dodoc README || die
+}
diff --git a/app-misc/hexcompare/hexcompare-1.0.4.ebuild b/app-misc/hexcompare/hexcompare-1.0.4.ebuild
new file mode 100644
index 000000000000..67f2047c110a
--- /dev/null
+++ b/app-misc/hexcompare/hexcompare-1.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="ncurses-based visual comparison of binary files"
+HOMEPAGE="http://hexcompare.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:5"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}
diff --git a/app-misc/hexcompare/metadata.xml b/app-misc/hexcompare/metadata.xml
new file mode 100644
index 000000000000..d5c82fe0dcaf
--- /dev/null
+++ b/app-misc/hexcompare/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">hexcompare</remote-id>
+ </upstream>
+</pkgmetadata>