summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/ktoblzcheck
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/ktoblzcheck')
-rw-r--r--app-misc/ktoblzcheck/Manifest3
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.39.ebuild54
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.45.ebuild41
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.48.ebuild41
-rw-r--r--app-misc/ktoblzcheck/metadata.xml10
5 files changed, 149 insertions, 0 deletions
diff --git a/app-misc/ktoblzcheck/Manifest b/app-misc/ktoblzcheck/Manifest
new file mode 100644
index 000000000000..81cf00595bc4
--- /dev/null
+++ b/app-misc/ktoblzcheck/Manifest
@@ -0,0 +1,3 @@
+DIST ktoblzcheck-1.39.tar.gz 547649 SHA256 c7017be79b58d0b6c2e919877b7d320da5dcba92d558f36f437da34d9b2dcb41 SHA512 d393fef7aba5af7a0f3901b9a646f5869e66116c1ac065f091d0c6d10bb8fd305ade2acdc1ad64c3f4cecd1ed4162a0b1b5ddc92cd557aa0f9bdfa3dd6225734 WHIRLPOOL 33fd63878ff88c15090aa4eceed30c8edc4021a7bed851068fe6d244b6ce26714616c75ab8821568e13b27a5dec4e4ed8b2b2be8834b24c7ce8c2b42f930496e
+DIST ktoblzcheck-1.45.tar.gz 572929 SHA256 f5be987c7f7c6935ad8ef80349beea6852f16dd9e16fd1494c9864ce3394a289 SHA512 07c8ed763961c245f55e739d6d821d09d7fe8965365dd74f1e14d5a634eb55dcb8e7abc50700a905450510c2491a1776cc03bf343391147e373e238d30fbb5d8 WHIRLPOOL 2a9304e4052c79d76708823bfdd21b90d7c5206ca6612b6e3b79b5965612d6b4eb7f25b6a45284aafe8b7ac860e6185f3bedd1df4b195cbc7c135d1faf317fba
+DIST ktoblzcheck-1.48.tar.gz 561054 SHA256 0f4e66d3a880355b1afc88870d224755e078dfaf192242d9c6acb8853f5bcf58 SHA512 897a98b7f39cee43f46fb34009e5d51b06fc0734f4c6e50adf888e9663114c7f927ba5b34cfe8786cb4558621828a580076cd975512a253f247b1e4ce5cfb089 WHIRLPOOL 71a4734aecc042ac2ca6a1cea84fbd70303df3666a76b09696c53ff883c7e0de7588b7eb393774327dd601fb6a4e23aa13b116da2995d006f6b8777f4de8f42d
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.39.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.39.ebuild
new file mode 100644
index 000000000000..83015d8a81a8
--- /dev/null
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.39.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+PYTHON_DEPEND="python? 2:2.6"
+inherit python
+
+DESCRIPTION="Library to check account numbers and bank codes of German banks"
+HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 ~sparc x86"
+IUSE="python"
+
+RDEPEND="app-text/recode
+ virtual/awk
+ sys-apps/grep
+ sys-apps/sed
+ || ( net-misc/wget www-client/lynx )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2.6b"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ >py-compile
+}
+
+src_configure() {
+ econf $(use_enable python)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize ktoblzcheck.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ktoblzcheck.py
+}
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.45.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.45.ebuild
new file mode 100644
index 000000000000..ef4c0fd303e7
--- /dev/null
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.45.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="Library to check account numbers and bank codes of German banks"
+HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+
+RDEPEND="app-text/recode
+ virtual/awk
+ sys-apps/grep
+ sys-apps/sed
+ || ( net-misc/wget www-client/lynx )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2.6b"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf $(use_enable python)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.48.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.48.ebuild
new file mode 100644
index 000000000000..c2ee3f03ebe3
--- /dev/null
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.48.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="Library to check account numbers and bank codes of German banks"
+HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+
+RDEPEND="app-text/recode
+ virtual/awk
+ sys-apps/grep
+ sys-apps/sed
+ || ( net-misc/wget www-client/lynx )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2.6b"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf $(use_enable python)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/app-misc/ktoblzcheck/metadata.xml b/app-misc/ktoblzcheck/metadata.xml
new file mode 100644
index 000000000000..a1c6038a6128
--- /dev/null
+++ b/app-misc/ktoblzcheck/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ktoblzcheck</remote-id>
+ </upstream>
+</pkgmetadata>