summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-29 00:53:44 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-03-29 01:07:28 +0200
commit1435fff38b1905f33b72a2f2a300e96cb2ea26d0 (patch)
treef39e11d8c51508142c2998981785eb4b70259806 /app-misc/openrgb
parentdev-ruby/date: Stabilize 3.3.3 ppc, #903443 (diff)
downloadgentoo-1435fff38b1905f33b72a2f2a300e96cb2ea26d0.tar.gz
gentoo-1435fff38b1905f33b72a2f2a300e96cb2ea26d0.tar.bz2
gentoo-1435fff38b1905f33b72a2f2a300e96cb2ea26d0.zip
app-misc/openrgb: patch for GCC 13
Bug: https://gitlab.com/CalcProgrammer1/OpenRGB/-/merge_requests/1743 Closes: https://bugs.gentoo.org/895428 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-misc/openrgb')
-rw-r--r--app-misc/openrgb/files/openrgb-0.8-gcc-13.patch36
-rw-r--r--app-misc/openrgb/openrgb-0.8-r1.ebuild4
2 files changed, 39 insertions, 1 deletions
diff --git a/app-misc/openrgb/files/openrgb-0.8-gcc-13.patch b/app-misc/openrgb/files/openrgb-0.8-gcc-13.patch
new file mode 100644
index 000000000000..2a78d8f4ab5c
--- /dev/null
+++ b/app-misc/openrgb/files/openrgb-0.8-gcc-13.patch
@@ -0,0 +1,36 @@
+diff --git a/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp b/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp
+index 2bdc37ad695dfdc870cb912f17fffd54bda2b89b..17080edb896f74c9393049041c25347d38a8a6f5 100644
+--- a/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp
++++ b/Controllers/ENESMBusController/ENESMBusInterface/ENESMBusInterface_SpectrixS40G.cpp
+@@ -10,6 +10,7 @@
+ #include "ENESMBusInterface_SpectrixS40G.h"
+ #include <sys/ioctl.h>
+ #include <cstring>
++#include <cstdint>
+
+ /*---------------------------------------------------------------------*\
+ | Functions for submitting NVME admin passthrough command taken from |
+diff --git a/Controllers/SteelSeriesController/SteelSeriesMouseController.h b/Controllers/SteelSeriesController/SteelSeriesMouseController.h
+index 64df7a1cc0351ccb8f306984c8b554f8eb3dcc6e..a4e561a3504c1def8acdd1921dc3955df7f68271 100644
+--- a/Controllers/SteelSeriesController/SteelSeriesMouseController.h
++++ b/Controllers/SteelSeriesController/SteelSeriesMouseController.h
+@@ -10,6 +10,7 @@
+ #include <hidapi/hidapi.h>
+ #include <vector>
+ #include "SteelSeriesGeneric.h"
++#include <cstdint>
+
+ #pragma once
+
+diff --git a/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp b/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp
+index 8f0cd4cdb637ea5f474b1caf587dc3c98c5dba89..367e9175b07548845696616aef86920ca2536bb4 100644
+--- a/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp
++++ b/Controllers/SteelSeriesController/SteelSeriesRivalController.cpp
+@@ -11,6 +11,7 @@
+ #include <cstring>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <cstdint>
+
+ static void send_usb_msg(hid_device* dev, char * data_pkt, unsigned int size)
+ {
diff --git a/app-misc/openrgb/openrgb-0.8-r1.ebuild b/app-misc/openrgb/openrgb-0.8-r1.ebuild
index 672546f43e85..05c82b84efb7 100644
--- a/app-misc/openrgb/openrgb-0.8-r1.ebuild
+++ b/app-misc/openrgb/openrgb-0.8-r1.ebuild
@@ -18,7 +18,8 @@ fi
DESCRIPTION="Open source RGB lighting control"
HOMEPAGE="https://openrgb.org https://gitlab.com/CalcProgrammer1/OpenRGB/"
LICENSE="GPL-2"
-# subslot is OPENRGB_PLUGIN_API_VERSION from https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
+# subslot is OPENRGB_PLUGIN_API_VERSION from
+# https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
SLOT="0/2"
RDEPEND="
@@ -41,6 +42,7 @@ BDEPEND="
"
PATCHES+=(
+ "${FILESDIR}"/${PN}-0.8-gcc-13.patch
"${FILESDIR}"/OpenRGB-0.7-r1-udev.patch
"${FILESDIR}"/OpenRGB-0.8-includes.patch
)