summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/rl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/rl')
-rw-r--r--app-misc/rl/Manifest1
-rw-r--r--app-misc/rl/metadata.xml10
-rw-r--r--app-misc/rl/rl-0.2.7.ebuild26
3 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/rl/Manifest b/app-misc/rl/Manifest
new file mode 100644
index 000000000000..17427f8ce248
--- /dev/null
+++ b/app-misc/rl/Manifest
@@ -0,0 +1 @@
+DIST rl-0.2.7.tar.gz 131028 SHA256 1cfca23d6a14acd190c5a6261923757d20cb94861c9b2066991ec7a7cae33bc8 SHA512 c9db8564832494148ed8e60df844a2a383e52b9d293564cf46b393e57a88f773b7307a1dd749d4e5e2daef1632b5350de00ab2585478ff3c18bffa1c5c573f8d WHIRLPOOL ee388274029b4ed5c8bc58f27a8fc1c9ccc7be2167426d5e4751eb26f88a238084bde89d9c036fd5d067ceff72e3191a4b32aa0e067c491ce6b87d20f077654c
diff --git a/app-misc/rl/metadata.xml b/app-misc/rl/metadata.xml
new file mode 100644
index 000000000000..7d749dcbefb7
--- /dev/null
+++ b/app-misc/rl/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <maintainer>
+ <email>swegener@gentoo.org</email>
+ <description>primary maintainer</description>
+ </maintainer>
+ <longdescription>randomize lines can be used to randomize the contents of text files or standard input.</longdescription>
+</pkgmetadata>
diff --git a/app-misc/rl/rl-0.2.7.ebuild b/app-misc/rl/rl-0.2.7.ebuild
new file mode 100644
index 000000000000..eb7d68467b79
--- /dev/null
+++ b/app-misc/rl/rl-0.2.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Randomize lines from text files or stdin"
+HOMEPAGE="http://ch.tudelft.nl/~arthur/rl/"
+SRC_URI="http://ch.tudelft.nl/~arthur/rl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~mips ppc s390 sparc x86"
+IUSE="debug"
+
+src_compile() {
+ local myconf=""
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO || die
+}