summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Leupold <tobias.leupold@gmx.de>2017-11-05 15:55:55 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-09 18:58:23 +0100
commitcb927f919b08c29f682c39b2448325205f802282 (patch)
tree0b1f47848827cf4c1574a78e10ea5dd4b6147b4b /app-misc/vcontrold
parentwww-client/vivaldi-snapshot: Old. (diff)
downloadgentoo-cb927f919b08c29f682c39b2448325205f802282.tar.gz
gentoo-cb927f919b08c29f682c39b2448325205f802282.tar.bz2
gentoo-cb927f919b08c29f682c39b2448325205f802282.zip
app-misc/vcontrold: Daemon for comm with Viessmann Vito heatings
Closes: https://bugs.gentoo.org/574964 Closes: https://github.com/gentoo/gentoo/pull/6132
Diffstat (limited to 'app-misc/vcontrold')
-rw-r--r--app-misc/vcontrold/Manifest1
-rw-r--r--app-misc/vcontrold/files/vcontrold5
-rw-r--r--app-misc/vcontrold/metadata.xml28
-rw-r--r--app-misc/vcontrold/vcontrold-0.98.5.ebuild43
4 files changed, 77 insertions, 0 deletions
diff --git a/app-misc/vcontrold/Manifest b/app-misc/vcontrold/Manifest
new file mode 100644
index 000000000000..7c116c628378
--- /dev/null
+++ b/app-misc/vcontrold/Manifest
@@ -0,0 +1 @@
+DIST vcontrold-0.98.5.tar.gz 86684 BLAKE2B 07ed2c932b9f1c03410cbd6c23cfbfb7bf1aeaff027f597fb6f05a6b61c647f229a75b5a87d893a66c6b8e917595083d193c5da8585c6b9546d12c5867ca1a1b SHA512 b94dbb09ffe274e0a0a0ac4948365ed3213f221dbc00ed2b2adec2ac5a632e293686d62a07575454b3d11b1b8e4e058625a067461996dd720c2f84066d57e60e
diff --git a/app-misc/vcontrold/files/vcontrold b/app-misc/vcontrold/files/vcontrold
new file mode 100644
index 000000000000..369dc6d8e642
--- /dev/null
+++ b/app-misc/vcontrold/files/vcontrold
@@ -0,0 +1,5 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/sbin/vcontrold"
diff --git a/app-misc/vcontrold/metadata.xml b/app-misc/vcontrold/metadata.xml
new file mode 100644
index 000000000000..b718f1673eb4
--- /dev/null
+++ b/app-misc/vcontrold/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>tobias.leupold@gmx.de</email>
+ <name>Tobias Leupold</name>
+</maintainer>
+<maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+</maintainer>
+<longdescription lang="en">
+ Vcontrold can be used for communication with Viessmann Vito heatings
+ through their Optolink interface using an optical communication device
+ (which can be built quite cheap and easily, cf. the homepage of the
+ "OpenV" project).
+</longdescription>
+<use>
+ <flag name="man">Build the manpages</flag>
+ <flag name="vclient">
+ Build the vclient helper program to talk to vcontrold
+ </flag>
+ <flag name="vsim">
+ Build the vsim helper program (simulates the heating's answers, for
+ development and debugging)
+ </flag>
+</use>
+</pkgmetadata>
diff --git a/app-misc/vcontrold/vcontrold-0.98.5.ebuild b/app-misc/vcontrold/vcontrold-0.98.5.ebuild
new file mode 100644
index 000000000000..e5b4f78672d4
--- /dev/null
+++ b/app-misc/vcontrold/vcontrold-0.98.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Daemon for communication with Viessmann Vito heatings"
+HOMEPAGE="https://github.com/openv/vcontrold/"
+SRC_URI="https://github.com/openv/vcontrold/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+man +vclient vsim"
+
+RDEPEND="dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ man? ( dev-python/docutils )"
+
+src_prepare() {
+ sed "s/@VERSION@/${PV}/" "src/version.h.in" \
+ > "src/version.h" || die "Setting version failed"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DMANPAGES="$(usex man)"
+ -DVCLIENT="$(usex vclient)"
+ -DVSIM="$(usex vsim)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doinitd "${FILESDIR}/vcontrold"
+ insinto /etc/vcontrold/
+ doins -r xml
+}