summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-01-26 18:10:28 -0800
committerMatt Turner <mattst88@gentoo.org>2022-01-26 18:48:08 -0800
commit4fda7593ca579989ad296e2131bf861bda3112f8 (patch)
tree1e955f5d7e3c0a1e0aa453b43e2dab7f44bf11cf /app-misc
parentdev-python/notebook: keyword ~riscv, #832087 (diff)
downloadgentoo-4fda7593ca579989ad296e2131bf861bda3112f8.tar.gz
gentoo-4fda7593ca579989ad296e2131bf861bda3112f8.tar.bz2
gentoo-4fda7593ca579989ad296e2131bf861bda3112f8.zip
app-misc/tracker: Version bump to 3.2.1
Closes: https://bugs.gentoo.org/807985 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tracker/Manifest1
-rw-r--r--app-misc/tracker/files/tracker-3.2.1-Add-config-options-for-libsoup.patch41
-rw-r--r--app-misc/tracker/tracker-3.2.1.ebuild116
3 files changed, 158 insertions, 0 deletions
diff --git a/app-misc/tracker/Manifest b/app-misc/tracker/Manifest
index 73fe290c692a..5756be13c5d8 100644
--- a/app-misc/tracker/Manifest
+++ b/app-misc/tracker/Manifest
@@ -1,3 +1,4 @@
DIST tracker-2.3.5.tar.xz 1604004 BLAKE2B ad79682cb703056fd927649021a5f37fddb2e978ecc710d020c23ef5dd076f88c7e0c2cd9d4385343e9d6c2c2ac7473af7508d86793c505e2361a8021bf27d50 SHA512 74cd3b2671b811f3267a516e6f6047594fffa7c8a4a23fa5be4f7d71f581c417a88f12f614757418a848077a9231c0c876617d4486f3bb5b103382b871913d34
DIST tracker-2.3.6.tar.xz 1606716 BLAKE2B ea39df4438e4502bc0229a5cc3b42a2fe6e13a643ac8e4034004b1291da49ff3ad1a177227035a4a02fd8f3723a735d37371c898bb03a6fc10573606a1c29d70 SHA512 1b8ae06b6c64a0cbe7d4c987bafe392fb38014215fc698f919273ba1f422dd0bc24344d3fd73164b00bfea315e527e2886ba90f1f1b86d5fceff24455b36d67e
DIST tracker-3.1.2.tar.xz 1429356 BLAKE2B 2401ee4d73aef29a40ff9c9f917fdf4709884bc26b7e8c5ae52b0e009bfd1934a122a78adea2fe6950480f4ccacb89d11388b4553bd4c0c68f5738118d34d3a1 SHA512 3c5feb658d7d3e35bcc61ef216e59b069df661d6f13de6f26e71da35bd0ca78878099d1ae507da82860d955954f971ab68d5a3b86a3132781c3f03a12dec1f0c
+DIST tracker-3.2.1.tar.xz 1947304 BLAKE2B 9095a457157cd2bedfd34b01afc9fd832af0a5c57c6ba5b9c00175f382b70135e20437d6fd2ca9cc06df28634627e487536b15548f2c5d54c68297f26f06447b SHA512 3e8f33de0f77d45af2ed82e8fd216d6fb4c3aa080648cf490bdaef233fac1c635e10660ac0bfcdf0a43af48d454e0d4d7c04cb650f5f89660e8e4efc10104f56
diff --git a/app-misc/tracker/files/tracker-3.2.1-Add-config-options-for-libsoup.patch b/app-misc/tracker/files/tracker-3.2.1-Add-config-options-for-libsoup.patch
new file mode 100644
index 000000000000..c6895f36512f
--- /dev/null
+++ b/app-misc/tracker/files/tracker-3.2.1-Add-config-options-for-libsoup.patch
@@ -0,0 +1,41 @@
+From 6ebc7d09f005898236ee27a780f6fc0426cdd271 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Wed, 26 Jan 2022 18:08:24 -0800
+Subject: [PATCH] Add config options for libsoup
+
+---
+ meson.build | 4 ++--
+ meson_options.txt | 5 +++++
+ 2 files changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 4109293a9..39947437a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -53,8 +53,8 @@ json_glib = dependency('json-glib-1.0', version: '>= 1.4', required: true)
+ libxml2 = dependency('libxml-2.0', version: '> 2.6')
+ sqlite = dependency('sqlite3', version: '>' + sqlite_required)
+ dbus = dependency('dbus-1')
+-libsoup2 = dependency('libsoup-2.4', version: '> 2.40', required: false)
+-libsoup3 = dependency('libsoup-3.0', version: '>= 2.99.2', required: false)
++libsoup2 = dependency('libsoup-2.4', version: '> 2.40', required: get_option('libsoup2'))
++libsoup3 = dependency('libsoup-3.0', version: '>= 2.99.2', required: get_option('libsoup3'))
+
+ libmath = cc.find_library('m', required: false)
+ libdl = cc.find_library('dl')
+diff --git a/meson_options.txt b/meson_options.txt
+index a7e647d02..d431caa03 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -28,3 +28,8 @@ option('tests_tap_protocol', type: 'boolean', value: false,
+ description: 'Whether to enable TAP protocol on tests')
+ option('introspection', type: 'feature', value: 'enabled',
+ description: 'Whether to enable introspection')
++
++option('libsoup2', type: 'feature', value: 'enabled',
++ description: 'Whether to enable libsoup2')
++option('libsoup3', type: 'feature', value: 'enabled',
++ description: 'Whether to enable libsoup3')
+--
+2.34.1
+
diff --git a/app-misc/tracker/tracker-3.2.1.ebuild b/app-misc/tracker/tracker-3.2.1.ebuild
new file mode 100644
index 000000000000..81ebe3d808b7
--- /dev/null
+++ b/app-misc/tracker/tracker-3.2.1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+VALA_MIN_API_VERSION="0.40"
+
+inherit bash-completion-r1 flag-o-matic gnome.org gnome2-utils linux-info meson python-any-r1 systemd vala xdg
+
+DESCRIPTION="A tagging metadata database, search tool and indexer"
+HOMEPAGE="https://wiki.gnome.org/Projects/Tracker"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="3/0" # libtracker-sparql-3.0 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk-doc +miners stemmer test"
+RESTRICT="!test? ( test )"
+
+PV_SERIES=$(ver_cut 1-2)
+
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=sys-apps/dbus-1.3.2
+ >=dev-libs/gobject-introspection-1.54:=
+ >=dev-libs/icu-4.8.1.2:=
+ >=dev-libs/json-glib-1.4
+ >=net-libs/libsoup-2.40.1:2.4
+ >=dev-libs/libxml2-2.7
+ >=dev-db/sqlite-3.29.0
+ stemmer? ( dev-libs/snowball-stemmer:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ app-text/asciidoc
+ dev-libs/libxslt
+ $(vala_depend)
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.8
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xml-dtd:4.5
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ $(python_gen_any_dep 'dev-python/tappy[${PYTHON_USEDEP}]')
+ )
+ ${PYTHON_DEPS}
+"
+PDEPEND="miners? ( >=app-misc/tracker-miners-${PV_SERIES} )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-Fix-asciidoc-manpage.xsl-location.patch
+ "${FILESDIR}"/${PN}-3.2.1-Add-config-options-for-libsoup.patch
+)
+
+function inotify_enabled() {
+ if linux_config_exists; then
+ if ! linux_chkconfig_present INOTIFY_USER; then
+ ewarn "You should enable the INOTIFY support in your kernel."
+ ewarn "Check the 'Inotify support for userland' under the 'File systems'"
+ ewarn "option. It is marked as CONFIG_INOTIFY_USER in the config"
+ die 'missing CONFIG_INOTIFY'
+ fi
+ else
+ einfo "Could not check for INOTIFY support in your kernel."
+ fi
+}
+
+python_check_deps() {
+ use test || return 0
+ has_version -b "dev-python/tappy[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ inotify_enabled
+
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ append-cflags -DTRACKER_DEBUG -DG_DISABLE_CAST_CHECKS
+
+ local emesonargs=(
+ $(meson_use gtk-doc docs)
+ -Dman=true
+ $(meson_feature stemmer)
+ -Dunicode_support=icu
+ -Dbash_completion_dir="$(get_bashcompdir)"
+ -Dsystemd_user_services_dir="$(systemd_get_userunitdir)"
+ -Dintrospection=enabled
+ -Dlibsoup2=enabled
+ -Dlibsoup3=disabled
+ )
+ meson_src_configure
+}
+
+src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}