summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-10-21 19:23:51 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-21 19:25:03 +0200
commit96e14cddf235bc6e96196bb89e23bb6e1592a9cc (patch)
treecb990d612b900ed346494619b1f5bbc3929d8a78 /app-misc
parentapp-misc/joy2key: clean up old. (diff)
downloadgentoo-96e14cddf235bc6e96196bb89e23bb6e1592a9cc.tar.gz
gentoo-96e14cddf235bc6e96196bb89e23bb6e1592a9cc.tar.bz2
gentoo-96e14cddf235bc6e96196bb89e23bb6e1592a9cc.zip
app-misc/towitoko: EAPI 6 bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/towitoko/towitoko-2.0.7-r3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/towitoko/towitoko-2.0.7-r3.ebuild b/app-misc/towitoko/towitoko-2.0.7-r3.ebuild
new file mode 100644
index 000000000000..0538c5fd15b7
--- /dev/null
+++ b/app-misc/towitoko/towitoko-2.0.7-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Driver for Towitoko smartcard readers"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+
+IUSE="moneyplex"
+
+src_configure() {
+ local myconf
+ use moneyplex && myconf="--disable-atr-check"
+ econf \
+ $(use_enable moneyplex win32-com) \
+ "${myconf}"
+}
+
+pkg_postinst() {
+ if ! use moneyplex; then
+ elog "If you want to use the moneyplex home banking software from"
+ elog "http://www.matrica.de"
+ elog "then please re-emerge this package with 'moneyplex' in USE"
+ fi
+}