summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-01-28 07:56:17 +0000
committerSam James <sam@gentoo.org>2022-01-28 08:36:22 +0000
commitc6e90538f9d4beec31023efa68e87da7d6e28f50 (patch)
tree78effdff8c5d804b9a8c63970a9e58276f21bf7c /app-misc
parentwww-apps/gitea: drop vulnerable (diff)
downloadgentoo-c6e90538f9d4beec31023efa68e87da7d6e28f50.tar.gz
gentoo-c6e90538f9d4beec31023efa68e87da7d6e28f50.tar.bz2
gentoo-c6e90538f9d4beec31023efa68e87da7d6e28f50.zip
app-misc/elasticsearch: bump to 6.8.23/7.16.3
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/elasticsearch/Manifest3
-rw-r--r--app-misc/elasticsearch/elasticsearch-6.8.23.ebuild90
-rw-r--r--app-misc/elasticsearch/elasticsearch-7.16.3.ebuild83
3 files changed, 176 insertions, 0 deletions
diff --git a/app-misc/elasticsearch/Manifest b/app-misc/elasticsearch/Manifest
index 856eb9df3909..aedbbe137d56 100644
--- a/app-misc/elasticsearch/Manifest
+++ b/app-misc/elasticsearch/Manifest
@@ -1,3 +1,6 @@
DIST elasticsearch-6.8.22.tar.gz 149669518 BLAKE2B 7f942891d24491c5064179f38408de62bbb257c8a611f0cbba93eb144233c6353e24b636ffdd36aacf25d528fdc88892ca71525f18e126ffc4420d8bb325bbb1 SHA512 64539d9c451cb32de227cbbe54c2ae1d90ad97fd461d1b0f2f09cffa18f1b9ad787df43a38dfbb0899f7ba2766217bbb56d012d23c25dc3e716009da11c4d26c
+DIST elasticsearch-6.8.23.tar.gz 149672445 BLAKE2B dd7b080f1496f3a20755c183befae74194eab05b04c6f77679e9dad6067eef5222a4c7ce43d6267f1233a7bf864c6f8b23d5caf52278e1fe5f48f465e6603113 SHA512 73258b400cd194768058105a74ca0e811962ccf81bed8c4d3a824d4e5b97a8178a31150e60602fa1e04c6764b139980eb45ae6f246864702120653b45120b597
DIST elasticsearch-7.16.2-no-jdk-linux-x86_64.tar.gz 199602093 BLAKE2B c1cbb96e02b9f6eff3839bc8e9aa69b60b10f8c41bc18140aee3ba09120b59a36ee8d90e0f08942c8e6726da37d7380d9b1adc5e3c3991ffecaea7d2964b1c07 SHA512 4e913e6657501a23830e138d0f7de7de57e80c0953078ecb10565770931bbba0eed37b38de0888f9618de579138d51ca16f0239048ff70de68330aba862aff8d
+DIST elasticsearch-7.16.3-no-jdk-linux-x86_64.tar.gz 167284956 BLAKE2B 9dfa13d6f08bf5bbd5752870839c344635e3cc6b9f34e92948f09afdfb3929c0942d89bd02d5844f40a80d18c2cac51c8bb207c0c830ad2853acf662f5e79845 SHA512 ec9747694ba9f8b76b1620e42addd106afa3d3c207dd3836afe2482556f8a982fa03f3536ebb762f12a6093c9a5eac63cdbf2f1941dde9e3ce69c41652749d4f
DIST elasticsearch-oss-6.8.22.tar.gz 68572525 BLAKE2B c98ae3aeffead132ec884e10f3ddc8eaac853f654279214fcb268e9941a49bc9f0156fbdca6d5a538dbc5dabdbba2c23d16fe36327faa24eb2d204aec5fa54a6 SHA512 44019994f9a59a1d96ffc54847a4a7c90f70ece2c661c710878f643d6439d83b7ee6a205f445b1bfb2e7ab3de733434a6241f7b454159142e6e68255e8807e52
+DIST elasticsearch-oss-6.8.23.tar.gz 68573265 BLAKE2B 80366fdc4eaaf45161a36da112397938a82d08d842d82dd5a9311abf63ca20afb93ecc06387c6852bbb1a861306382d6e7c2314e67635b6f2e75cdc183057ad8 SHA512 14dbb2809b06499373c3ec5035d829d62255c2c93103618fbfe3d7d03cecf8847f654e83c78f765f23224126ff18ed713b959857e8ecf435c475b11bcd143d3f
diff --git a/app-misc/elasticsearch/elasticsearch-6.8.23.ebuild b/app-misc/elasticsearch/elasticsearch-6.8.23.ebuild
new file mode 100644
index 000000000000..5fd5b2ceff2e
--- /dev/null
+++ b/app-misc/elasticsearch/elasticsearch-6.8.23.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd tmpfiles
+
+DESCRIPTION="Open Source, Distributed, RESTful, Search Engine"
+HOMEPAGE="https://www.elastic.co/products/elasticsearch"
+SRC_URI="x-pack? ( https://artifacts.elastic.co/downloads/${PN}/${P}.tar.gz )
+ !x-pack? ( https://artifacts.elastic.co/downloads/${PN}/${PN}-oss-${PV}.tar.gz )"
+LICENSE="Apache-2.0 BSD-2 LGPL-3 MIT public-domain x-pack? ( Elastic )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="x-pack"
+
+RDEPEND="acct-group/elasticsearch
+ acct-user/elasticsearch
+ virtual/jre:1.8"
+
+QA_PRESTRIPPED="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
+
+src_prepare() {
+ default
+
+ rm bin/*.{bat,exe} LICENSE.txt NOTICE.txt || die
+ rmdir logs || die
+
+ if use x-pack; then
+ rm bin/x-pack/*.bat || die
+ rm -r modules/x-pack-ml/platform/{darwin,windows}-x86_64 || die
+ fi
+}
+
+src_install() {
+ keepdir /etc/${PN}
+ keepdir /etc/${PN}/scripts
+
+ insinto /etc/${PN}
+ doins -r config/.
+ rm -r config || die
+
+ fowners root:${PN} /etc/${PN}
+ fperms 2750 /etc/${PN}
+
+ insinto /usr/share/${PN}
+ doins -r .
+
+ exeinto /usr/share/${PN}/bin
+ doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
+
+ chmod +x "${ED}"/usr/share/${PN}/bin/* || die
+
+ if use x-pack; then
+ chmod +x "${ED}"/usr/share/${PN}/modules/x-pack-ml/platform/linux-x86_64/bin/* || die
+ fi
+
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ fperms 0750 /var/{lib,log}/${PN}
+ dodir /usr/share/${PN}/plugins
+
+ insinto /etc/sysctl.d
+ newins "${FILESDIR}/${PN}.sysctl.d" ${PN}.conf
+
+ newconfd "${FILESDIR}/${PN}.conf.3" ${PN}
+ newinitd "${FILESDIR}/${PN}.init.6" ${PN}
+
+ systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles.d" ${PN}.conf
+ systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service
+}
+
+pkg_postinst() {
+ elog
+ elog "You may create multiple instances of ${PN} by"
+ elog "symlinking the init script:"
+ elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
+ elog
+ elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
+ elog "from /etc/${PN} into the configuration directory of the instance:"
+ elog "/etc/${PN}/instance"
+ elog
+ ewarn "Please make sure you have proper permissions on /etc/${PN}"
+ ewarn "prior to keystore generation or you may experience startup fails."
+ ewarn "chown root:${PN} /etc/${PN} && chmod 2750 /etc/${PN}"
+ ewarn "chown root:${PN} /etc/${PN}/${PN}.keystore && chmod 0660 /etc/${PN}/${PN}.keystore"
+
+ tmpfiles_process /usr/lib/tmpfiles.d/elasticsearch.conf
+}
diff --git a/app-misc/elasticsearch/elasticsearch-7.16.3.ebuild b/app-misc/elasticsearch/elasticsearch-7.16.3.ebuild
new file mode 100644
index 000000000000..be38b6a483a2
--- /dev/null
+++ b/app-misc/elasticsearch/elasticsearch-7.16.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd tmpfiles
+
+DESCRIPTION="Free and Open, Distributed, RESTful Search Engine"
+HOMEPAGE="https://www.elastic.co/elasticsearch/"
+SRC_URI="https://artifacts.elastic.co/downloads/${PN}/${P}-no-jdk-linux-x86_64.tar.gz"
+LICENSE="Apache-2.0 BSD-2 Elastic-2.0 LGPL-3 MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="acct-group/elasticsearch
+ acct-user/elasticsearch
+ sys-libs/zlib
+ virtual/jre"
+
+QA_PREBUILT="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
+QA_PRESTRIPPED="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
+
+src_prepare() {
+ default
+
+ rm LICENSE.txt NOTICE.txt || die
+ rmdir logs || die
+}
+
+src_install() {
+ keepdir /etc/${PN}
+ keepdir /etc/${PN}/scripts
+
+ insinto /etc/${PN}
+ doins -r config/.
+ rm -r config || die
+
+ fowners root:${PN} /etc/${PN}
+ fperms 2750 /etc/${PN}
+
+ insinto /usr/share/${PN}
+ doins -r .
+
+ exeinto /usr/share/${PN}/bin
+ doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
+
+ fperms -R +x /usr/share/${PN}/bin
+ fperms -R +x /usr/share/${PN}/modules/x-pack-ml/platform/linux-x86_64/bin
+
+ keepdir /var/{lib,log}/${PN}
+ fowners ${PN}:${PN} /var/{lib,log}/${PN}
+ fperms 0750 /var/{lib,log}/${PN}
+ dodir /usr/share/${PN}/plugins
+
+ insinto /etc/sysctl.d
+ newins "${FILESDIR}/${PN}.sysctl.d" ${PN}.conf
+
+ newconfd "${FILESDIR}/${PN}.conf.4" ${PN}
+ newinitd "${FILESDIR}/${PN}.init.8" ${PN}
+
+ systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
+ systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service
+
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfiles.d ${PN}.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process /usr/lib/tmpfiles.d/${PN}.conf
+
+ elog
+ elog "You may create multiple instances of ${PN} by"
+ elog "symlinking the init script:"
+ elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
+ elog
+ elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
+ elog "from /etc/${PN} into the configuration directory of the instance:"
+ elog "/etc/${PN}/instance"
+ elog
+ ewarn "Please make sure you have proper permissions on /etc/${PN}"
+ ewarn "prior to keystore generation or you may experience startup fails."
+ ewarn "chown root:${PN} /etc/${PN} && chmod 2750 /etc/${PN}"
+ ewarn "chown root:${PN} /etc/${PN}/${PN}.keystore && chmod 0660 /etc/${PN}/${PN}.keystore"
+}