summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-13 00:53:45 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-13 00:54:48 -0500
commit133314d45de7bd8868a451f8aa1a5a04c956c1a1 (patch)
tree7e30e9a6ddd2c41cae5edf1622422fd5709494ad /app-portage
parentnet-fs/davfs2: bump to 1.6.1 (diff)
downloadgentoo-133314d45de7bd8868a451f8aa1a5a04c956c1a1.tar.gz
gentoo-133314d45de7bd8868a451f8aa1a5a04c956c1a1.tar.bz2
gentoo-133314d45de7bd8868a451f8aa1a5a04c956c1a1.zip
app-portage/iwdevtools: add 0.10.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.10.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index ef36a601aa85..d9d9dd05deec 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.10.0.tar.gz 60808 BLAKE2B 31f5288c54513a95199c3e41e7147778276ffaa2a63bb88e49a91680fa53602c4d1883ccf9b78bf63eba2fefec3fcd50e45ce7a599a0b252eadfaca62f2d9a09 SHA512 e03eda68eced8a23476d6681bd8090f80b642c40e5ed7e3ecb758fe04e51f496be02042bb87f6b42e150d28086e7ce14b278a6fdd05f06725b184b328405d412
+DIST iwdevtools-0.10.1.tar.gz 61117 BLAKE2B fd5508a40a854987db7f2ecc0e68e100cd6a8b6cc5b90a9901bbf6c16336ebc497861e05a6c1683ac9082aa9f12a03cb47f7116da793fbd8e105ed78aae2bbb3 SHA512 0f04850f15edc8af368a87bbc665c62d5588f4220c2d15ca5c0dd00d2c8135f7e1294217c8aec313650b7b7aae6433b87bdc32306c2c4c6e6747e55a13adbbe0
diff --git a/app-portage/iwdevtools/iwdevtools-0.10.1.ebuild b/app-portage/iwdevtools/iwdevtools-0.10.1.ebuild
new file mode 100644
index 000000000000..037698e7008f
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.10.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}