summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-03 07:21:03 +0000
committerSam James <sam@gentoo.org>2020-12-03 07:21:25 +0000
commitbc660ab7669eecffca30e4ac7b11cd5e775da161 (patch)
tree0e39ddefc2801795b135f148a2c6e417b96746f6 /app-shells/thefuck
parentapp-shells/thefuck: add Python 3.8, 3.9 (diff)
downloadgentoo-bc660ab7669eecffca30e4ac7b11cd5e775da161.tar.gz
gentoo-bc660ab7669eecffca30e4ac7b11cd5e775da161.tar.bz2
gentoo-bc660ab7669eecffca30e4ac7b11cd5e775da161.zip
app-shells/thefuck: bump to 3.30
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells/thefuck')
-rw-r--r--app-shells/thefuck/Manifest1
-rw-r--r--app-shells/thefuck/thefuck-3.28.ebuild5
-rw-r--r--app-shells/thefuck/thefuck-3.30.ebuild41
3 files changed, 42 insertions, 5 deletions
diff --git a/app-shells/thefuck/Manifest b/app-shells/thefuck/Manifest
index c41029c3faa2..d6ed1e34c906 100644
--- a/app-shells/thefuck/Manifest
+++ b/app-shells/thefuck/Manifest
@@ -1,2 +1,3 @@
DIST thefuck-3.27.tar.gz 1367120 BLAKE2B a840ac3e8f6807df632948e2fe2789a47bdcfececfd4a9bb0f1836bbaa641501e13c559221b9a2f25bbd93505c8b03db102636e480ece116a42c46f341d5cd35 SHA512 766c589f0e99a9773e74094e91c6a74d00e5be8b7241680ad664ecc3f549b597416bc7a4d289f399ed3a0d9ccad629ed78bb983edc809664c303c687ea1eec1a
DIST thefuck-3.28.tar.gz 1369230 BLAKE2B 0825ead15eae174b08bc2608ff64e1cd5993484a8aa6cc5cd1f6dbb3a856898e7c77eb9d5f92884f01261cf5cc5b00696c6e706a6553ce661866689e3d94d746 SHA512 6c3edcfff604567a18209bf46aceb662ed4549efd0e3b0daee1abee8a93fbe3ff4dfa260eb74c3d560b3a798e3cc90f911072d694a0d986a09c8581e951421d2
+DIST thefuck-3.30.tar.gz 1383210 BLAKE2B 9d6a7ba2712b5cea0146315f5023a104667531928ade93c4aee1f210f06755efb3488b82ce2bc63adf9ce41aec91528bbb6ee4212adb5eca2af53cacf4510a67 SHA512 99b270d0aa535673c09e7e932212af4ded5639fcf30ad0aeedc89a54e94c0a072a37883b1a1a56301efb82ea1c72cf53d4dacf2e83edcafcf4fbaa55ecd35f3a
diff --git a/app-shells/thefuck/thefuck-3.28.ebuild b/app-shells/thefuck/thefuck-3.28.ebuild
index ffcc66f3c8af..c55322df315f 100644
--- a/app-shells/thefuck/thefuck-3.28.ebuild
+++ b/app-shells/thefuck/thefuck-3.28.ebuild
@@ -32,10 +32,5 @@ distutils_enable_tests pytest
python_prepare_all() {
sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
-
distutils-r1_python_prepare_all
}
-
-python_test() {
- py.test -vv || die
-}
diff --git a/app-shells/thefuck/thefuck-3.30.ebuild b/app-shells/thefuck/thefuck-3.30.ebuild
new file mode 100644
index 000000000000..ffcc66f3c8af
--- /dev/null
+++ b/app-shells/thefuck/thefuck-3.30.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/pyte[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -vv || die
+}