summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-07-16 11:38:02 +0200
committerFabian Groffen <grobian@gentoo.org>2019-07-16 11:38:15 +0200
commit82219cbda3dbd39839cf010fde81fa70aaf6df9e (patch)
treeac510085b904d69da08a82a42f2fc39060189b65 /app-shells
parentapp-misc/vlock: Block >=sys-apps/kbd-2.1.0[pam] (diff)
downloadgentoo-82219cbda3dbd39839cf010fde81fa70aaf6df9e.tar.gz
gentoo-82219cbda3dbd39839cf010fde81fa70aaf6df9e.tar.bz2
gentoo-82219cbda3dbd39839cf010fde81fa70aaf6df9e.zip
app-shells/tcsh: add patch to fix USE=-nls, bug #689904
Closes: https://bugs.gentoo.org/689904 Signed-off-by: Fabian Groffen <grobian@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/tcsh/files/tcsh-6.21.00-no-nls.patch17
-rw-r--r--app-shells/tcsh/tcsh-6.21.00.ebuild1
2 files changed, 18 insertions, 0 deletions
diff --git a/app-shells/tcsh/files/tcsh-6.21.00-no-nls.patch b/app-shells/tcsh/files/tcsh-6.21.00-no-nls.patch
new file mode 100644
index 000000000000..a01ebfb57fdb
--- /dev/null
+++ b/app-shells/tcsh/files/tcsh-6.21.00-no-nls.patch
@@ -0,0 +1,17 @@
+GetCmdChar: fix compilation with --disable-nls
+
+Bug: https://bugs.gentoo.org/689904
+
+--- a/ed.inputl.c
++++ b/ed.inputl.c
+@@ -669,8 +669,8 @@
+ {
+ #ifndef WINNT_NATIVE // We use more than 256 for various extended keys
+- wint_t c = ch & CHAR;
++ eChar c = ch & CHAR;
+ #else
+- wint_t c = ch;
++ eChar c = ch;
+ #endif
+ return c < NT_NUM_KEYS ? CurrentKeyMap[c] : F_INSERT;
+ }
diff --git a/app-shells/tcsh/tcsh-6.21.00.ebuild b/app-shells/tcsh/tcsh-6.21.00.ebuild
index dadd2ea9de5a..c4e52506794f 100644
--- a/app-shells/tcsh/tcsh-6.21.00.ebuild
+++ b/app-shells/tcsh/tcsh-6.21.00.ebuild
@@ -32,6 +32,7 @@ CONFDIR=${WORKDIR}/tcsh-gentoo-patches-r${CONFVER}
PATCHES=(
"${FILESDIR}"/${PN}-6.20.00-debian-dircolors.patch # bug #120792
"${FILESDIR}"/${PN}-6.18.01-aix.patch
+ "${FILESDIR}"/${PN}-6.21.00-no-nls.patch
)
src_prepare() {