summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-10 20:19:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-10 20:44:02 +0200
commit6ca3ba7b1d4a2a17268aad7582daec0856e0dc8c (patch)
treee4813630f266b6c888df5d9617b43e76e5923b96 /app-text/libmwaw
parentwww-apps/liquid_feedback_core: bump to 3.2.2 (diff)
downloadgentoo-6ca3ba7b1d4a2a17268aad7582daec0856e0dc8c.tar.gz
gentoo-6ca3ba7b1d4a2a17268aad7582daec0856e0dc8c.tar.bz2
gentoo-6ca3ba7b1d4a2a17268aad7582daec0856e0dc8c.zip
app-text/libmwaw: 0.3.18 version bump
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/libmwaw')
-rw-r--r--app-text/libmwaw/Manifest1
-rw-r--r--app-text/libmwaw/libmwaw-0.3.18.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-text/libmwaw/Manifest b/app-text/libmwaw/Manifest
index b43737ef1ec8..b09316833b99 100644
--- a/app-text/libmwaw/Manifest
+++ b/app-text/libmwaw/Manifest
@@ -1 +1,2 @@
DIST libmwaw-0.3.17.tar.xz 1349700 BLAKE2B 4b5ba8d5133144973609dfbd273ca36cc95e52608c78f6143f7c4283bc2bc6d7ceb22836a693d64fa7408957a3b02a7c9d0a5ab9235aa2d0b9725170441babfc SHA512 c3a1bb079d7e74cd7a23de1501730be21b1b089ef6d4f81ee0001775483c6346da3105b0d67f75523e4e088987bc92b97acb056ec7fc11bb29047109a1cf5ac4
+DIST libmwaw-0.3.18.tar.xz 1382328 BLAKE2B eae75e24826a963032d866be1834221850a762447495a209ad1fe268c1072c877e4c19843d61e2e4d9322a48a03b459fa9a4cc734af0eabbb09813ff9626e466 SHA512 4666c0dcc567e3e4c0ae5d9651a7003d2f32acda841bd1e297d46e566430c9227588e29b219987c56f1347f6e5656b52b00d8d6d8fa7902e19d175505e345b7e
diff --git a/app-text/libmwaw/libmwaw-0.3.18.ebuild b/app-text/libmwaw/libmwaw-0.3.18.ebuild
new file mode 100644
index 000000000000..7363e33a0479
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.18.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc tools"
+
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ local myeconfargs=(
+ --enable-zip
+ --disable-static
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}