summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-06 03:39:45 +0000
committerSam James <sam@gentoo.org>2022-11-06 03:39:45 +0000
commit7615b933b9e801ee64e08c29b3c89401eedd6185 (patch)
tree2cf568666a05df4d1a2625b5a76bce058b235197 /app-text/libpaper
parentapp-admin/sudo: drop 1.9.12, 1.9.12-r1 (diff)
downloadgentoo-7615b933b9e801ee64e08c29b3c89401eedd6185.tar.gz
gentoo-7615b933b9e801ee64e08c29b3c89401eedd6185.tar.bz2
gentoo-7615b933b9e801ee64e08c29b3c89401eedd6185.zip
app-text/libpaper: add 2.0.3
Note that the help2man dep is back [0]. [0] https://github.com/rrthomas/libpaper/commit/def092de8ec83b75a80a4d468d58c4870b42440c Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/libpaper')
-rw-r--r--app-text/libpaper/Manifest1
-rw-r--r--app-text/libpaper/libpaper-2.0.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-text/libpaper/Manifest b/app-text/libpaper/Manifest
index 6b977695c395..3dfa50c7b3ac 100644
--- a/app-text/libpaper/Manifest
+++ b/app-text/libpaper/Manifest
@@ -1,4 +1,5 @@
DIST libpaper-2.0.0.tar.gz 1221217 BLAKE2B ef2c08ff7dc537734d080a29560a711b196b05a3b0c4b375c8dc73d4dd9588156d325d233e27940fac96a18dfa6bf523128b53eb4c7098e561aa6054efb88408 SHA512 ca5c79969a8c5d56322a6993917d5aa47089bb396a144edd0d9040b0bdde78c8fb59468a3d4063ae1fb323a1b23fb28169616d153de65f9085351b9c9d47f8c0
DIST libpaper-2.0.1.tar.gz 1229250 BLAKE2B 67730d6783d8ab9c2f837f8f477ab8ea04be7df2b2f419e81d57834c86bfcdd373ecc29cbea51fee06ca102ea12c18646f96caafe7b7cc53580153d01873a329 SHA512 ccc77e2f7805e7e5f6b3e96acffa9aeb2854a21acbdbb40947251a6a8dca6f9d97db0c8e2859d2056d3b60b06200ef50d9cccae58f961ff77f234ad1ab3c32dc
DIST libpaper-2.0.2.tar.gz 1287342 BLAKE2B 8044f372205c41834e06eba5c2210fdb57be72867bfe3035c16451c241d659ad18fd42bcb2c1e49074bb4da5d7f7061abdb7e783c4025544e64c093207ec3d62 SHA512 8360dd91b4f0972bd25774ea531037192e7233ffaf4295e4cde906c1085e32d61d35fa2c73636960ea105ab40836b9a505a057633115b287e4e54cd587980424
+DIST libpaper-2.0.3.tar.gz 1286822 BLAKE2B c3ac1628cb44155326626ddd5b7858a8192a4d23e888b152045001f3b8395ca46e0c82000838df13dd391dc187e10f82f843f75497dfb4c13e445f3587dea422 SHA512 c2af8f98a02b772ef3fb86b4f2bc50277f9fb720a070adc7a90da65881a5fc340b0841b198c50066001f4572123435305e0db4404365f9b9362d08280b7f6dd9
DIST libpaper_1.1.28.tar.gz 42356 BLAKE2B 48c4a28c6ff01bd91e257b6b306e787e5c6112052cff09bdb501d1cc4ddd10964c3588942098a6092d5a44391dfb22e10d5147d4c5012497f473473129ff7422 SHA512 3bf6ebb0af89931d2f72ea4a09a7fa958b2facda5f238983ec7bac39652e08614b33f0de3af74a03457b2a4203eee4950bf18a4b726e79aa64093ace6a1fb0bc
diff --git a/app-text/libpaper/libpaper-2.0.3.ebuild b/app-text/libpaper/libpaper-2.0.3.ebuild
new file mode 100644
index 000000000000..dcf04a114100
--- /dev/null
+++ b/app-text/libpaper/libpaper-2.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for handling paper characteristics"
+HOMEPAGE="https://github.com/rrthomas/libpaper"
+SRC_URI="https://github.com/rrthomas/libpaper/releases/download/v${PV}/${P}.tar.gz"
+
+# See README.
+# paperspecs is public-domain
+LICENSE="LGPL-2.1+ GPL-3+ public-domain"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="sys-apps/help2man"
+
+# False positive (runs within a conditional)
+QA_AM_MAINTAINER_MODE=".*help2man.*"
+
+src_configure() {
+ econf --enable-relocatable
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}