summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 13:04:08 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:01:00 +0100
commitb6d539c447bb03d322da0152d26fd8dfd8491a77 (patch)
tree7c9e60846bca1d87ef0a99e2da50d460cf228553 /app-text/pandoc
parentdev-haskell/tasty-lua: add package (diff)
downloadgentoo-b6d539c447bb03d322da0152d26fd8dfd8491a77.tar.gz
gentoo-b6d539c447bb03d322da0152d26fd8dfd8491a77.tar.bz2
gentoo-b6d539c447bb03d322da0152d26fd8dfd8491a77.zip
app-text/pandoc: bump up to 2.9.2.1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-text/pandoc')
-rw-r--r--app-text/pandoc/Manifest1
-rw-r--r--app-text/pandoc/metadata.xml1
-rw-r--r--app-text/pandoc/pandoc-2.9.2.1.ebuild112
3 files changed, 114 insertions, 0 deletions
diff --git a/app-text/pandoc/Manifest b/app-text/pandoc/Manifest
index feb748ef0df5..e764068e4e5d 100644
--- a/app-text/pandoc/Manifest
+++ b/app-text/pandoc/Manifest
@@ -4,3 +4,4 @@ DIST pandoc-1.14.0.4.tar.gz 2052114 BLAKE2B 12de5d3ab457718708f3181e78879b511c90
DIST pandoc-1.15.0.6.tar.gz 2049870 BLAKE2B d1495abd3451ec6e14fa13ca022051813bf736b9c15ff6106987c00bd53672fe027ad87d43d81faa15d50694fa1735a5ec31472738ff2b9a496e78d27c7656c9 SHA512 4c9bfea7440d6bdb72fb10a9a99b69c018db0ef0f1028d86b032e6c4df215c86566b93fd55c5cba7772d713d4ce3f764891de079dfa24de8ca21f818b7729211
DIST pandoc-1.18.tar.gz 2711663 BLAKE2B 3c324917285eb0bff314ff04add75aa6dfa381d1bb8dcc99078284be8c93cb8f5f9bacd9e557be1f07b2e6a4137b74d10e769b42e08f27bdfa0c6bd71aca4b12 SHA512 52bc68e9586366433e522a867946adf2e03219dfa4ca63cd6ff318ebb251f77ab16aa18f0350605fa31f8e085bb6cac9055f9661a0ef3cb5693faba9e124d049
DIST pandoc-1.19.2.1.tar.gz 2755101 BLAKE2B 1314ebe4084dd39521fed89c1d14b8365f2bfb40c6f8ff581ab6b2566bf5e5ef43c4014e383c2e17ac10bc66cbb159ae60a718d399873084b68c7fcd5fb90f2b SHA512 bb814c162b68efd00f249899ebb2cffa07c69bf0ac73838191de8da38dbc9a37b9edb0c24473c7ac8f816c0105d340ca7387c5f5c6f07a908e1537f4d35ef2f9
+DIST pandoc-2.9.2.1.tar.gz 12586844 BLAKE2B 298cafc88c33f461e6724cb60f4462398ab6a484eb4fcd598a488f4d599abc09f5e85faf16cc4da5c7cfc2274fb2ed1acf5cf9450bcc83c2ec810badfb7d6380 SHA512 35ac491a7e0a2f6d8fe0f2c2ffe265748b13920904e974f88c92b3f82edb2f1c03e28ebef1bc344ead13d566117a5e50707a68edc49f95159157f974210b23b2
diff --git a/app-text/pandoc/metadata.xml b/app-text/pandoc/metadata.xml
index 837984f412b5..33ba2477472a 100644
--- a/app-text/pandoc/metadata.xml
+++ b/app-text/pandoc/metadata.xml
@@ -16,6 +16,7 @@
</longdescription>
<use>
<flag name="embed-data-files">Embed data files in binary for relocatable executable.</flag>
+ <flag name="optimize">Enable -O1 optimizations (requires ~16GiB memory)</flag>
<flag name="http-conduit">Enable downloading of resources over https.</flag>
<flag name="trypandoc">Build trypandoc cgi executable.</flag>
<flag name="https">Enable support for downloading of resources over https.</flag>
diff --git a/app-text/pandoc/pandoc-2.9.2.1.ebuild b/app-text/pandoc/pandoc-2.9.2.1.ebuild
new file mode 100644
index 000000000000..878536e561c9
--- /dev/null
+++ b/app-text/pandoc/pandoc-2.9.2.1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion between markup formats"
+HOMEPAGE="https://pandoc.org"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="embed-data-files optimize static trypandoc"
+# test failure: error while loading shared libraries:
+# libHSpandoc-2.9.2.1-FD5JyeIDy0ZA6c46md2bYO-ghc8.8.3.so:
+# cannot open shared object file: No such file or directory
+RESTRICT=test
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?] <dev-haskell/aeson-1.5:=[profile?]
+ >=dev-haskell/aeson-pretty-0.8.5:=[profile?] <dev-haskell/aeson-pretty-0.9:=[profile?]
+ >=dev-haskell/attoparsec-0.12:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/base-compat-0.9:=[profile?]
+ >=dev-haskell/base-noprelude-4.9:=[profile?] <dev-haskell/base-noprelude-5:=[profile?]
+ >=dev-haskell/base64-bytestring-0.1:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-html-0.9:=[profile?] <dev-haskell/blaze-html-0.10:=[profile?]
+ >=dev-haskell/blaze-markup-0.8:=[profile?] <dev-haskell/blaze-markup-0.9:=[profile?]
+ >=dev-haskell/case-insensitive-1.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/cmark-gfm-0.2:=[profile?] <dev-haskell/cmark-gfm-0.3:=[profile?]
+ >=dev-haskell/data-default-0.4:=[profile?] <dev-haskell/data-default-0.8:=[profile?]
+ >=dev-haskell/doclayout-0.3:=[profile?] <dev-haskell/doclayout-0.4:=[profile?]
+ >=dev-haskell/doctemplates-0.8:=[profile?] <dev-haskell/doctemplates-0.9:=[profile?]
+ >=dev-haskell/emojis-0.1:=[profile?] <dev-haskell/emojis-0.2:=[profile?]
+ >=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/glob-0.7:=[profile?] <dev-haskell/glob-0.11:=[profile?]
+ >=dev-haskell/haddock-library-1.7:=[profile?] <dev-haskell/haddock-library-1.10:=[profile?]
+ >=dev-haskell/hslua-1.0.1:=[profile?] <dev-haskell/hslua-1.1:=[profile?]
+ >=dev-haskell/hslua-module-system-0.2:=[profile?] <dev-haskell/hslua-module-system-0.3:=[profile?]
+ >=dev-haskell/hslua-module-text-0.2:=[profile?] <dev-haskell/hslua-module-text-0.3:=[profile?]
+ >=dev-haskell/hsyaml-0.2:=[profile?] <dev-haskell/hsyaml-0.3:=[profile?]
+ >=dev-haskell/http-4000.0.5:=[profile?] <dev-haskell/http-4000.4:=[profile?]
+ >=dev-haskell/http-client-0.4.30:=[profile?] <dev-haskell/http-client-0.7:=[profile?]
+ >=dev-haskell/http-client-tls-0.2.4:=[profile?] <dev-haskell/http-client-tls-0.4:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?] <dev-haskell/http-types-0.13:=[profile?]
+ >=dev-haskell/ipynb-0.1:=[profile?] <dev-haskell/ipynb-0.2:=[profile?]
+ >=dev-haskell/jira-wiki-markup-1.1.3:=[profile?] <dev-haskell/jira-wiki-markup-1.2:=[profile?]
+ >=dev-haskell/juicypixels-3.1.6.1:=[profile?] <dev-haskell/juicypixels-3.4:=[profile?]
+ >=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?]
+ >=dev-haskell/pandoc-types-1.20:=[profile?] <dev-haskell/pandoc-types-1.21:=[profile?]
+ >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/random-1:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/sha-1.6:=[profile?] <dev-haskell/sha-1.7:=[profile?]
+ >=dev-haskell/skylighting-0.8.3.2:=[profile?] <dev-haskell/skylighting-0.9:=[profile?]
+ >=dev-haskell/skylighting-core-0.8.3.2:=[profile?] <dev-haskell/skylighting-core-0.9:=[profile?]
+ >=dev-haskell/split-0.2:=[profile?] <dev-haskell/split-0.3:=[profile?]
+ >=dev-haskell/syb-0.1:=[profile?] <dev-haskell/syb-0.8:=[profile?]
+ >=dev-haskell/tagsoup-0.14.6:=[profile?] <dev-haskell/tagsoup-0.15:=[profile?]
+ >=dev-haskell/temporary-1.1:=[profile?] <dev-haskell/temporary-1.4:=[profile?]
+ >=dev-haskell/texmath-0.12.0.1:=[profile?] <dev-haskell/texmath-0.13:=[profile?]
+ >=dev-haskell/text-1.1.1.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/text-conversions-0.3:=[profile?] <dev-haskell/text-conversions-0.4:=[profile?]
+ >=dev-haskell/unicode-transforms-0.3:=[profile?] <dev-haskell/unicode-transforms-0.4:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-haskell/xml-1.3.12:=[profile?] <dev-haskell/xml-1.4:=[profile?]
+ >=dev-haskell/zip-archive-0.2.3.4:=[profile?] <dev-haskell/zip-archive-0.5:=[profile?]
+ >=dev-haskell/zlib-0.5:=[profile?] <dev-haskell/zlib-0.7:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+ embed-data-files? ( >=dev-haskell/file-embed-0.0:=[profile?] <dev-haskell/file-embed-0.1:=[profile?] )
+ trypandoc? ( >=dev-haskell/wai-0.3:=[profile?]
+ dev-haskell/wai-extra:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.0
+ test? ( >=dev-haskell/diff-0.2 <dev-haskell/diff-0.5
+ >=dev-haskell/executable-path-0.0 <dev-haskell/executable-path-0.1
+ >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.14
+ >=dev-haskell/tasty-0.11 <dev-haskell/tasty-1.3
+ >=dev-haskell/tasty-golden-2.3 <dev-haskell/tasty-golden-2.4
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-lua-0.2 <dev-haskell/tasty-lua-0.3
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11 )
+"
+
+src_prepare() {
+ default
+ # optimisations require ~16GB of memory on ghc-8.8.3
+ use optimize || HCFLAGS+=' -O0'
+ cabal_chdeps \
+ 'haddock-library >= 1.8 && < 1.9' 'haddock-library >= 1.7'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag embed-data-files embed_data_files) \
+ $(cabal_flag static static) \
+ $(cabal_flag trypandoc trypandoc)
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ doman "${S}/man/${PN}.1"
+}