summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/paps/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/paps/files')
-rw-r--r--app-text/paps/files/paps-0.6.8-fix-as-needed-build.patch36
-rw-r--r--app-text/paps/files/paps-0.6.8-fix-doxygen-acinclude.patch20
-rw-r--r--app-text/paps/files/paps-0.6.8-fix-freetype-include.patch13
3 files changed, 69 insertions, 0 deletions
diff --git a/app-text/paps/files/paps-0.6.8-fix-as-needed-build.patch b/app-text/paps/files/paps-0.6.8-fix-as-needed-build.patch
new file mode 100644
index 000000000000..ec4ba8b2b180
--- /dev/null
+++ b/app-text/paps/files/paps-0.6.8-fix-as-needed-build.patch
@@ -0,0 +1,36 @@
+--- paps-0.6.8/configure.in
++++ paps-0.6.8/configure.in
+@@ -18,4 +18,6 @@
+
+ DX_INIT_DOXYGEN(libpaps, doxygen.cfg, doxygen-doc)
+
++PKG_CHECK_MODULES([PANGO], [pangoft2])
++
+ AC_OUTPUT(Makefile src/Makefile)
+--- paps-0.6.8/src/Makefile.am
++++ paps-0.6.8/src/Makefile.am
+@@ -7,21 +7,19 @@
+ bin_PROGRAMS = paps
+ paps_CFLAGS = -Wall
+ paps_SOURCES = paps.c
+-paps_LDADD = $(lib_LIBRARIES) $(all_libraries)
+-paps_LDFLAGS = `pkg-config --libs pangoft2`
++paps_LDADD = $(lib_LIBRARIES) $(all_libraries) $(PANGO_LIBS)
+ paps_DEPENDENCIES = $(lib_LIBRARIES)
+
+ EXTRA_DIST = test_libpaps.c paps.1
+
+ # set the include path found by configure
+-INCLUDES= $(all_includes) `pkg-config --cflags pangoft2`
++INCLUDES= $(all_includes) $(PANGO_CFLAGS)
+
+ # Test program
+ noinst_PROGRAMS = test_libpaps
+
+
+ test_libpaps_SOURCES = test_libpaps.c
+-test_libpaps_LDADD = $(lib_LIBRARIES) $(all_libraries)
+-test_libpaps_LDFLAGS = `pkg-config --libs pangoft2`
++test_libpaps_LDADD = $(lib_LIBRARIES) $(all_libraries) $(PANGO_LIBS)
+ test_libpaps_DEPENDENCIES = $(lib_LIBRARIES)
+
diff --git a/app-text/paps/files/paps-0.6.8-fix-doxygen-acinclude.patch b/app-text/paps/files/paps-0.6.8-fix-doxygen-acinclude.patch
new file mode 100644
index 000000000000..baba74b4b8bb
--- /dev/null
+++ b/app-text/paps/files/paps-0.6.8-fix-doxygen-acinclude.patch
@@ -0,0 +1,20 @@
+--- paps-0.6.8/acinclude.m4
++++ paps-0.6.8/acinclude.m4
+@@ -78,7 +78,7 @@
+ AC_PATH_TOOL([$1], [$2])
+ if test "$DX_FLAG_[]DX_CURRENT_FEATURE$$1" = 1; then
+ AC_MSG_WARN([$2 not found - will not DX_CURRENT_DESCRIPTION])
+- AC_SUBST([DX_FLAG_[]DX_CURRENT_FEATURE], 0)
++ AC_SUBST([DX_FLAG_]DX_CURRENT_FEATURE, 0)
+ fi
+ ])
+
+@@ -101,7 +101,7 @@
+ # ----------------------------------------------------------
+ # Turn off the DX_CURRENT_FEATURE if the required feature is off.
+ AC_DEFUN([DX_CLEAR_DEPEND], [
+-test "$DX_FLAG_$1" = "$2" || AC_SUBST([DX_FLAG_[]DX_CURRENT_FEATURE], 0)
++test "$DX_FLAG_$1" = "$2" || AC_SUBST([DX_FLAG_]DX_CURRENT_FEATURE, 0)
+ ])
+
+ # DX_FEATURE_ARG(FEATURE, DESCRIPTION,
diff --git a/app-text/paps/files/paps-0.6.8-fix-freetype-include.patch b/app-text/paps/files/paps-0.6.8-fix-freetype-include.patch
new file mode 100644
index 000000000000..30b456e77416
--- /dev/null
+++ b/app-text/paps/files/paps-0.6.8-fix-freetype-include.patch
@@ -0,0 +1,13 @@
+--- paps-0.6.8/src/libpaps.c
++++ paps-0.6.8/src/libpaps.c
+@@ -25,8 +25,8 @@
+
+ #include <pango/pango.h>
+ #include <pango/pangoft2.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
++#include <ftglyph.h>
++#include <ftoutln.h>
+ #include <errno.h>
+ #include <stdlib.h>
+ #include <stdio.h>