summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/peg-markdown
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/peg-markdown')
-rw-r--r--app-text/peg-markdown/Manifest1
-rw-r--r--app-text/peg-markdown/metadata.xml11
-rw-r--r--app-text/peg-markdown/peg-markdown-0.4.14.ebuild41
3 files changed, 53 insertions, 0 deletions
diff --git a/app-text/peg-markdown/Manifest b/app-text/peg-markdown/Manifest
new file mode 100644
index 000000000000..154203d2a687
--- /dev/null
+++ b/app-text/peg-markdown/Manifest
@@ -0,0 +1 @@
+DIST peg-markdown-0.4.14.tar.gz 85692 SHA256 111bc56058cfed11890af11bec7419e2f7ccec6b399bf05f8c55dae0a1712980 SHA512 38e43b548b2cedf04fae87baf91c9e0767914bdb617ee4b6a3cbe950f8cbb0717c457cafabcff606501e889ac196a0aef94317f3bf85f5b88a2285f686b6dd5e WHIRLPOOL ae799da2be4d5dde55d73fd841063a88242a6e6cddb1473cda847a32d53a3f75b100937df0b07b1a83bbf995ae9a125bda9ace19809318d56b7eb646aabd781b
diff --git a/app-text/peg-markdown/metadata.xml b/app-text/peg-markdown/metadata.xml
new file mode 100644
index 000000000000..bcf02e7f7440
--- /dev/null
+++ b/app-text/peg-markdown/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jgm/peg-markdown</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/peg-markdown/peg-markdown-0.4.14.ebuild b/app-text/peg-markdown/peg-markdown-0.4.14.ebuild
new file mode 100644
index 000000000000..c9f0478c7c35
--- /dev/null
+++ b/app-text/peg-markdown/peg-markdown-0.4.14.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Implementation of markdown in C, using a PEG grammar"
+HOMEPAGE="https://github.com/jgm/peg-markdown"
+SRC_URI="https://github.com/jgm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 MIT )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ dev-util/peg
+ test? (
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+ app-text/htmltidy )"
+
+src_prepare() {
+ rm -rf peg-* || die "rm failed"
+ sed -i \
+ -e 's/^PROGRAM=markdown/PROGRAM=peg-markdown/' \
+ -e 's/$(CC) `/$(CC) $(LDFLAGS) `/g' \
+ -e 's/^\t$(LEG)/\tleg/' \
+ -e 's/^$(PEGDIR):/dummy:/' \
+ -e '/$(PEGDIR)/d' \
+ -e 's/$(LEG) //g' \
+ Makefile || die 'sed failed'
+ sed -i \
+ -e '/strdup/d' markdown_peg.h || die 'sed .h failed'
+}
+
+src_install() {
+ dobin peg-markdown
+ dodoc README.markdown
+}