summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/scrollkeeper-dtd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/scrollkeeper-dtd')
-rw-r--r--app-text/scrollkeeper-dtd/Manifest1
-rw-r--r--app-text/scrollkeeper-dtd/metadata.xml6
-rw-r--r--app-text/scrollkeeper-dtd/scrollkeeper-dtd-1.0.ebuild56
3 files changed, 63 insertions, 0 deletions
diff --git a/app-text/scrollkeeper-dtd/Manifest b/app-text/scrollkeeper-dtd/Manifest
new file mode 100644
index 000000000000..6c5d6bc1813e
--- /dev/null
+++ b/app-text/scrollkeeper-dtd/Manifest
@@ -0,0 +1 @@
+DIST scrollkeeper-omf.dtd 11031 SHA256 43df758009b17f8487419ef1fe3039379370417385885a2578e1789ab092ae26 SHA512 edb38d85352d0ed4a4fd1eea108cd88696d2f0759bc4402d4b7f85aa56b5647ca5a518de14deb3a429344ede474d42a64b90100e5d3c772ae6e5e47a47d86ff0 WHIRLPOOL a99c168e3645c2f7bf497d3e38ff3b98b5334246d87cbb3d12e9b15e72e7ea420db60ff553c49d45f5a380cd8a0a813269e08af20767f365bbaa9796b392d5eb
diff --git a/app-text/scrollkeeper-dtd/metadata.xml b/app-text/scrollkeeper-dtd/metadata.xml
new file mode 100644
index 000000000000..48a8d9232864
--- /dev/null
+++ b/app-text/scrollkeeper-dtd/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+</pkgmetadata>
+
diff --git a/app-text/scrollkeeper-dtd/scrollkeeper-dtd-1.0.ebuild b/app-text/scrollkeeper-dtd/scrollkeeper-dtd-1.0.ebuild
new file mode 100644
index 000000000000..f4599fdff214
--- /dev/null
+++ b/app-text/scrollkeeper-dtd/scrollkeeper-dtd-1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+DTD_FILE="scrollkeeper-omf.dtd"
+
+DESCRIPTION="DTD from the Scrollkeeper package"
+HOMEPAGE="http://scrollkeeper.sourceforge.net/"
+SRC_URI="http://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0/${DTD_FILE}"
+
+LICENSE="FDL-1.1"
+SLOT="1.0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.4.19"
+DEPEND="${RDEPEND}
+ !<app-text/scrollkeeper-9999-r1"
+
+src_unpack() { :; }
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/xml/scrollkeeper/dtds
+ doins "${DISTDIR}/${DTD_FILE}"
+}
+
+pkg_postinst() {
+ einfo "Installing catalog..."
+
+ # Install regular DOCTYPE catalog entry
+ "${EROOT}"usr/bin/xmlcatalog --noout --add "public" \
+ "-//OMF//DTD Scrollkeeper OMF Variant V1.0//EN" \
+ "${EROOT}"usr/share/xml/scrollkeeper/dtds/${DTD_FILE} \
+ "${EROOT}"etc/xml/catalog
+
+ # Install catalog entry for calls like: xmllint --dtdvalid URL ...
+ "${EROOT}"usr/bin/xmlcatalog --noout --add "system" \
+ "${SRC_URI}" \
+ "${EROOT}"usr/share/xml/scrollkeeper/dtds/${DTD_FILE} \
+ "${EROOT}"etc/xml/catalog
+}
+
+pkg_postrm() {
+ # Remove all sk-dtd from the cache
+ einfo "Cleaning catalog..."
+
+ "${EROOT}"usr/bin/xmlcatalog --noout --del \
+ "${EROOT}"usr/share/xml/scrollkeeper/dtds/${DTD_FILE} \
+ "${EROOT}"etc/xml/catalog
+}