summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/trang
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/trang')
-rw-r--r--app-text/trang/Manifest1
-rw-r--r--app-text/trang/files/build.xml68
-rw-r--r--app-text/trang/files/test.xml87
-rw-r--r--app-text/trang/metadata.xml8
-rw-r--r--app-text/trang/trang-20091111-r1.ebuild61
-rw-r--r--app-text/trang/trang-20091111.ebuild65
6 files changed, 290 insertions, 0 deletions
diff --git a/app-text/trang/Manifest b/app-text/trang/Manifest
new file mode 100644
index 000000000000..010b2099dfbf
--- /dev/null
+++ b/app-text/trang/Manifest
@@ -0,0 +1 @@
+DIST trang-20091111.zip 1079534 SHA256 d8a3f034f9918ebe5b265aafeadbee6729ddda5732cfc368e2c30b3b8c0ca598 SHA512 c19bf98613097d377ecce347dcab31b458b16d77c320b5d2a6106ff7b06b3aa3c7b87b4c78376b3d4f89be24ecb11fad622aadc0ba9d8d6be716486d7a1ebd7b WHIRLPOOL 6ed18632dfdb7c9661fcb6e1b3a02130ac877fdda3c4cc7779ec61510a7e67e68ab7315ab6f3e5cb8ed2a83447873579791c568f7706eaab29f5e2258fa5bc3b
diff --git a/app-text/trang/files/build.xml b/app-text/trang/files/build.xml
new file mode 100644
index 000000000000..104cabd267a4
--- /dev/null
+++ b/app-text/trang/files/build.xml
@@ -0,0 +1,68 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!-- Author: Ralph Sennhauser -->
+<project name="trang" default="jar" basedir=".">
+
+ <!-- properties -->
+
+ <property name="src.dir" value="src"/>
+ <property name="build.dir" value="build"/>
+ <property name="docs.dir" value="javadoc"/>
+ <property name="dist.dir" value="dist"/>
+
+ <property name="app.name" value="trang"/>
+ <property name="package.names" value="com.* org.*"/>
+ <property name="jar.name" value="${app.name}.jar"/>
+
+ <!-- targets -->
+
+ <target name="prepare">
+ <mkdir dir="${build.dir}"/>
+ <mkdir dir="${docs.dir}"/>
+ <mkdir dir="${dist.dir}"/>
+ <unzip src="${src.dir}.zip" dest="${src.dir}"/>
+ <!-- need the resource files shipped inside the jar, beed! -->
+ <unzip src="trang.jar" dest="${build.dir}">
+ <patternset>
+ <include name="**/*properties"/>
+ </patternset>
+ </unzip>
+ </target>
+
+ <target name="compile" description="Compiles source" depends="prepare">
+ <javac srcdir="${src.dir}" destdir="${build.dir}" encoding="UTF-8" classpath="${gentoo.classpath}">
+<!-- <compilerarg value="-Xlint:deprecation"/> -->
+<!-- <compilerarg value="-Xlint"/> -->
+ </javac>
+ </target>
+
+ <target name="javadoc" depends="prepare" description="Create javadocs">
+ <javadoc packagenames="net.*"
+ classpath="${gentoo.classpath}"
+ sourcepath="${src.dir}"
+ defaultexcludes="yes"
+ destdir="./${docs.dir}"
+ author="true"
+ version="true"
+ use="true"
+ windowtitle="${app.name} API">
+ <fileset dir="${src.dir}"/>
+ </javadoc>
+ </target>
+
+ <target name="jar" description="Create the jar" depends="compile">
+ <jar destfile="${dist.dir}/${jar.name}" basedir="${build.dir}">
+ <manifest>
+ <attribute name="Main-Class" value="com.thaiopensource.relaxng.translate.Driver"/>
+ <attribute name="Class-Path" value="."/>
+ </manifest>
+ <service type="com.thaiopensource.datatype.xsd.regex.RegexEngine">
+ <provider classname="com.thaiopensource.datatype.xsd.regex.java.RegexEngineImpl"/>
+ <provider classname="com.thaiopensource.datatype.xsd.regex.xerces2.RegexEngineImpl"/>
+ </service>
+ <service type="org.relaxng.datatype.DatatypeLibraryFactory">
+ <provider classname="com.thaiopensource.datatype.xsd.DatatypeLibraryFactoryImpl"/>
+ </service>
+ </jar>
+ </target>
+
+</project>
diff --git a/app-text/trang/files/test.xml b/app-text/trang/files/test.xml
new file mode 100644
index 000000000000..747972587821
--- /dev/null
+++ b/app-text/trang/files/test.xml
@@ -0,0 +1,87 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!--
+Copyright (C) 2001-2004 Bart Massey, Jamey Sharp, and Josh Triplett.
+All Rights Reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
+ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+Except as contained in this notice, the names of the authors or their
+institutions shall not be used in advertising or otherwise to promote the
+sale, use or other dealings in this Software without prior written
+authorization from the authors.
+-->
+<xcb header="dpms" extension-xname="DPMS" extension-name="DPMS"
+ major-version="0" minor-version="0">
+ <request name="GetVersion" opcode="0">
+ <field type="CARD16" name="client_major_version" />
+ <field type="CARD16" name="client_minor_version" />
+ <reply>
+ <pad bytes="1" />
+ <field type="CARD16" name="server_major_version" />
+ <field type="CARD16" name="server_minor_version" />
+ </reply>
+ </request>
+
+ <request name="Capable" opcode="1">
+ <reply>
+ <pad bytes="1" />
+ <field type="BOOL" name="capable" />
+ <pad bytes="23" />
+ </reply>
+ </request>
+
+ <request name="GetTimeouts" opcode="2">
+ <reply>
+ <pad bytes="1" />
+ <field type="CARD16" name="standby_timeout" />
+ <field type="CARD16" name="suspend_timeout" />
+ <field type="CARD16" name="off_timeout" />
+ <pad bytes="18" />
+ </reply>
+ </request>
+
+ <request name="SetTimeouts" opcode="3">
+ <field type="CARD16" name="standby_timeout" />
+ <field type="CARD16" name="suspend_timeout" />
+ <field type="CARD16" name="off_timeout" />
+ </request>
+
+ <request name="Enable" opcode="4" />
+
+ <request name="Disable" opcode="5" />
+
+ <enum name="DPMSMode">
+ <item name="On" />
+ <item name="Standby" />
+ <item name="Suspend" />
+ <item name="Off" />
+ </enum>
+
+ <request name="ForceLevel" opcode="6">
+ <field type="CARD16" name="power_level" enum="DPMSMode" />
+ </request>
+
+ <request name="Info" opcode="7">
+ <reply>
+ <pad bytes="1" />
+ <field type="CARD16" name="power_level" enum="DPMSMode" />
+ <field type="BOOL" name="state" />
+ <pad bytes="21" />
+ </reply>
+ </request>
+</xcb> \ No newline at end of file
diff --git a/app-text/trang/metadata.xml b/app-text/trang/metadata.xml
new file mode 100644
index 000000000000..8c6a042450d3
--- /dev/null
+++ b/app-text/trang/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="google-code">jing-trang</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/trang/trang-20091111-r1.ebuild b/app-text/trang/trang-20091111-r1.ebuild
new file mode 100644
index 000000000000..fcc80852348f
--- /dev/null
+++ b/app-text/trang/trang-20091111-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Multi-format schema converter based on RELAX NG"
+HOMEPAGE="http://thaiopensource.com/relaxng/trang.html"
+SRC_URI="http://jing-trang.googlecode.com/files/${P}.zip"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/xerces:2
+ dev-java/xml-commons-resolver:0"
+
+RDEPEND="
+ >=virtual/jre-1.6
+ ${COMMON_DEP}"
+
+DEPEND="
+ app-arch/unzip
+ >=virtual/jdk-1.6
+ ${COMMON_DEP}"
+
+java_prepare() {
+ # need resource files in jar archive so can't remove, see build.xml
+ # rm -v *.jar || die "Failed to remove jar archives"
+ cp "${FILESDIR}/build.xml" "${S}/build.xml" || die
+}
+
+EANT_GENTOO_CLASSPATH="xerces-2,xml-commons-resolver"
+
+src_test() {
+ java -jar "dist/${PN}.jar" "${FILESDIR}/test.xml" "test/test.xsd"
+ java -jar "dist/${PN}.jar" "${FILESDIR}/test.xml" "test/test.dtd"
+ java -jar "dist/${PN}.jar" "test/test.dtd" "test/test.dtd.xsd"
+
+ md5sum -c <<MD5SUMS_END || die "Failed to verify md5sum"
+4bcb454ade46c0188f809d2e8ce15315 "${FILESDIR}"/test.xml
+d096c1fb462902e10a3440a604a21664 test/test.xsd
+3fb46bdb16dc75a2a1e36e421b13e51d test/test.dtd
+fce355ca962cb063d7baa5d7fd571bcf test/test.dtd.xsd
+MD5SUMS_END
+}
+
+src_install() {
+ java-pkg_dojar "dist/${PN}.jar"
+ java-pkg_dolauncher trang \
+ --main com.thaiopensource.relaxng.translate.Driver
+ dohtml *.html || die
+
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/{org,com}
+}
diff --git a/app-text/trang/trang-20091111.ebuild b/app-text/trang/trang-20091111.ebuild
new file mode 100644
index 000000000000..d2f55b7db61d
--- /dev/null
+++ b/app-text/trang/trang-20091111.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Multi-format schema converter based on RELAX NG"
+HOMEPAGE="http://thaiopensource.com/relaxng/trang.html"
+SRC_URI="http://jing-trang.googlecode.com/files/${P}.zip"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/xerces:2
+ dev-java/xml-commons-resolver:0"
+
+RDEPEND="
+ >=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+DEPEND="
+ app-arch/unzip
+ >=virtual/jdk-1.5
+ ${COMMON_DEP}"
+
+java_prepare() {
+ # need resource files in jar archive so can't remove, see build.xml
+ # rm -v *.jar || die "Failed to remove jar archives"
+
+ cp "${FILESDIR}/build.xml" "${S}/build.xml"
+}
+
+EANT_GENTOO_CLASSPATH="xerces-2,xml-commons-resolver"
+
+src_test() {
+ # a very simple test
+ mkdir "test"
+
+ java -jar "dist/${PN}.jar" "${FILESDIR}/test.xml" "test/test.xsd"
+ java -jar "dist/${PN}.jar" "${FILESDIR}/test.xml" "test/test.dtd"
+ java -jar "dist/${PN}.jar" "test/test.dtd" "test/test.dtd.xsd"
+
+ md5sum -c <<MD5SUMS_END || die "Failed to verify md5sum"
+4bcb454ade46c0188f809d2e8ce15315 ${FILESDIR}/test.xml
+d096c1fb462902e10a3440a604a21664 test/test.xsd
+3fb46bdb16dc75a2a1e36e421b13e51d test/test.dtd
+fce355ca962cb063d7baa5d7fd571bcf test/test.dtd.xsd
+MD5SUMS_END
+}
+
+src_install() {
+ java-pkg_dojar "dist/${PN}.jar"
+ java-pkg_dolauncher trang \
+ --main com.thaiopensource.relaxng.translate.Driver
+ dohtml *.html || die
+
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/{org,com}
+}