summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/wscr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/wscr')
-rw-r--r--app-text/wscr/Manifest1
-rw-r--r--app-text/wscr/metadata.xml10
-rw-r--r--app-text/wscr/wscr-1.2-r1.ebuild30
3 files changed, 41 insertions, 0 deletions
diff --git a/app-text/wscr/Manifest b/app-text/wscr/Manifest
new file mode 100644
index 000000000000..c323964b4895
--- /dev/null
+++ b/app-text/wscr/Manifest
@@ -0,0 +1 @@
+DIST wscr-1.2.tar.gz 3502 SHA256 00b69d95cbd5c4e0f6fe63c991d5b01bc8cdbd3b03c7faa1fa93738fc091d49b SHA512 8a26c7fb190f830f6436240fc00dcf61405b1818ff311999e02c64b3506fa6abf13a6f212dbb9b15794ecae4f122def563f9301eebdd7e8d09f22cd647467ee3 WHIRLPOOL 2fbe0796373ac373887e2a00c079fba0e7110ec346d80000e5dd34ea92f9c571cf09f45e02b075dcd5cbc50fce80ef2bb7422cd41000325ad731341596ead2e4
diff --git a/app-text/wscr/metadata.xml b/app-text/wscr/metadata.xml
new file mode 100644
index 000000000000..8ee40597ee2e
--- /dev/null
+++ b/app-text/wscr/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>jer@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">WSCR is a program to solve word jumbles, print all
+permutations of a string, and print pseudo-anagrams. It will use /usr/dict/words
+or a user-specified wordlist file</longdescription>
+</pkgmetadata>
diff --git a/app-text/wscr/wscr-1.2-r1.ebuild b/app-text/wscr/wscr-1.2-r1.ebuild
new file mode 100644
index 000000000000..8ba24062d0df
--- /dev/null
+++ b/app-text/wscr/wscr-1.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="A Lightweight and Fast Anagram Solver"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~jer/${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+
+KEYWORDS="amd64 ~mips ppc x86"
+IUSE=""
+RDEPEND="sys-apps/miscfiles"
+
+src_prepare() {
+ sed -i 's#"/usr/dict/words";#"/usr/share/dict/words";#' wscr.h || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" FLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin wscr
+ doman wscr.6
+ dodoc README
+}