summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-07-28 14:18:43 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-04 10:17:44 +0300
commit17a390643654410d20262cec3446dcf38495dfa0 (patch)
treeb5acbbc69bb5c02e23b5e6660e35ee0ac5b68a77 /app-text
parentnet-firewall/arno-iptables-firewall: add 2.1.2a (diff)
downloadgentoo-17a390643654410d20262cec3446dcf38495dfa0.tar.gz
gentoo-17a390643654410d20262cec3446dcf38495dfa0.tar.bz2
gentoo-17a390643654410d20262cec3446dcf38495dfa0.zip
app-text/htmlrecode: bump EAPI, fix QA issues
Signed-off-by: Filip Kobierski <fkobi@pm.me> Closes: https://github.com/gentoo/gentoo/pull/37761 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/htmlrecode/htmlrecode-1.3.1-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/htmlrecode/htmlrecode-1.3.1-r2.ebuild b/app-text/htmlrecode/htmlrecode-1.3.1-r2.ebuild
new file mode 100644
index 000000000000..36dd29809cda
--- /dev/null
+++ b/app-text/htmlrecode/htmlrecode-1.3.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Recodes HTML file using a new character set"
+HOMEPAGE="https://bisqwit.iki.fi/source/htmlrecode.html"
+SRC_URI="https://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=( "${FILESDIR}/${P}-ar.patch" )
+
+src_prepare() {
+ touch .depend argh/.depend || die
+ default
+}
+
+src_configure() { :; }
+
+src_compile() {
+ local makeopts=(
+ AR="$(tc-getAR)"
+ CPPDEBUG=
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+ emake "${makeopts[@]}" -C argh libargh.a
+ emake "${makeopts[@]}" htmlrecode
+}
+
+src_install() {
+ dobin htmlrecode
+ dodoc README.html
+}