summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2016-04-30 04:04:08 +0200
committerRafael Martins <rafaelmartins@gentoo.org>2016-04-30 04:04:08 +0200
commit5a92d76ca34b4da290828a39ef7997ec0cb2e25e (patch)
tree0521656bcd1d2b750cabc67c95fbb9e89c89ada8 /app-text
parentprofiles: mask blogc helper tools (diff)
downloadgentoo-5a92d76ca34b4da290828a39ef7997ec0cb2e25e.tar.gz
gentoo-5a92d76ca34b4da290828a39ef7997ec0cb2e25e.tar.bz2
gentoo-5a92d76ca34b4da290828a39ef7997ec0cb2e25e.zip
app-text/blogc: version bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text')
-rw-r--r--app-text/blogc/Manifest2
-rw-r--r--app-text/blogc/blogc-0.9.0.ebuild (renamed from app-text/blogc/blogc-0.8.1.ebuild)28
2 files changed, 19 insertions, 11 deletions
diff --git a/app-text/blogc/Manifest b/app-text/blogc/Manifest
index 9f7cc02a5589..b0c57ee0906b 100644
--- a/app-text/blogc/Manifest
+++ b/app-text/blogc/Manifest
@@ -1 +1 @@
-DIST blogc-0.8.1.tar.xz 270704 SHA256 06b9367ff6992a0aac447d74b1df13c35f58f7ac06ee331260462ce3a402864f SHA512 2a8f00401a3f119532dfadde5bf62f455ea229fab75ca5219493aec7cc502a29e62226e88a663441f317b065053284dd78303bd8c423aff5d46cff20c3a2c6d7 WHIRLPOOL f68aa583780d7b4a1b7dc97c9bf617792780322fc766bfa2bc45f74965e1f98a7d7161bd2175b0d68c2564e3914e24513db603b7dd0f0e99979cb816cd4a0ac8
+DIST blogc-0.9.0.tar.xz 265340 SHA256 e5d21deb3793e5863c32c87bd51522cde7749b144a486ab37c5be007d3b3e968 SHA512 3068f8b666b87d168a0cf893d4c913461bb403588fef0cd4d53d006c3c0e880592c71d5e4f6d622c930b05b67b1ad77b53af18cba5c183fc3357d97b8af27f39 WHIRLPOOL 1932625f1330391a5e403bd65183c02106b446743c5fa61a7e552c35c511f18a9dff548c932e401c6c62e6bed2f78ce48efe5cf7a38bb7e679b9fc9ceb68c3cd
diff --git a/app-text/blogc/blogc-0.8.1.ebuild b/app-text/blogc/blogc-0.9.0.ebuild
index 4a8d832ace1e..538dbb319bbd 100644
--- a/app-text/blogc/blogc-0.8.1.ebuild
+++ b/app-text/blogc/blogc-0.9.0.ebuild
@@ -12,32 +12,39 @@ if [[ ${PV} = *9999* ]]; then
fi
DESCRIPTION="A blog compiler"
-HOMEPAGE="http://blogc.org/"
+HOMEPAGE="https://blogc.rgm.io/"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
if [[ ${PV} = *9999* ]]; then
SRC_URI=""
KEYWORDS=""
- RDEPEND="=dev-libs/squareball-9999"
- DEPEND="${RDEPEND}
- app-text/ronn"
-else
- RDEPEND=">=dev-libs/squareball-0.2.0"
- DEPEND="${RDEPEND}"
+ DEPEND="app-text/ronn"
fi
LICENSE="BSD"
SLOT="0"
-IUSE="test"
+IUSE="git httpd test"
+
+CDEPEND="
+ httpd? (
+ dev-libs/libevent
+ sys-apps/file )"
+
+RDEPEND="${CDEPEND}
+ git? (
+ dev-vcs/git )
+ !dev-vcs/blogc-git-receiver
+ !www-servers/blogc-runserver"
DEPEND="${DEPEND}
+ ${CDEPEND}
virtual/pkgconfig
test? (
dev-util/cmocka )"
src_prepare() {
- [[ ${PV} = *9999* ]] && AT_NO_RECURSIVE=1 eautoreconf
+ [[ ${PV} = *9999* ]] && eautoreconf
eapply_user
default
}
@@ -51,7 +58,8 @@ src_configure() {
fi
econf \
$(use_enable test tests) \
+ $(use_enable git git-receiver) \
+ $(use_enable httpd runserver) \
--disable-valgrind \
- --with-squareball=system \
${myconf}
}