summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-07-02 16:47:00 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-07-02 16:49:11 +0700
commit791f6b69720e9d2da7f94b170a3e0ad1f3c71ce0 (patch)
tree10ddfd491ea106b47eacd8b67a66dffbfce5fa87 /app-text
parentapp-shells/fzf: Stabilize 0.52.1 arm64, #935315 (diff)
downloadgentoo-791f6b69720e9d2da7f94b170a3e0ad1f3c71ce0.tar.gz
gentoo-791f6b69720e9d2da7f94b170a3e0ad1f3c71ce0.tar.bz2
gentoo-791f6b69720e9d2da7f94b170a3e0ad1f3c71ce0.zip
app-text/pdfarranger: bump to 1.11.0
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pdfarranger/Manifest1
-rw-r--r--app-text/pdfarranger/pdfarranger-1.11.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-text/pdfarranger/Manifest b/app-text/pdfarranger/Manifest
index 635713743a4f..538383722d4a 100644
--- a/app-text/pdfarranger/Manifest
+++ b/app-text/pdfarranger/Manifest
@@ -1,2 +1,3 @@
DIST pdfarranger-1.10.0.tar.gz 303125 BLAKE2B 126b47dfdabbe6d75331788dd891e1d8136a70b98e70601e19fd47fc7e3d81c350eb1fc8866a3a09db88b2b760ef964e7a01cf233464440c81a6dc5462101592 SHA512 92aa53a402d2f4c82a7f99f2acc1c328f71ad18835e524588e0f011f3ba8b074bf425ed881bb5f9ce3020833ce37cc3c301fd90b8931b44f909c8647bc1b09af
DIST pdfarranger-1.10.1.tar.gz 304298 BLAKE2B 9762864072d4d75cf7e4a65f9ec9db040eef53ee97b2867340bc427d350f4b9b9fbc321520bf2e47d1c2ab2c866c8ceaf56b9806378bcdff4897ebc7f6c1e2ee SHA512 a0bebb569570656217e4f9432c0a3fbdb7f441b7ee04dc82f31e449befec19a1fa1045ef7ce95dc75e9feb14fad9a0265307efdf221c8a727091c05348554427
+DIST pdfarranger-1.11.0.tar.gz 450491 BLAKE2B a34323e2491412bd192ee49106008388170452fa2ff150c56a03573a18582e65457e213db2e0f33b909b6e442acd30f397a3167d560555f2d9b70a2b0daca985 SHA512 b5eb91ea0157453928e908fb13857929364d3cb0fa6872c1a2c2a60f654bebdeaf88da483071e52727dc1943f972fa78e919e4b46a63a131795018c125dfee48
diff --git a/app-text/pdfarranger/pdfarranger-1.11.0.ebuild b/app-text/pdfarranger/pdfarranger-1.11.0.ebuild
new file mode 100644
index 000000000000..5bb0d5ee7a7a
--- /dev/null
+++ b/app-text/pdfarranger/pdfarranger-1.11.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1 optfeature xdg desktop
+
+DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages"
+HOMEPAGE="https://github.com/jeromerobert/pdfarranger"
+SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/poppler[introspection,cairo]
+ dev-python/pikepdf[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},lcms]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ for x in 16 32 48 256 scalable
+ do doicon -s ${x} data/icons/hicolor/${x}*/*
+ done
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "image file import" media-gfx/img2pdf
+}