summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYury Martynov <email@linxon.ru>2019-11-19 14:45:12 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-11-20 08:03:25 +0200
commit9c5073a7607d859022ce465370c77407f839a7e9 (patch)
tree569f9506393e8db78631bcf791d289e6ba14d298 /app-text
parentmedia-sound/teamspeak-server: drop old version (diff)
downloadgentoo-9c5073a7607d859022ce465370c77407f839a7e9.tar.gz
gentoo-9c5073a7607d859022ce465370c77407f839a7e9.tar.bz2
gentoo-9c5073a7607d859022ce465370c77407f839a7e9.zip
app-text/cherrytree: 0.37.0 EAPI bump and other minor changes
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Yury Martynov <email@linxon.ru> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/cherrytree/cherrytree-0.37.0-r1.ebuild52
-rw-r--r--app-text/cherrytree/cherrytree-0.37.0.ebuild55
2 files changed, 52 insertions, 55 deletions
diff --git a/app-text/cherrytree/cherrytree-0.37.0-r1.ebuild b/app-text/cherrytree/cherrytree-0.37.0-r1.ebuild
new file mode 100644
index 000000000000..b7c0b37e37f2
--- /dev/null
+++ b/app-text/cherrytree/cherrytree-0.37.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A hierarchical note taking application"
+HOMEPAGE="https://www.giuspen.com/cherrytree"
+SRC_URI="https://github.com/giuspen/cherrytree/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="nls"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/pygtksourceview:2[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+python_prepare_all() {
+ sed -r -i \
+ -e '/\bupdate-desktop-database\b/d' \
+ setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ use nls || mydistutilsargs+=( --without-gettext )
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
diff --git a/app-text/cherrytree/cherrytree-0.37.0.ebuild b/app-text/cherrytree/cherrytree-0.37.0.ebuild
deleted file mode 100644
index 70d1db48a137..000000000000
--- a/app-text/cherrytree/cherrytree-0.37.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite"
-DISTUTILS_SINGLE_IMPL=true
-
-inherit xdg distutils-r1
-
-DESCRIPTION="A hierarchical note taking application"
-HOMEPAGE="https://www.giuspen.com/cherrytree"
-LICENSE="GPL-3"
-
-SLOT="0"
-SRC_URI="https://github.com/giuspen/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="nls"
-
-RDEPEND="
- x11-libs/libX11
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pyenchant[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2.16:2[${PYTHON_USEDEP}]
- dev-python/pygtksourceview:2[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
-"
-
-PLOCALES="cs de es fr hy it ja lt nl pl pt_BR ru sl tr uk zh_CN"
-inherit l10n
-
-python_prepare_all() {
- xdg_src_prepare
-
- if use nls ; then
- l10n_find_plocales_changes 'locale' '' '.po'
-
- rm_loc() {
- rm -v -f "locale/${1}.po" || return 1
- }
- l10n_for_each_disabled_locale_do rm_loc
- fi
-
- sed -r -e '/\bupdate-desktop-database\b/d' -i -- 'setup.py' || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- use nls || mydistutilsargs+=( --without-gettext )
-}